Bug 283858

Summary: KMyMoney v4.6.0 (Windows) Help error "requested help file could not be parsed".
Product: kde-windows Reporter: kdemeoz <kdemeoz>
Component: installerAssignee: KMyMoney Devel Mailing List <kmymoney-devel>
Status: RESOLVED FIXED    
Severity: normal CC: geraldkane, jf150552, kdemeoz, lueck, onet.cristian, ps_ml, ralf.habacker, stephane, vinayakgarg2.0, yurchor
Priority: NOR    
Version: 4.10   
Target Milestone: ---   
Platform: Microsoft Windows   
OS: Microsoft Windows   
Latest Commit: Version Fixed In:
Sentry Crash Report:
Attachments: package file list of kmymoney 4.6.0 binary package

Description kdemeoz 2011-10-12 13:23:50 UTC
Version:           4.6.0 (using KDE 4.7.0) 
OS:                MS Windows


I have Win7 64-bit OS, & used kdewin-installer-gui-latest.exe to download & install Windows version 4.6.0 of KMyMoney. Now i can launch KMM from the Start icon, & it opens ok... but its Help will not run [error = "The requested help file could not be parsed:<br/>c:/programdata/kde/share/doc/html/en//kmymoney/index.docbook"].

I need to import my GnuCash data to KMM, but found this other error; "Cannot load file <<filename>> Reason: No storage object attached to MyMoneyFile". 

I reported both these errors at  http://forum.kde.org/viewtopic.php?f=69&t=97254&p=205172#p205172 , where cristian.onet, KDE Developer at KDE Community Forums, KMyMoney sub-Forum, gave me this advice re the Help fault; "file a bug report at bugs.kde.org but file the bug under kde-windows since this a Windows packaging problem not a KMyMoney one"... hence i am now posting here. [He also told me that the GnuCash import error is fixed in v4.6.1, btw].

i am a novice with KDE & KMM. Therefore i cannot guarantee that i did not maybe do something wrong when i last ran the KDE for Windows Installer [by which i installed KMM]. However i made sure that i selected anything that seemed to have "KMyManager" in its package name or notes... so i had imagined that all necessary documentation thus would come with the app itself. I have just re-run it now to double-check if i missed something separate for KMM Help... but there's nothing like that listed as a separate package.

Is this Help error a bug? Is a solution known / scheduled pls?

Reproducible: Always

Steps to Reproduce:
1. Download & install KMM 4.6.0 in Win7 x64 via the KDE for Windows Installer KDE Installer 0.9.9-1.
2. Launch KMM from Win7's Start - Programs.
3. In KMM, Home screen, click link "Learn how to use KMyMoney", OR go to menu bar's Help - KMyMoney Handbook.
4. Either of these launch KDE Help Center, Version 4.7.00 (4.7.0), Using KDE Development Platform 4.7.00 (4.7.0)
5. Its main pane displays this msg; "The requested help file could not be parsed:<br/>c:/programdata/kde/share/doc/html/en//kmymoney/index.docbook".

Actual Results:  
KDE Help Center main pane displays this msg; "The requested help file could not be parsed:<br/>c:/programdata/kde/share/doc/html/en//kmymoney/index.docbook".

Expected Results:  
Presumably the actual Help doc should have appeared. 

Ta, Steffie.
Comment 1 kdemeoz 2011-10-12 13:29:32 UTC
I'm sorry, just after submitting this bug i realised that i've entered it under Product "kmymoney4", but Cristian had advised me to enter it under product "kde-windows". Oops! Can it be reclassified pls?
Steffie [sorry].
Comment 2 Cristian Oneț 2011-10-12 14:03:23 UTC
I've changed the product to kde-windows.
Comment 3 Ralf Habacker 2011-10-13 06:08:48 UTC
Created attachment 64474 [details]
package file list of kmymoney 4.6.0 binary package

This is no packaging issue. The installed file list shows all the required docbook files
Comment 4 Ralf Habacker 2011-10-13 06:52:57 UTC
A similar bug report http://forum.kde.org/viewtopic.php?f=22&t=93029 suggests to check if the related docbook files has been installed. 

The <install-root>/manifest dir should show the installed docbook package 

11.10.2011  15:58             2.851 docbook-dtd-4.2-bin.mft
11.10.2011  15:58                54 docbook-dtd-4.2-bin.ver
11.10.2011  15:58           144.846 docbook-xsl-1.75.2-bin.mft
11.10.2011  15:58                60 docbook-xsl-1.75.2-bin.ver

If you can run khelpcenter it should be installed correctly.
Comment 5 Cristian Oneț 2011-10-13 06:55:03 UTC
Until this is fixed the manual is also available online at
http://kmymoney2.sourceforge.net/kde4/online-manual
Comment 6 Burkhard Lück 2011-10-13 07:24:09 UTC
There is another report with a similar problem:
https://bugs.kde.org/show_bug.cgi?id=280108
Comment 7 kdemeoz 2011-10-15 04:19:38 UTC
Thank you to all who've replied.

I'm afraid though from reading all the replies, i'm having trouble understanding if the concensus is that this IS a fault, or conversely that all's well & that it is my error. Pls can you clarify for me?

Ta,
Steffie.
Comment 8 Ralf Habacker 2011-10-16 09:04:51 UTC
The writings are hints what happens in the background. 

The behavior you described is not normal and is caused by a software problem because of a crashed background process of khelpcenter named kio_help (it crashed at kio_help!xsltprocExternalEntityLoader+0x22). 


For a short solution of this you have several options: 

1. Use the online help as suggested
2. Wait for the next release in which this bug will hopefully be fixed 

Additional there are options to fix the bug by yourself or to convince or pay someone else to fix the bug.
Comment 9 kdemeoz 2011-11-27 12:27:42 UTC
(In reply to comment #8)

"> 2. Wait for the next release in which this bug will hopefully be fixed "
> 

--> Thanks Ralf. Any idea when the next version will be available pls?
Steffie.
Comment 10 Ralf Habacker 2011-11-28 06:21:07 UTC
Building of KDE 4.7.3 release has been started - see http://mail.kde.org/pipermail/kde-windows/2011-November/006230.html for more informations 

While the win32 base packages are already fine (http://www.winkde.org/pub/kde/ports/win32/dashboard/win32libs/) there are build problems with kde related packages http://www.winkde.org/pub/kde/ports/win32/dashboard/release/, which prevents releasing.
Comment 11 kdemeoz 2011-11-28 12:07:53 UTC
(In reply to comment #10)

Thanks Ralf. I guess i'll just keep on checking back in every couple of months to see when it's all ok.

Steffie.
Comment 12 Vinayak Garg 2011-12-30 08:49:11 UTC
I am using KDE 4.7.4 (latest) on windows. When i launched Handbook inside KTurtle, i get this error "The requested help file could not be parsed:<br/>e:/programs/kde/share/doc/html/en//kturtle/index.docbook"
This is related to this bug. 

Please look into it. And tell me how can i resolve this bug, as a user or as a developer (I am new to KDE but old to C++ etc. and would love to contribute)
Comment 13 Ralf Habacker 2011-12-30 22:21:15 UTC
Git commit f42984dc640d0cee6237819c7d6a2ffbdc68b6f7 by Ralf Habacker.
Committed on 30/12/2011 at 23:19.
Pushed by habacker into branch 'KDE/4.7'.

crash fix on windows

transform() is called recursive, which sets xsltprocExternalEntityLoader()
as default external entity handler. The default handler is called in
xsltprocExternalEntityLoader(), which calls itself until kioslave crashes
on stack overflow.

The bug is fixed by only setting the default handler on the first call.

M  +6    -4    kdoctools/xslt.cpp

http://commits.kde.org/kdelibs/f42984dc640d0cee6237819c7d6a2ffbdc68b6f7
Comment 14 Ralf Habacker 2011-12-30 22:51:10 UTC
> Please look into it. 

I digged into this stuff and recognized that there is a recursice call problem in kio_help.dll. I committed a related patch 

to the 4.7 and 4.8 branch - see https://projects.kde.org/projects/kde/kdelibs/repository/revisions/f42984dc640d0cee6237819c7d6a2ffbdc68b6f7

Now the people working on the 4.7.4 release need to be informed that an updated binary kdelibs package is required. 

> And tell me how can i resolve this bug, as a user or as a developer 
> (I am new to KDE but old to C++ etc. and would love to contribute)

I you like to work on KDE see http://techbase.kde.org/Windows as a starting point.
Comment 15 kdemeoz 2012-01-01 02:24:45 UTC
Hi Ralf. You said "Now the people working on the 4.7.4 release need to be informed that an updated binary kdelibs package is required" ... does this next step happen "automatically" somehow, or does one of us need to write specifically to someone about this?  From my perspective [as a non-programmer], should i just continue to monitor this site each few months in the hope that the fault will eventually be fixed? Thanks. Steffie.
Comment 16 Sebastian Trueg 2012-01-27 13:20:48 UTC
Git commit 45e453002a1e07eb13747e0f21342be01c838ddc by Sebastian Trueg, on behalf of Ralf Habacker.
Committed on 30/12/2011 at 23:19.
Pushed by trueg into branch 'KDE/4.8'.

crash fix on windows

transform() is called recursive, which sets xsltprocExternalEntityLoader()
as default external entity handler. The default handler is called in
xsltprocExternalEntityLoader(), which calls itself until kioslave crashes
on stack overflow.

The bug is fixed by only setting the default handler on the first call.

M  +6    -4    kdoctools/xslt.cpp

http://commits.kde.org/kdelibs/45e453002a1e07eb13747e0f21342be01c838ddc
Comment 17 Ralf Habacker 2012-01-27 14:35:24 UTC
(In reply to comment #15)
> Hi Ralf. You said "Now the people working on the 4.7.4 release need to be
> informed that an updated binary kdelibs package is required" ... does this next
> step happen "automatically" somehow, or does one of us need to write
> specifically to someone about this? 

This could be asked on the KDE on Windows mailing list or see http://windows.kde.org/ for new release announcements or see  http://www.winkde.org/pub/kde/ports/win32/releases for new releases. 

There is recently 4.8.0 available.
Comment 18 kdemeoz 2012-01-28 03:37:39 UTC
Hello. Re "There is recently 4.8.0 available", now i went to http://windows.kde.org/download.php ,  downloaded the latest KDE-Installer for Win [seems to be v0.9.9-5], selected the Package Manager installation mode, chose the "Central Europe, Germany (http://www.winkde.org)" Server, selected the "stable 4.8.0" release, chose the "kmymoney-vc100" package, BUT then i stopped. It lists "Available" as "gitStable-4.6" ... but my version already installed is 4.6.1 ... so i did not proceed, because 4.6 sounds OLDER to me than 4.6.1 ... I do not wish to revert to an older version of KMM itself, simply to solve the original problem of the Help function not working in KMM on a Windows OS. 

What should i do now pls? Will there be an updated version soon that is BOTH the latest KMM *AND* the latest [successful] Help package?

Thanks, Steffie.
Comment 19 Cristian Oneț 2012-01-28 10:42:01 UTC
gitStable-4.6 is actually newer then 4.6.1.
It is a snapshot of what will become 4.6.2, 4.6.3 and so on. 4.6.2 will be released next week until I recommend installing gitStable-4.6.
Comment 20 kdemeoz 2012-01-29 07:02:12 UTC
Hi Cristian, thanks for your update here. Sadly, I have had a very unhappy several hours as I tried repeatedly, unsuccessfully, to download & install gitStable-4.6, from the "stable 4.8.0" release folder:

1.	I ran “kdewin-installer-gui-latest.exe” [v0.9.9-5] selected the Package Manager installation mode & the 1st radio-button Compiler option [MSVC 2010 32bit], chose the "Central Europe, Germany (http://www.winkde.org)" Server, selected the "stable 4.8.0" release, chose the "kmymoney-vc100" package, then selected "gitStable-4.6".
2.	I did the above, 3 times, but every time it failed with multiple Checksum error msgs.
3.	I then re-ran [twice] the KDEWIN Installer but selected the 2nd, not 1st, radio-button Compiler option [MnGW4 64bit].
4.	Failed again with more Checksum error msgs, eg, final entries in large log-file “C:\Users\Steffie\AppData\Local\Temp\KDE\kdewin-installer.log”: 
a.	[2012-01-29 15:35:40] Debug: static\shared\downloader.cpp 286 Downloader::fetchInternal ret:  true 
b.	[2012-01-29 15:35:40] Critical: static\shared\package.cpp 615 Package::downloadItem could not verify checksum of archive after two tries 
c.	[2012-01-29 15:35:40] Critical: static\shared\package.h 283 "archive downloaded from http://www.winkde.org/pub/kde/ports/win32/releases/stable/4.8.0/libcurl-x64-mingw4-7.20.0-bin.tar.bz2 checksum error
5.	Now tried the 3rd Compiler [MnGW4 32bit], but this was the least-productive of all … this one does not even have KMyMoney listed, in the "stable 4.8.0" release folder, of any version!
6.	Given that my choice now was to have NO functioning KMM on my pc at all after EVERY attempt failed, whilst I wait for a fix from you, OR to [try to] get KMM v4.6.1 reinstalled from the "stable 4.7.4" release folder, I opted for the latter… luckily this succeeded, so I am back now with a working installation of KMM v4.6.1.

I’m interested to note your previous advice that KMM “4.6.2 will be released next week”, but I would sincerely hope that it is more successful than the current gitStable-4.6 [reminder; I use Win7 x64, not any Unix / Linux OS].

Thanks, Steffie.
Comment 21 Cristian Oneț 2012-01-29 10:01:17 UTC
This has happened because the KDE 4.8 release is not yet finished - that's why there is no release announcement yet. It was my mistake after reading Ralf's comment to think that KDE 4.8 is ready. The bottom line is that a KDE on Windows release is not for end users until the release announcement is out on windows.kde.org.
Comment 22 Ralf Habacker 2012-01-29 12:39:45 UTC
(In reply to comment #21)
> This has happened because the KDE 4.8 release is not yet finished - that's why
> there is no release announcement yet. It was my mistake after reading Ralf's
> comment to think that KDE 4.8 is ready. The bottom line is that a KDE on
> Windows release is not for end users until the release announcement is out on
> windows.kde.org.

Uploaded packages may have be dependency problems, but there should not be such results. This is an error in the package upload process. The normal way is to report this on the kde-windows mailing list.
Comment 23 Ralf Habacker 2012-01-29 14:59:44 UTC
(In reply to comment #22)
> (In reply to comment #21)
> > This has happened because the KDE 4.8 release is not yet finished - that's why
> > there is no release announcement yet. It was my mistake after reading Ralf's
> > comment to think that KDE 4.8 is ready. The bottom line is that a KDE on
> > Windows release is not for end users until the release announcement is out on
> > windows.kde.org.
> 
> Uploaded packages may have be dependency problems, but there should not be such
> results. This is an error in the package upload process. The normal way is to
> report this on the kde-windows mailing list.

I took a look on this issue: There seems to be a problem with recent installer and sha1 hashes, which requires an installer update. As a workaround I switched back the package repository digest type to md5. 

Unfortunally many md5 digests seems to be incorrect, see http://www.winkde.org/~kde/digest-files/errors.log

I recreated the md5 digest files and has been able to install kmymoney from 4.8.0
Comment 24 Patrick Spendrin 2012-01-29 18:39:49 UTC
The 4.8.0 release needs to be regenerated, so even if it is possible at the moment to try it out, it is not ready before we released the announcement. I am currently uploading the l10n packages and the newer version of libalkimia (4.3.2). As Cristian said, stable-4.6 is the current stable branch, the version string is bad, so I will probably change it again in the future (probably 4.6.YYYYMMDD). Release probably will be either tonight or tomorrow.
Comment 25 kdemeoz 2012-02-02 12:31:11 UTC
(In reply to comment #24)
> The 4.8.0 release needs to be regenerated, so even if it is possible at the
> moment to try it out, it is not ready before we released the announcement. I am
> currently uploading the l10n packages and the newer version of libalkimia
> (4.3.2). As Cristian said, stable-4.6 is the current stable branch, the version
> string is bad, so I will probably change it again in the future (probably
> 4.6.YYYYMMDD). Release probably will be either tonight or tomorrow.

Hi, thank you each for your various replies. Sorry but i'm a bit confused now as to what i really should do: nothing but wait; report a bug; try to download from a different server; something else?   Steffie.
Comment 26 Ralf Habacker 2012-02-03 22:01:42 UTC
it says: The umbrello provided with kde 4.8.0 is currently the newest version. 

BTW: KDE on Windows 4.8.0 has been official released - http://mail.kde.org/pipermail/kde-windows/2012-February/006413.html
Comment 27 kdemeoz 2012-02-04 09:36:53 UTC
Hi Patrick -- thanks for your email to me: 

"From: Patrick Spendrin <ps_ml@gmx.de>
To: steffie5904@yahoo.com.au 
Sent: Friday, 3 February 2012 10:57 AM
Subject: Re: kmymoney bug 283858

Hi, I just released KDE 4.8.0 - please try to rerun the installer and update the libalkimia, kmymoney and libofx packages.    I can help you tomorrow with that if you need, but now I need to go to sleep ;-)    Hope this helps you, regards, Patrick"

I have now got KMM running in my Win7 x64 pc via the MSVC 2010 32bit Compiler & ""stable 4.8.0" release". Unfortunately i still could only select gitStable-4.6, not v4.6.2. When i launch KMM now  i see it's still only KMM v4.6.1, but at least it’s now based on KDE 4.8.0 [ie, no longer 4.7.4]... so this is an improvement. However, similar as when I originally Posted in Oct 2011, KMM Help will not run [error = " The requested help file could not be parsed:<br/>c:/program files (x86)/kde/msvc 2010 32bit compiler/share/doc/html/en//kmymoney/index.docbook"].		

Also, i'm advising this FYI:   Before i did today’s upgrade as noted above, i was using KMM from the MnGW4 64bit Compiler, & so [following your advice as in yr email to me] I did these steps today:

Launched “kdewin-installer-gui-latest.exe” [v0.9.9-5], retained the defaulted MnGW4 64bit Compiler [given that’s what was currently installed], picked the "Central Europe, Germany (http://www.winkde.org)" Server, selected the "stable 4.8.0" release, still could only select gitStable-4.6, not v4.6.2;  searched for & selected Upgrade for libalkimia, and libofx packages; there’s no newer kmymoney package there. Unfortunately, KMM 64-bit still behaved very badly, same as it had before i did today's upgrade, like this:   (a) EVERY time I tried to access the "Configure KMM" function, KMM CRASHES [32bit KMM does not do this]; (b) KMM 64bit takes *several minutes* to load, & also has high latency every time i made ANY edits to any part of my data file [32bit KMM does not do this] – this extreme latency makes KMM 64bit simply impractical to use [but it’s perfectly acceptable in 32bit Compiler version]. 

Please can you tell me WHERE i can find KMM v4.6.2 … & will its Help finally work?

Many thanks, Steffie.
Comment 28 Cristian Oneț 2012-02-04 11:20:42 UTC
(In reply to comment #27)
> ""stable 4.8.0" release". Unfortunately i still could only select
> gitStable-4.6, not v4.6.2. When i launch KMM now  i see it's still only KMM
> v4.6.1, but at least it’s now based on KDE 4.8.0 [ie, no longer 4.7.4]... so
> this is an improvement. However, similar as when I originally Posted in Oct
> 2011, KMM Help will not run [error = " The requested help file could not be
> parsed:<br/>c:/program files (x86)/kde/msvc 2010 32bit
> compiler/share/doc/html/en//kmymoney/index.docbook"].        

This is because 'gitStable-4.6' does not contain the documentation and translations.

> Please can you tell me WHERE i can find KMM v4.6.2 … & will its Help finally
> work?

It will be available in a few days, I'll drop a note here when you can use it.
Comment 29 Cristian Oneț 2012-02-07 17:50:45 UTC
4.6.2 is available but the manual still can't be opened with the same error.
Comment 30 kdemeoz 2012-02-07 22:24:09 UTC
Thanks Cristian


Oh dear, how very disappointing... what's the next step needed now, pls?


Can you pls summarise the changes from KMM 4.6.1 to 4.6.2, so that i can decide if it's worth the hassle for me to upgrade my installed version, given still no Help module?


Two other questions that i've been meaning to ask for months, but kept forgetting:


1. Each time i launch my KMM v4.x.x [in my Win7 x64 OS], my ZoneAlarm warns me that multiple k*.exe files [eg, kioslave etc] are trying to connect to the internet... what's going on? Is my personal data safe?


2. When i do my regular hdd data backups, with respect to my KMM data files, is the ONLY file that i need to backup my active *.kmy file? I have been assuming yes, but felt i should ask, as this file is TINY [< 40 kB], compared to my old GnuCash file [> 2 MB] & my older Quicken file [> 4 MB] ... admittedly I used GC for a year, & Quicken for ~ a decade, vs only a few months so far for KMM. Anyway, in event of disaster recovery, is backing up my *.kmy file sufficient, pls?

 
Thanks.
 
 
Cheers, Steffie.



>________________________________
> From: Cristian Onet <onet.cristian@gmail.com>
>To: steffie5904@yahoo.com.au 
>Sent: Wednesday, 8 February 2012 4:50 AM
>Subject: [Bug 283858] KMyMoney v4.6.0 (Windows) Help error "requested help file could not be parsed".
> 
>https://bugs.kde.org/show_bug.cgi?id=283858
>
>
>
>
>
>--- Comment #29 from Cristian Onet <onet cristian gmail com>  2012-02-07 17:50:45 ---
>4.6.2 is available but the manual still can't be opened with the same error.
>
>-- 
>Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
>------- You are receiving this mail because: -------
>You are on the CC list for the bug.
>You reported the bug.
>
>
>
Comment 31 Cristian Oneț 2012-02-08 05:52:21 UTC
(In reply to comment #30)
> Oh dear, how very disappointing... what's the next step needed now, pls?
Nothing, just wait for it to be fixed.

> Can you pls summarise the changes from KMM 4.6.1 to 4.6.2, so that i can decide
> if it's worth the hassle for me to upgrade my installed version, given still no
> Help module?

It's definitely worth it to upgrade since 4.6.2 is 4.6.1 with a lot of bugs fixed (checkout the release notes http://kmymoney2.sourceforge.net/release-4.6.2.html).

> 1. Each time i launch my KMM v4.x.x [in my Win7 x64 OS], my ZoneAlarm warns me
> that multiple k*.exe files [eg, kioslave etc] are trying to connect to the
> internet... what's going on? Is my personal data safe?
AFAIK KDE is safe. If I'm not mistaking multiple kioslave instances communicate with the KIO scheduler trough local TCP/IP ports and that's why the firewall think that they try to connect to the internet.

> 2. When i do my regular hdd data backups, with respect to my KMM data files, is
> the ONLY file that i need to backup my active *.kmy file? I have been assuming
> yes, but felt i should ask, as this file is TINY [< 40 kB], compared to my old
> GnuCash file [> 2 MB] & my older Quicken file [> 4 MB] ... admittedly I used GC
> for a year, & Quicken for ~ a decade, vs only a few months so far for KMM.
> Anyway, in event of disaster recovery, is backing up my *.kmy file sufficient,
> pls?

All your data is in the *.kmy file which is a compressed xml file.
Comment 32 kdemeoz 2012-02-08 06:24:06 UTC
Hi Cristian


Thank you VERY MUCH for your ongoing help to me ... & your very fast reply!


I have said this before, but am happy to say it again ... as a long-term [but now ex-] Quicken-user, & a GnuCash-user [also now ex-] for ~a year, i think that KMM is just *fabulous*. To everyone who designed, built & actively maintains & enhances it... thank you for doing your marvellous work for the world!!!   :-) 
 
 
 
Cheers, Steffie.



>________________________________
> From: Cristian Onet <onet.cristian@gmail.com>
>To: steffie5904@yahoo.com.au 
>Sent: Wednesday, 8 February 2012 4:52 PM
>Subject: [Bug 283858] KMyMoney v4.6.0 (Windows) Help error "requested help file could not be parsed".
> 
>https://bugs.kde.org/show_bug.cgi?id=283858
>
>
>
>
>
>--- Comment #31 from Cristian Onet <onet cristian gmail com>  2012-02-08 05:52:21 ---
>(In reply to comment #30)
>> Oh dear, how very disappointing... what's the next step needed now, pls?
>Nothing, just wait for it to be fixed.
>
>> Can you pls summarise the changes from KMM 4.6.1 to 4.6.2, so that i can decide
>> if it's worth the hassle for me to upgrade my installed version, given still no
>> Help module?
>
>It's definitely worth it to upgrade since 4.6.2 is 4.6.1 with a lot of bugs
>fixed (checkout the release notes
>http://kmymoney2.sourceforge.net/release-4.6.2.html).
>
>> 1. Each time i launch my KMM v4.x.x [in my Win7 x64 OS], my ZoneAlarm warns me
>> that multiple k*.exe files [eg, kioslave etc] are trying to connect to the
>> internet... what's going on? Is my personal data safe?
>AFAIK KDE is safe. If I'm not mistaking multiple kioslave instances communicate
>with the KIO scheduler trough local TCP/IP ports and that's why the firewall
>think that they try to connect to the internet.
>
>> 2. When i do my regular hdd data backups, with respect to my KMM data files, is
>> the ONLY file that i need to backup my active *.kmy file? I have been assuming
>> yes, but felt i should ask, as this file is TINY [< 40 kB], compared to my old
>> GnuCash file [> 2 MB] & my older Quicken file [> 4 MB] ... admittedly I used GC
>> for a year, & Quicken for ~ a decade, vs only a few months so far for KMM.
>> Anyway, in event of disaster recovery, is backing up my *.kmy file sufficient,
>> pls?
>
>All your data is in the *.kmy file which is a compressed xml file.
>
>-- 
>Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
>------- You are receiving this mail because: -------
>You are on the CC list for the bug.
>You reported the bug.
>
>
>
Comment 33 Ralf Habacker 2012-02-08 12:35:20 UTC
While the initial khelpcenter bug has been fixed in 4.8.0, there is a different bug in 4.8.0 khelpcenter installation, which prohibits showing docs. The problem is identified and a fix is on the way. 

A workaround for people cannot waiting until a fixed kdelibs packages will be released is documented at https://bugs.kde.org/show_bug.cgi?id=293610
Comment 34 Yuri Chornoivan 2012-02-08 13:32:36 UTC
*** Bug 293636 has been marked as a duplicate of this bug. ***
Comment 35 Yuri Chornoivan 2012-02-10 15:20:41 UTC
*** Bug 293779 has been marked as a duplicate of this bug. ***
Comment 36 Yuri Chornoivan 2012-04-02 16:39:31 UTC
*** Bug 297324 has been marked as a duplicate of this bug. ***
Comment 37 kdemeoz 2012-09-15 06:47:13 UTC
Hello. I have not checked this site for several months. Can anyone pls tell me now; has the original problem* been resolved, ie, is there yet a way that i can download & install something that will finally allow me to open KMM's Help documentation from within KMM, without me having to simply browse online to the Help website? Reminder - it's the KMM for Windows that i need [my current one = KMM v4.6.2]. Thanks.

Steffie. 

* [error = "The requested help file could not be parsed:<br/>c:/programdata/kde/share/doc/html/en//kmymoney/index.docbook"].
Comment 38 Yuri Chornoivan 2012-09-15 14:59:28 UTC
(In reply to comment #37)
> Hello. I have not checked this site for several months. Can anyone pls tell
> me now; has the original problem* been resolved, ie, is there yet a way that
> i can download & install something that will finally allow me to open KMM's
> Help documentation from within KMM, without me having to simply browse
> online to the Help website? Reminder - it's the KMM for Windows that i need
> [my current one = KMM v4.6.2]. Thanks.
> 
> Steffie. 
> 
> * [error = "The requested help file could not be
> parsed:<br/>c:/programdata/kde/share/doc/html/en//kmymoney/index.docbook"].

Please update your components to KDE 4.8.0. The new release has almost fixed the problem:

https://bugs.kde.org/show_bug.cgi?id=293610

But for some reason KHelpCenter refuses to show the docs with multiple docbooks, e.g. KMyMoney, Kate, KWrite, etc.

This problem should be fixed by KDE-Windows team. Please contact them directly through IRC (#kde-windows on freenode) or mailing list ( https://mail.kde.org/mailman/listinfo/kde-windows ) to speed up the solution as most of KMyMoney developers have no Windows installation to help with triaging the source of the problem.

Thanks for your help.
Comment 39 kdemeoz 2012-09-23 04:02:14 UTC
Thanks Yuri. I have now posted there as you advised ... http://mail.kde.org/pipermail/kde-windows/2012-September/006934.html 

Steffie.
Comment 40 Burkhard Lück 2013-10-23 15:13:02 UTC
Running KDE in a virtual Windows 7:
KMyMoney
Version 4.6.3
KDE 4.10.2

Using F1 or Help->KMyMoney Handbook opens KHelpcenter with the KMymoney Documentation
Comment 41 Cristian Oneț 2013-10-24 05:06:38 UTC
I can confirm that this bug is fixed.
Comment 42 kdemeoz 2013-10-24 09:18:30 UTC
Hi Burkhard & Cristian

Thank you both. By chance / coincidence a few days ago i discovered the new Windows installer version of KMM & KDE. I successfully downloaded & installed, & was happy to find that finally i now have the working onboard Handbook documentation. I'm not sure that it's necessarily properly up to date [being "The KMyMoney Handbook for KMyMoney version 4.6", last updated 2011, vs the latest KMM v4.6.4], but at least it's working ... a nice step forward!

Sorry to be the bearer of bad tidings, but i did notice these 2 idiosyncrasies [faults?]; the 1st in this onboard Handbook, the 2nd in KMM v4.6.4 itself:
1. Single-clicking on any of the chapter / section / page links in the left-hand column does not jump the right-hand pane to that page ... a double-click is needed every time.
2. In the v4.6.4 KMM "icon bar" [immediately below the Menu Bar], the most right-hand icon is "What's This?". It never worked in any of the previous Windows versions i've used, but i expected that was possibly due to the same underlying bug that stopped the Handbook working. However in v4.6.4, given the Handbook bug is fixed, i thought this icon function should now also work ... but it still does not. 

Thanks to all the KMM Devs for their hard work. KMM continues to be a really brilliant product !!

Steffie.
Comment 43 Cristian Oneț 2013-10-24 09:58:55 UTC
1. Single click vs. double click to activate is a system setting - I don't know where this can be set
2. What's this only works when there is information to display like in the settings dialog for some options - try the ledger entry options (Use the ledger lens)
Comment 44 kdemeoz 2013-10-26 01:37:26 UTC
Hi Cristian

 

Yes Single click is a Windows7 setting that I have used for years, & it works just fine on my pc with all other apps. It’s specifically only the new Handbook for which I observed that I had to double-click everything. 

 

OK now I see what you mean with the “What’s This”, but its functionality is not quite what I expected from its name, not least because there’s many areas that it doesn’t work.

 

Thanks.

 

Steffie.

 

From: bugzilla_noreply@kde.org [mailto:bugzilla_noreply@kde.org] On Behalf Of Cristian One? 
Sent: Thursday, 24 October 2013 20:59
To: steffie5904@yahoo.com.au
Subject: [kde-windows] [Bug 283858] KMyMoney v4.6.0 (Windows) Help error "requested help file could not be parsed".

 

Comment # 43 <https://bugs.kde.org/show_bug.cgi?id=283858#c43>  on bug 283858 <https://bugs.kde.org/show_bug.cgi?id=283858>  from  <mailto:onet.cristian@gmail.com> Cristian Oneț 

1. Single click vs. double click to activate is a system setting - I don't know
where this can be set
2. What's this only works when there is information to display like in the
settings dialog for some options - try the ledger entry options (Use the ledger
lens)
  _____  


You are receiving this mail because: 

*	You are on the CC list for the bug.
*	You reported the bug.