Bug 293610 - khelpcenter do not show any help
Summary: khelpcenter do not show any help
Status: RESOLVED FIXED
Alias: None
Product: kde-windows
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: KDE-Windows
URL:
Keywords:
: 277976 314436 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-08 08:43 UTC by Ralf Habacker
Modified: 2019-07-23 10:14 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Habacker 2012-02-08 08:43:18 UTC
Version:           unspecified (using KDE 4.8.0) 
OS:                MS Windows

I installed whole KDE 4.8.0 MSVC 2010 variant. 

When I run the "application handbook" menu entry from any application khelpcenter do not show the related content. 


Reproducible: Always

Steps to Reproduce:
start khelpcenter 
press F1

Actual Results:  
khelpcenter prints 
"Die angeforderte Hilfedatei ist nicht lesbar:<br/>c:/program files/kde-vc100-4.8.0/share/doc/html/de//khelpcenter/index.docbook"


Expected Results:  
khelpcenter should show the related handbook

The related docbook file is present. It looks that the internal docbook processing is somehow broken.
Comment 1 Ralf Habacker 2012-02-08 08:48:40 UTC
First issue is that there is are path problems in the ksgmltools2 part of the kdelibs package: 

- in share\apps\ksgmltools2\customization\kde-include-common.xsl there are absolute references:
   <xsl:import href="n:/share/xml/docbook/xsl-stylesheets-1.75.2/html/autoidx.xsl"/>
   <xsl:import href="n:/share/xml/docbook/xsl-stylesheets-1.75.2/html/chunk.xsl"/>

- in share\apps\ksgmltools2\customization\kde-include-man.xsl there are absolute references:

   <xsl:import href="n:/share/xml/docbook/xsl-stylesheets-1.75.2/manpages/docbook.xsl"/>
Comment 2 Ralf Habacker 2012-02-08 08:50:35 UTC
This issue could be fixed by changing the related pathes in share\apps\ksgmltools2\customization\kde-include-common.xsl to

   <xsl:import href="../../../xml/docbook/xsl-stylesheets-1.75.2/html/autoidx.xsl"/>
   <xsl:import href="../../../xml/docbook/xsl-stylesheets-1.75.2/html/chunk.xsl"/>

and in  share\apps\ksgmltools2\customization\kde-include-man.xsl to 

   <xsl:import href="../../../xml/docbook/xsl-stylesheets-1.75.2/manpages/docbook.xsl"/>
Comment 3 Ralf Habacker 2012-02-08 08:59:44 UTC
The second issue is that the following required packages 

docbook-xsl 
docbook-dtd 

ared installed, although they are listed as dependency of kdelibs-vc100 in the package list (config.txt) of the 4.8.0 release. 

Trying to install the package with installer 0.9.9-5 do not fix the issue because the installer do not list the docbook-xsl package as installable package. 

As workaround a manual download and unpack in the install root of these package could be used.
Comment 4 Ralf Habacker 2012-02-08 10:21:39 UTC
(In reply to comment #3)
> ared installed, 

s/ared/aren't/g
Comment 5 Patrick Spendrin 2012-02-08 11:01:30 UTC
the packages are missing from the release, I also have an idea why: they are neither built together with win32libs nor with kdesupport/kde so no way I could add them to the packagelist. shared-desktop-ontologies are also missing.

I will rebuild kdelibs as soon as I have made a working patch for that.
Comment 6 Ralf Habacker 2012-02-08 11:21:02 UTC
(In reply to comment #5)
> the packages are missing from the release, I also have an idea why: they are
> neither built together with win32libs nor with kdesupport/kde so no way I could
> add them to the packagelist. shared-desktop-ontologies are also missing.
> 
> I will rebuild kdelibs as soon as I have made a working patch for that.

Thanks for this info, for the mean time I copied the docbook* packages from 4.7.0 into 4.8.0 release.
Comment 7 Ralf Habacker 2012-02-08 11:36:05 UTC
(In reply to comment #0)
> The related docbook file is present. It looks that the internal docbook
> processing is somehow broken.

After locally fixed the missing docbook packages and the path issues with kdelibs packages khelpcenter returns still not the expected result. It displays empty pages for every application help. 

The reason is that in C:\Program Files\KDE-vc100-4.8.0\share\apps\ksgmltools2\customization\dtd\kdex.dtd an additional absolute path reference is included: 

line 98: 
<!ENTITY % DocBookDTD	    PUBLIC
  "-//OASIS//DTD DocBook XML V4.2//EN"
  "n:/share/xml/docbook/schema/dtd/4.2/docbookx.dtd"         >
%DocBookDTD;

changing it to 

<!ENTITY % DocBookDTD	    PUBLIC
  "-//OASIS//DTD DocBook XML V4.2//EN"
  "../../../../xml/docbook/schema/dtd/4.2/docbookx.dtd"         >
%DocBookDTD;


fixes the problem - applications manuals are now displayed in khelpcenter
Comment 8 Patrick Spendrin 2012-02-08 14:13:49 UTC
this doesn't seem to help for mingw-w64 (x64), but I could reproduce the workaround for vc100. I am going to investigate further...
Comment 9 Patrick Spendrin 2012-02-19 18:48:18 UTC
Ok, I had some more time to investigate this:
It works if the path has no spaces in it, if it has (think of C:\Program Files\KDE), the fixes are not enough. I will try to find the fix in the coming days.
Comment 10 Patrick Spendrin 2012-02-21 00:31:12 UTC
ok, replacing spaces with %20 works. There is another problem because these files need absolute paths while building kdelibs since the relative paths are different then. I am currently trying out a new solution and hope that this bug will be fixed tomorrow.
Comment 11 Patrick Spendrin 2012-02-22 22:32:23 UTC
*** Bug 277976 has been marked as a duplicate of this bug. ***
Comment 12 Yuri Chornoivan 2013-02-05 05:09:20 UTC
*** Bug 314436 has been marked as a duplicate of this bug. ***
Comment 13 Iain 2013-02-07 11:43:41 UTC
observed when accessing help manual for Krita:
The requested help file could not be parsed:<br/>c:/program files/calligra/share/doc/html/en//khelpcenter/documentationnotfound/index.docbook

release:
Krita
Version 2.6 RC3
Using KDE Development Platform 4.7.4 (4.7.4)
Windows 7 Ultimate
Comment 14 Patrick Spendrin 2013-05-10 20:46:24 UTC
Git commit 38b5e7f937b5d2c291c5b20a0c8648632084dde5 by Patrick Spendrin.
Committed on 10/05/2013 at 22:43.
Pushed by sengels into branch 'KDE/4.10'.

do not hardcode installation paths into files.

This makes it possible to move around packages after running make install
on Windows.

M  +26   -4    kdoctools/CMakeLists.txt

http://commits.kde.org/kdelibs/38b5e7f937b5d2c291c5b20a0c8648632084dde5