Bug 281865

Summary: Crash on Flash Video (You Tube) when navigating to new video
Product: [Applications] rekonq Reporter: Steve <campbell.steve.nz>
Component: generalAssignee: Andrea Diamantini <adjam7>
Status: RESOLVED DOWNSTREAM    
Severity: crash CC: alexorghici_1999, arielmartin_1, avcascade, bruce2186, b_antonov, combineuniversal, edsonnota2008, jackycholo, james.fisher27, jeepeg, jorge.barroso.11, keiliikuu, keithluxeus, kenhall5551, lindsay.mathieson, mail, Michael.Zens, nolan1063, okorpela, victor.roth.cardoso
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi
New crash information added by DrKonqi
New crash information added by DrKonqi

Description Steve 2011-09-12 09:44:35 UTC
Application: rekonq (0.7.57)
KDE Platform Version: 4.7.00 (4.7.0)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-11-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
Normally the first video plays fine, but on navigating to another rekonq crashes.  If I open the video selected as the first video it plays fine.  The crash will occur again selecting a new video.

The crash can be reproduced every time.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f23e0e68780 (LWP 6653))]

Thread 9 (Thread 0x7f23c2594700 (LWP 6654)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f23dfa4a832 in scavengerThread (context=0x7f23e0271f00) at wtf/FastMalloc.cpp:2378
#2  WTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f23e0271f00) at wtf/FastMalloc.cpp:1497
#3  0x00007f23d9bf2d8c in start_thread (arg=0x7f23c2594700) at pthread_create.c:304
#4  0x00007f23d9ef004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f23c10c9700 (LWP 6655)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f23e06482a2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f23e0961180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f23e06482d9 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f23e096f254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f23d9bf2d8c in start_thread (arg=0x7f23c10c9700) at pthread_create.c:304
#4  0x00007f23d9ef004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f23bfc9a700 (LWP 6656)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f23da9b382b in wait (this=<value optimized out>, mutex=0x1906570, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1906570, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f23dadd8704 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x190c930, th=0x1a150e0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f23daddad73 in ThreadWeaver::WorkingHardState::applyForWork (this=0x18fe260, th=0x1a150e0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f23daddad8c in ThreadWeaver::WorkingHardState::applyForWork (this=0x18fe260, th=0x1a150e0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f23dadd9b8f in ThreadWeaver::ThreadRunHelper::run (this=0x7f23bfc99e20, parent=0x190c930, th=0x1a150e0) at ../../../threadweaver/Weaver/Thread.cpp:87
#7  0x00007f23dadd9c1b in ThreadWeaver::Thread::run (this=0x1a150e0) at ../../../threadweaver/Weaver/Thread.cpp:142
#8  0x00007f23da9b3175 in QThreadPrivate::start (arg=0x1a150e0) at thread/qthread_unix.cpp:320
#9  0x00007f23d9bf2d8c in start_thread (arg=0x7f23bfc9a700) at pthread_create.c:304
#10 0x00007f23d9ef004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f23bce2f700 (LWP 6658)):
#0  0x00007f23d9bf6d9d in __pthread_mutex_unlock_usercnt (mutex=0x1e19c28) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x1e19c28) at pthread_mutex_unlock.c:290
#2  0x00007f23d6d6e4f5 in g_main_context_query () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f23d6d6f00a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f23d6d6f639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f23daac5446 in QEventDispatcherGlib::processEvents (this=0x1e19430, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#6  0x00007f23daa99882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f23daa99abc in QEventLoop::exec (this=0x7f23bce2edd0, flags=...) at kernel/qeventloop.cpp:201
#8  0x00007f23da9b0924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#9  0x00007f23daa7bc2f in QInotifyFileSystemWatcherEngine::run (this=0x1e17da0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f23da9b3175 in QThreadPrivate::start (arg=0x1e17da0) at thread/qthread_unix.cpp:320
#11 0x00007f23d9bf2d8c in start_thread (arg=0x7f23bce2f700) at pthread_create.c:304
#12 0x00007f23d9ef004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f23b4c64700 (LWP 6672)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f23da9b382b in wait (this=<value optimized out>, mutex=0x1906570, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1906570, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f23dadd8704 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x190c930, th=0x235e750) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f23daddad73 in ThreadWeaver::WorkingHardState::applyForWork (this=0x18fe260, th=0x235e750) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f23dadd9b8f in ThreadWeaver::ThreadRunHelper::run (this=0x7f23b4c63e20, parent=0x190c930, th=0x235e750) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f23dadd9c1b in ThreadWeaver::Thread::run (this=0x235e750) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f23da9b3175 in QThreadPrivate::start (arg=0x235e750) at thread/qthread_unix.cpp:320
#8  0x00007f23d9bf2d8c in start_thread (arg=0x7f23b4c64700) at pthread_create.c:304
#9  0x00007f23d9ef004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f23b41f3700 (LWP 6681)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f23da9b382b in wait (this=<value optimized out>, mutex=0x1906570, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:88
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x1906570, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:160
#3  0x00007f23dadd8704 in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x190c930, th=0x4ca2d50) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f23daddad73 in ThreadWeaver::WorkingHardState::applyForWork (this=0x18fe260, th=0x4ca2d50) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f23dadd9b8f in ThreadWeaver::ThreadRunHelper::run (this=0x7f23b41f2e20, parent=0x190c930, th=0x4ca2d50) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f23dadd9c1b in ThreadWeaver::Thread::run (this=0x4ca2d50) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f23da9b3175 in QThreadPrivate::start (arg=0x4ca2d50) at thread/qthread_unix.cpp:320
#8  0x00007f23d9bf2d8c in start_thread (arg=0x7f23b41f3700) at pthread_create.c:304
#9  0x00007f23d9ef004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f23a27b1700 (LWP 6799)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f23b1d6ad8c in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#2  0x00007f23b1e88fa0 in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#3  0x00007f23b1d6afec in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#4  0x00007f23b1d6b43e in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#5  0x00007f23d9bf2d8c in start_thread (arg=0x7f23a27b1700) at pthread_create.c:304
#6  0x00007f23d9ef004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f23a912d700 (LWP 6800)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f23b1d6ad8c in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#2  0x00007f23b1e88fa0 in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#3  0x00007f23b1d6afec in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#4  0x00007f23b1d6b43e in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#5  0x00007f23d9bf2d8c in start_thread (arg=0x7f23a912d700) at pthread_create.c:304
#6  0x00007f23d9ef004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f23e0e68780 (LWP 6653)):
[KCrash Handler]
#6  0x00007f23d6d8c2b6 in g_slice_alloc () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#7  0x00007f23d6d8c916 in g_slice_alloc0 () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#8  0x00007f23d664d399 in g_type_create_instance () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#9  0x00007f23d662b76c in ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#10 0x00007f23d662e389 in g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007f23d662f63c in g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#12 0x00007f23b16d53ca in gtk_plug_new_for_display () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x00007f23b1d6655a in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#14 0x00007f23b1d5df0f in ?? () from /usr/lib/flashplugin-installer/libflashplayer.so
#15 0x00007f23df7cac69 in WebCore::PluginView::setNPWindowIfNeeded (this=0x7f23b339c040) at plugins/qt/PluginViewQt.cpp:600
#16 0x00007f23df7cbe89 in WebCore::PluginView::platformStart (this=0x7f23b339c040) at plugins/qt/PluginViewQt.cpp:883
#17 0x00007f23df67539e in WebCore::PluginView::start (this=0x7f23b339c040) at plugins/PluginView.cpp:258
#18 0x00007f23df6757be in WebCore::PluginView::init (this=0x7f23b339c040) at plugins/PluginView.cpp:193
#19 0x00007f23df655a78 in WebCore::ScrollView::addChild (this=0x7f23b374ac80, prpChild=<value optimized out>) at platform/ScrollView.cpp:69
#20 0x00007f23df72aa53 in WebCore::moveWidgetToParentSoon (child=0x7f23b339c040, parent=0x7f23b374ac80) at rendering/RenderWidget.cpp:85
#21 0x00007f23df72b273 in WebCore::RenderWidget::setWidget (this=0x7f23b3125e80, widget=...) at rendering/RenderWidget.cpp:200
#22 0x00007f23df6ff0c7 in WebCore::RenderPart::setWidget (this=<value optimized out>, widget=<value optimized out>) at rendering/RenderPart.cpp:52
#23 0x00007f23df57f143 in WebCore::FrameLoader::loadPlugin (this=0x7f23b4f3e060, renderer=0x7f23b3125e80, url=<value optimized out>, mimeType=..., paramNames=..., paramValues=..., useFallback=false) at loader/FrameLoader.cpp:1381
#24 0x00007f23df581959 in WebCore::FrameLoader::requestObject (this=0x7f23b4f3e060, renderer=0x7f23b3125e80, url=<value optimized out>, frameName=..., mimeType=..., paramNames=..., paramValues=...) at loader/FrameLoader.cpp:1286
#25 0x00007f23df6c7a5d in WebCore::RenderEmbeddedObject::updateWidget (this=0x7f23b3125e80, onlyCreateNonNetscapePlugins=false) at rendering/RenderEmbeddedObject.cpp:321
#26 0x00007f23df5fa12a in WebCore::FrameView::updateWidgets (this=0x7f23b374ac80) at page/FrameView.cpp:1502
#27 0x00007f23df5fa33d in WebCore::FrameView::performPostLayoutTasks (this=0x7f23b374ac80) at page/FrameView.cpp:1532
#28 0x00007f23df5fa7ed in WebCore::FrameView::layout (this=0x7f23b374ac80, allowSubtree=<value optimized out>) at page/FrameView.cpp:771
#29 0x00007f23df665d92 in WebCore::ThreadTimers::sharedTimerFiredInternal (this=0x7f23e0cd1810) at platform/ThreadTimers.cpp:112
#30 0x00007f23daaae1c9 in QObject::event (this=0x19d9b20, e=<value optimized out>) at kernel/qobject.cpp:1190
#31 0x00007f23dbe249f4 in QApplicationPrivate::notify_helper (this=0x17f25f0, receiver=0x19d9b20, e=0x7fff983a0a40) at kernel/qapplication.cpp:4462
#32 0x00007f23dbe293ba in QApplication::notify (this=<value optimized out>, receiver=0x19d9b20, e=0x7fff983a0a40) at kernel/qapplication.cpp:4341
#33 0x00007f23dcb34796 in KApplication::notify (this=0x7fff983a0d20, receiver=0x19d9b20, event=0x7fff983a0a40) at ../../kdeui/kernel/kapplication.cpp:311
#34 0x00007f23daa9a49c in QCoreApplication::notifyInternal (this=0x7fff983a0d20, receiver=0x19d9b20, event=0x7fff983a0a40) at kernel/qcoreapplication.cpp:731
#35 0x00007f23daac7f12 in sendEvent (this=0x17edaf0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#36 QTimerInfoList::activateTimers (this=0x17edaf0) at kernel/qeventdispatcher_unix.cpp:604
#37 0x00007f23daac4cf4 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#38 0x00007f23d6d6ebcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007f23d6d6f3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#40 0x00007f23d6d6f639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#41 0x00007f23daac53ef in QEventDispatcherGlib::processEvents (this=0x17934f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#42 0x00007f23dbece4de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f23daa99882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f23daa99abc in QEventLoop::exec (this=0x7fff983a0cb0, flags=...) at kernel/qeventloop.cpp:201
#45 0x00007f23daa9decb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#46 0x00007f23e0a5dfd4 in kdemain (argc=1, argv=<value optimized out>) at /build/buildd/rekonq-0.7.57+git2011090621/src/main.cpp:215
#47 0x00007f23d9e28eff in __libc_start_main (main=0x4008d0 <main(int, char**)>, argc=1, ubp_av=0x7fff983a16b8, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff983a16a8) at libc-start.c:226
#48 0x00000000004007f9 in _start ()

This bug may be a duplicate of or related to bug 276213.

Possible duplicates by query: bug 280530, bug 278434, bug 278173, bug 276213, bug 268494.

Reported using DrKonqi
Comment 1 Andrea Diamantini 2011-09-16 14:07:24 UTC
Not sure I understood HOW I can reproduce it. Can you please explain it more deeply?
Comment 2 Steve 2011-09-16 23:11:54 UTC
Flash: 64bit 11.0.1.129

Navigate to http://www.youtube.com/watch?feature=player_embedded&v=6riY-103vbc

The video plays okay.

Click on another video from youTube suggestion panel on the right.

Repeat until crash. May take a few videos.  On this test it crashed on video 5.

Chromium-Browser which is using the same flash plugin doesn't crash.

Hope that helps.
Thank you
S.
Comment 3 Steve 2011-09-17 11:37:55 UTC
Crash also occurs with Konqueror in KHTML view mode.  In Konqueror it doesn't crash the browser, only nspluginviewer.
Comment 4 Andrea Diamantini 2011-09-21 21:45:02 UTC
I saw 20 videos and it worked well here:
rekonq 0.7.92 on QtWebKit 2.2
Comment 5 Steve 2011-09-23 08:44:14 UTC
Looks like it is a flash issue.  I don't get the crash after going back to the 10.3 32bit stable flash.  Please close the bug.  thank you.
Comment 6 Andrea Diamantini 2011-09-23 14:31:15 UTC
ok.
Thank you anyway for your bug report
Comment 7 Christoph Feck 2011-10-17 10:01:43 UTC
https://bugs.webkit.org/show_bug.cgi?id=66839
Comment 8 Christoph Feck 2011-10-17 10:02:19 UTC
*** Bug 283918 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2011-10-17 10:02:49 UTC
*** Bug 284153 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2011-10-17 10:03:32 UTC
*** Bug 284233 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2011-10-17 10:03:52 UTC
*** Bug 284239 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2011-10-21 08:33:17 UTC
*** Bug 284580 has been marked as a duplicate of this bug. ***
Comment 13 Christoph Feck 2011-10-21 08:33:37 UTC
*** Bug 284575 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2011-10-21 08:34:52 UTC
*** Bug 284301 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2011-10-25 09:36:20 UTC
*** Bug 284736 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2011-10-25 09:36:52 UTC
*** Bug 284721 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Feck 2011-10-25 09:37:23 UTC
*** Bug 284693 has been marked as a duplicate of this bug. ***
Comment 18 Christoph Feck 2011-10-25 09:37:50 UTC
*** Bug 284692 has been marked as a duplicate of this bug. ***
Comment 19 Christoph Feck 2011-10-26 20:58:08 UTC
*** Bug 284980 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Feck 2011-10-27 08:17:12 UTC
*** Bug 285058 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2011-10-29 10:55:01 UTC
*** Bug 285115 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Feck 2011-10-30 09:48:57 UTC
*** Bug 285296 has been marked as a duplicate of this bug. ***
Comment 23 Jorge Barroso Barea 2011-10-30 21:00:28 UTC
Created attachment 65051 [details]
New crash information added by DrKonqi

rekonq (0.8.0) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:
When Rekonq crashed I had two tabs on it, and then I opened a new tab when I went to www.youtube.com when I played a music video, I clicked on the URL before the page was completely charged (the page, not the video), and when I left-clicked to select the URL it get blocked for a moment and crashed. The other two pages where Tuenti and Facebook (social networks, both similar).
- Custom settings of the application:
The application it's with the default configuration, I haven't changed anything on it, just saved keys on KwalletManager, and obviously installed Flash player plugin 10

-- Backtrace (Reduced):
#9  0x06a98b56 in g_type_create_instance () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
[...]
#11 0x06a7ae79 in g_object_newv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#12 0x06a7c068 in g_object_new () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#13 0x070225eb in gtk_plug_new_for_display () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#14 0x07022644 in gtk_plug_new () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
Comment 24 Christoph Feck 2011-11-01 16:12:05 UTC
*** Bug 285470 has been marked as a duplicate of this bug. ***
Comment 25 Christoph Feck 2011-11-01 16:12:54 UTC
*** Bug 285313 has been marked as a duplicate of this bug. ***
Comment 26 Blackpaw 2011-11-12 04:25:55 UTC
Created attachment 65538 [details]
New crash information added by DrKonqi

rekonq (0.8.0) on KDE Platform 4.7.3 (4.7.3) using Qt 4.7.4

- What I was doing when the application crashed:

Watching embedded yuotube - when I browsed to a new page rekonq crashed. This happens every time with any embedded video.

-- Backtrace (Reduced):
#8  0x00007fc7f735fef9 in g_type_create_instance () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
[...]
#10 0x00007fc7f7342e94 in g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#11 0x00007fc7f734408c in g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
#12 0x00007fc79493118a in gtk_plug_new_for_display () from /usr/lib/x86_64-linux-gnu/libgtk-x11-2.0.so.0
[...]
#15 0x00007fc7fd20e74c in WebCore::PluginView::setNPWindowIfNeeded (this=0x7fc7965e8a00) at plugins/qt/PluginViewQt.cpp:701
Comment 27 Blackpaw 2011-11-12 04:33:59 UTC
Still seeing this one - rekonq 0.8, kde 4.7.3, 64 bit
Comment 28 nolan1063 2011-11-21 09:15:33 UTC
Created attachment 65897 [details]
New crash information added by DrKonqi

rekonq (0.8.0) on KDE Platform 4.7.2 (4.7.2) using Qt 4.7.4

- What I was doing when the application crashed:

1. Navigating through accuradio.com while listening to one of their music channels.
2. Looking into my e-mail & crashed all of the sudden.

-- Backtrace (Reduced):
#9  0x02f08b56 in g_type_create_instance () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
[...]
#11 0x02eeae79 in g_object_newv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#12 0x02eec068 in g_object_new () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#13 0xa52625eb in gtk_plug_new_for_display () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#14 0xa5262644 in gtk_plug_new () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
Comment 29 Andrea Diamantini 2011-11-22 05:02:25 UTC
*** Bug 286804 has been marked as a duplicate of this bug. ***
Comment 30 Tommi Tervo 2012-01-01 17:11:51 UTC
*** Bug 290333 has been marked as a duplicate of this bug. ***