Bug 280307

Summary: Zooming In Crash version 1.0.2
Product: marble Reporter: mom2twinzz
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: 1.3 (KDE 4.8)   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description mom2twinzz 2011-08-18 02:56:12 UTC
Application: marble (1.0.2 (Stable Release))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-10-generic x86_64
Distribution: Ubuntu 11.04

-- Information about the crash:
- What I was doing when the application crashed:
I was zooming in on a particular location after opening the application for the first time.  I am running Ubuntu 11.04 (Natty)  and just installed the Secondary Edubuntu package.

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff3c1a38780 (LWP 17245))]

Thread 7 (Thread 0x7ff3b20a3700 (LWP 17247)):
#0  0x00007ff3be4d2f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff3b951b104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff3b951b9f2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff3b2a02c44 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007ff3b95423e4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007ff3b9dded8c in start_thread (arg=0x7ff3b20a3700) at pthread_create.c:304
#6  0x00007ff3be4e004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7ff39fdfe700 (LWP 17249)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007ff39fdfdae0 in ?? ()
#2  0x00007fffbb3ce7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 5 (Thread 0x7ff39be90700 (LWP 17250)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007ff39be8fae0 in ?? ()
#2  0x00007fffbb3ce7b2 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 4 (Thread 0x7ff39b68f700 (LWP 17251)):
#0  0x00007ff3be4d2f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff3b951b104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff3b951b639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff3bfbeb446 in QEventDispatcherGlib::processEvents (this=0x1f091a0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff3bfbbf882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff3bfbbfabc in QEventLoop::exec (this=0x7ff39b68edd0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff3bfad6924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007ff3bfba1c2f in QInotifyFileSystemWatcherEngine::run (this=0x1f18f40) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007ff3bfad9175 in QThreadPrivate::start (arg=0x1f18f40) at thread/qthread_unix.cpp:320
#9  0x00007ff3b9dded8c in start_thread (arg=0x7ff39b68f700) at pthread_create.c:304
#10 0x00007ff3be4e004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7ff397e88700 (LWP 17258)):
#0  0x00007ff3be4d2f03 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ff3b951b104 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007ff3b951b639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007ff3bfbeb446 in QEventDispatcherGlib::processEvents (this=0x200a0f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007ff3bfbbf882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007ff3bfbbfabc in QEventLoop::exec (this=0x7ff397e87db0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007ff3bfad6924 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:492
#7  0x00007ff3c1083a98 in Marble::FileStorageWatcher::run (this=0x1d40e90) at ../../../../marble/src/lib/FileStorageWatcher.cpp:401
#8  0x00007ff3bfad9175 in QThreadPrivate::start (arg=0x1d40e90) at thread/qthread_unix.cpp:320
#9  0x00007ff3b9dded8c in start_thread (arg=0x7ff397e88700) at pthread_create.c:304
#10 0x00007ff3be4e004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff3aaa8f700 (LWP 17324)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007ff3bccea832 in ?? () from /usr/lib/libQtWebKit.so.4
#2  0x00007ff3b9dded8c in start_thread (arg=0x7ff3aaa8f700) at pthread_create.c:304
#3  0x00007ff3be4e004d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff3c1a38780 (LWP 17245)):
[KCrash Handler]
#6  0x00007ff3c10789cd in Marble::AbstractScanlineTextureMapper::pixelValue (this=0x1f64df0, lon=<value optimized out>, lat=<value optimized out>, scanLine=0x7ff3995c6010) at ../../../../marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#7  0x00007ff3c107a58d in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x1f64df0, viewParams=0x1d56fd8, texColorizer=0x1fb8f40) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#8  0x00007ff3c107a782 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x1f64df0, painter=0x7fffbb3bdd00, viewParams=0x1d56fd8, dirtyRect=..., texColorizer=<value optimized out>) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#9  0x00007ff3c0ff6d98 in Marble::MarbleMapPrivate::paintGround (this=0x1d56fc0, painter=..., dirtyRect=...) at ../../../../marble/src/lib/MarbleMap.cpp:188
#10 0x00007ff3c0fe9b30 in Marble::MarbleWidget::paintEvent (this=0x1cb6510, evt=0x7fffbb3be5b0) at ../../../../marble/src/lib/MarbleWidget.cpp:805
#11 0x00007ff3befcec7a in QWidget::event (this=0x1cb6510, event=0x7fffbb3be5b0) at kernel/qwidget.cpp:8405
#12 0x00007ff3bef7d9f4 in QApplicationPrivate::notify_helper (this=0x1a20700, receiver=0x1cb6510, e=0x7fffbb3be5b0) at kernel/qapplication.cpp:4462
#13 0x00007ff3bef823ba in QApplication::notify (this=<value optimized out>, receiver=0x1cb6510, e=0x7fffbb3be5b0) at kernel/qapplication.cpp:4341
#14 0x00007ff3c0601866 in KApplication::notify (this=0x7fffbb3c0da0, receiver=0x1cb6510, event=0x7fffbb3be5b0) at ../../kdeui/kernel/kapplication.cpp:311
#15 0x00007ff3bfbc049c in QCoreApplication::notifyInternal (this=0x7fffbb3c0da0, receiver=0x1cb6510, event=0x7fffbb3be5b0) at kernel/qcoreapplication.cpp:731
#16 0x00007ff3befcbacd in sendSpontaneousEvent (this=0x1d39900, pdev=0x1f3c2e8, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x1f44fc0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#17 QWidgetPrivate::drawWidget (this=0x1d39900, pdev=0x1f3c2e8, rgn=..., offset=..., flags=68, sharedPainter=0x0, backingStore=0x1f44fc0) at kernel/qwidget.cpp:5492
#18 0x00007ff3bf19298f in QWidgetBackingStore::sync (this=0x1f44fc0) at painting/qbackingstore.cpp:1325
#19 0x00007ff3befc1f60 in QWidgetPrivate::syncBackingStore (this=0x1c82bb0) at kernel/qwidget.cpp:1842
#20 0x00007ff3befcf194 in QWidget::event (this=0x1c829a0, event=0x7fffbb3bf4e0) at kernel/qwidget.cpp:8552
#21 0x00007ff3bf39ac0b in QMainWindow::event (this=0x1c829a0, event=0x7fffbb3bf4e0) at widgets/qmainwindow.cpp:1480
#22 0x00007ff3c06fcd8e in KXmlGuiWindow::event (this=0x1c829a0, ev=0x7fffbb3bf4e0) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#23 0x00007ff3bef7d9f4 in QApplicationPrivate::notify_helper (this=0x1a20700, receiver=0x1c829a0, e=0x7fffbb3bf4e0) at kernel/qapplication.cpp:4462
#24 0x00007ff3bef823ba in QApplication::notify (this=<value optimized out>, receiver=0x1c829a0, e=0x7fffbb3bf4e0) at kernel/qapplication.cpp:4341
#25 0x00007ff3c0601866 in KApplication::notify (this=0x7fffbb3c0da0, receiver=0x1c829a0, event=0x7fffbb3bf4e0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007ff3bfbc049c in QCoreApplication::notifyInternal (this=0x7fffbb3c0da0, receiver=0x1c829a0, event=0x7fffbb3bf4e0) at kernel/qcoreapplication.cpp:731
#27 0x00007ff3bf18f618 in sendEvent (this=0x1f44fc0, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#28 sendUpdateRequest (this=0x1f44fc0, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:507
#29 QWidgetBackingStore::markDirty (this=0x1f44fc0, rect=<value optimized out>, widget=<value optimized out>, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#30 0x00007ff3befc17f8 in QWidget::repaint (this=0x1cb6510, rect=...) at kernel/qwidget.cpp:10322
#31 0x00007ff3befc18b3 in QWidget::repaint (this=<value optimized out>) at kernel/qwidget.cpp:10278
#32 0x00007ff3c0febb38 in repaint (this=<value optimized out>, newLookAt=<value optimized out>, mode=<value optimized out>) at ../../../../marble/src/lib/MarbleWidget.cpp:272
#33 Marble::MarbleWidget::flyTo (this=<value optimized out>, newLookAt=<value optimized out>, mode=<value optimized out>) at ../../../../marble/src/lib/MarbleWidget.cpp:1316
#34 0x00007ff3c100eb32 in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt (this=<value optimized out>, marbleWidget=0x1cb6510, pos=<value optimized out>, newDistance=575.76286887758329) at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:271
#35 0x00007ff3c10100f6 in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0x1dd54e0, o=<value optimized out>, e=0x7fffbb3bff70) at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:738
#36 0x00007ff3bfbc0627 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x1cb6510, event=0x7fffbb3bff70) at kernel/qcoreapplication.cpp:846
#37 0x00007ff3bef7d9c1 in QApplicationPrivate::notify_helper (this=0x1a20700, receiver=0x1cb6510, e=0x7fffbb3bff70) at kernel/qapplication.cpp:4458
#38 0x00007ff3bef827cb in QApplication::notify (this=<value optimized out>, receiver=0x1cb6510, e=0x7fffbb3bff70) at kernel/qapplication.cpp:4078
#39 0x00007ff3c0601866 in KApplication::notify (this=0x7fffbb3c0da0, receiver=0x1cb6510, event=0x7fffbb3bff70) at ../../kdeui/kernel/kapplication.cpp:311
#40 0x00007ff3bfbc049c in QCoreApplication::notifyInternal (this=0x7fffbb3c0da0, receiver=0x1cb6510, event=0x7fffbb3bff70) at kernel/qcoreapplication.cpp:731
#41 0x00007ff3befeae42 in sendSpontaneousEvent (this=<value optimized out>, global_x=<value optimized out>, global_y=<value optimized out>, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#42 QETWidget::translateWheelEvent (this=<value optimized out>, global_x=<value optimized out>, global_y=<value optimized out>, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at kernel/qapplication_x11.cpp:4596
#43 0x00007ff3befffe4d in QETWidget::translateMouseEvent (this=0x1c6ef80, event=0x7fffbb3c0a30) at kernel/qapplication_x11.cpp:4373
#44 0x00007ff3beffeab7 in QApplication::x11ProcessEvent (this=0x7fffbb3c0da0, event=0x7fffbb3c0a30) at kernel/qapplication_x11.cpp:3680
#45 0x00007ff3bf027842 in x11EventSourceDispatch (s=0x1a219f0, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#46 0x00007ff3b951abcd in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#47 0x00007ff3b951b3a8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x00007ff3b951b639 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007ff3bfbeb3ef in QEventDispatcherGlib::processEvents (this=0x19db2b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#50 0x00007ff3bf0274de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#51 0x00007ff3bfbbf882 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#52 0x00007ff3bfbbfabc in QEventLoop::exec (this=0x7fffbb3c0d30, flags=...) at kernel/qeventloop.cpp:201
#53 0x00007ff3bfbc3ecb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#54 0x0000000000420755 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../marble/src/kdemain.cpp:351

This bug may be a duplicate of or related to bug 265599.

Possible duplicates by query: bug 278787, bug 275177, bug 274915, bug 274526, bug 274166.

Reported using DrKonqi
Comment 1 Bernhard Beschow 2011-08-19 20:16:10 UTC

*** This bug has been marked as a duplicate of bug 265599 ***