Bug 272696

Summary: Full Screen Video, Volume / Brightness indicator causes crash
Product: [Plasma] kwin Reporter: Jim Parsons <jammytodger>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description Jim Parsons 2011-05-07 14:23:10 UTC
Application: kwin (4.6.2 (4.6.2))
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.38-8-generic i686
Distribution: Ubuntu 11.04

-- Information about the crash:
The crash occured when I was watching BBC Iplayer in Chromium 11.0.696.57 (82915) and I turned the volume up on my laptop, the volume indicator breifly showed up on the screen then the whole screen went white, I had to alt + tab to open another window in order to clear the white out.

I have also experanced the same problem when I am watching full screen videos in the browser and there has been no mouse activity for a while and the screen dimms, the brightness indicator shows up breifly and then the same whiteout (the video continues to play in the background)

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7802720 (LWP 1407))]

Thread 3 (Thread 0xb2e63b70 (LWP 1418)):
#0  0x074c9d41 in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0x03a40dd8 in do_gettime () at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x03b0d4f2 in updateCurrentTime (this=0x93b4280, tm=...) at kernel/qeventdispatcher_unix.cpp:339
#4  QTimerInfoList::timerWait (this=0x93b4280, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x03b0f3a3 in QEventDispatcherUNIX::processEvents (this=0x93ae290, flags=...) at kernel/qeventdispatcher_unix.cpp:906
#6  0x03ade289 in QEventLoop::processEvents (this=0xb2e63280, flags=...) at kernel/qeventloop.cpp:149
#7  0x03ade522 in QEventLoop::exec (this=0xb2e63280, flags=...) at kernel/qeventloop.cpp:201
#8  0x039e82a0 in QThread::exec (this=0x93bf3d8) at thread/qthread.cpp:492
#9  0x03abffdb in QInotifyFileSystemWatcherEngine::run (this=0x93bf3d8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x039eada2 in QThreadPrivate::start (arg=0x93bf3d8) at thread/qthread_unix.cpp:320
#11 0x017cee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0x00a3173e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb265ab70 (LWP 1419)):
#0  0x001be416 in __kernel_vsyscall ()
#1  0x017d348c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0x00a3f3fd in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0x0061a817 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x72e1c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0x0061a851 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x72e1c0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0x017cee99 in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0x00a3173e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb7802720 (LWP 1407)):
[KCrash Handler]
#7  intel_region_buffer (intel=0x8dd1868, region=0x0, flag=2) at intel_regions.c:514
#8  0x0322cce2 in intelClearWithBlit (ctx=0x8dd1868, mask=2) at intel_blit.c:262
#9  0x0322f4c0 in intelClear (ctx=0x8dd1868, mask=2) at intel_clear.c:177
#10 0x032f5512 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0x008a184b in KWin::SceneOpenGL::paintBackground (this=0x8dfed70, region=...) at ../../kwin/scene_opengl.cpp:921
#12 0x00898562 in KWin::Scene::paintGenericScreen (this=0x8dfed70, orig_mask=32) at ../../kwin/scene.cpp:188
#13 0x008a1a31 in KWin::SceneOpenGL::paintGenericScreen (this=0x8dfed70, mask=32, data=...) at ../../kwin/scene_opengl.cpp:909
#14 0x008957c0 in KWin::Scene::finalPaintScreen (this=0x8dfed70, mask=32, region=..., data=...) at ../../kwin/scene.cpp:178
#15 0x008b70fc in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=32, region=..., data=...) at ../../kwin/effects.cpp:173
#16 0x036310e9 in KWin::StartupFeedbackEffect::paintScreen (this=0x9281838, mask=32, region=..., data=...) at ../../../kwin/effects/startupfeedback/startupfeedback.cpp:166
#17 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#18 0x00742256 in KWin::Effect::paintScreen (this=0x92f0708, mask=32, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#19 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#20 0x035d307f in KWin::LogoutEffect::paintScreen (this=0x91ef328, mask=32, region=..., data=...) at ../../../kwin/effects/logout/logout.cpp:207
#21 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#22 0x035eeb10 in KWin::ShadowEffect::paintScreen (this=0x9369970, mask=32, region=..., data=...) at ../../../kwin/effects/shadow/shadow.cpp:189
#23 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=32, region=..., data=...) at ../../kwin/effects.cpp:169
#24 0x03603013 in KWin::BlurEffect::paintScreen (this=0x915e8b8, mask=32, region=..., data=...) at ../../../kwin/effects/blur/blur.cpp:230
#25 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#26 0x035d7e6f in KWin::PresentWindowsEffect::paintScreen (this=0x9368aa0, mask=0, region=..., data=...) at ../../../kwin/effects/presentwindows/presentwindows.cpp:205
#27 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#28 0x00742256 in KWin::Effect::paintScreen (this=0x931ea60, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#29 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#30 0x00742256 in KWin::Effect::paintScreen (this=0x939f978, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#31 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#32 0x00742256 in KWin::Effect::paintScreen (this=0x91c2bf8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#33 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#34 0x00742256 in KWin::Effect::paintScreen (this=0x91badc8, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#35 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#36 0x03622202 in KWin::FlipSwitchEffect::paintScreen (this=0x91692a0, mask=0, region=..., data=...) at ../../../kwin/effects/flipswitch/flipswitch.cpp:148
#37 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#38 0x035be7e9 in KWin::DesktopGridEffect::paintScreen (this=0x92fcc28, mask=0, region=..., data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#39 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#40 0x035b7799 in KWin::BoxSwitchEffect::paintScreen (this=0x92833f8, mask=0, region=..., data=...) at ../../../kwin/effects/boxswitch/boxswitch.cpp:143
#41 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#42 0x03611bcc in KWin::CubeEffect::paintScreen (this=0x9281bb0, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cube.cpp:698
#43 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#44 0x00742256 in KWin::Effect::paintScreen (this=0x9295398, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#45 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#46 0x0361adf0 in KWin::CubeSlideEffect::paintScreen (this=0x92658b0, mask=0, region=..., data=...) at ../../../kwin/effects/cube/cubeslide.cpp:111
#47 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#48 0x00742256 in KWin::Effect::paintScreen (this=0x9267478, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#49 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#50 0x00742256 in KWin::Effect::paintScreen (this=0x927dc40, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#51 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#52 0x0360aa0c in KWin::CoverSwitchEffect::paintScreen (this=0x92ac2d8, mask=0, region=..., data=...) at ../../../kwin/effects/coverswitch/coverswitch.cpp:126
#53 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#54 0x00742256 in KWin::Effect::paintScreen (this=0x9161d88, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#55 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#56 0x00742256 in KWin::Effect::paintScreen (this=0x9284858, mask=0, region=..., data=...) at ../../../kwin/lib/kwineffects.cpp:227
#57 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#58 0x036000c1 in KWin::ZoomEffect::paintScreen (this=0x91ee930, mask=0, region=..., data=...) at ../../../kwin/effects/zoom/zoom.cpp:341
#59 0x008b7172 in KWin::EffectsHandlerImpl::paintScreen (this=0x8f62818, mask=0, region=..., data=...) at ../../kwin/effects.cpp:169
#60 0x0089698c in KWin::Scene::paintScreen (this=0x8dfed70, mask=0xbfdb5a48, region=0xbfdb5ad0) at ../../kwin/scene.cpp:137
#61 0x008ad962 in KWin::SceneOpenGL::paint (this=0x8dfed70, damage=..., toplevels=...) at ../../kwin/scene_opengl.cpp:772
#62 0x00892886 in KWin::Workspace::performCompositing (this=0x90fc4d0) at ../../kwin/composite.cpp:448
#63 0x03af4214 in QObject::event (this=0x90fc4d0, e=0xbfdb5ffc) at kernel/qobject.cpp:1190
#64 0x02010d24 in QApplicationPrivate::notify_helper (this=0x8d14020, receiver=0x90fc4d0, e=0xbfdb5ffc) at kernel/qapplication.cpp:4462
#65 0x020158ce in QApplication::notify (this=0xbfdb6314, receiver=0x90fc4d0, e=0xbfdb5ffc) at kernel/qapplication.cpp:3862
#66 0x00ca33ca in KApplication::notify (this=0xbfdb6314, receiver=0x90fc4d0, event=0xbfdb5ffc) at ../../kdeui/kernel/kapplication.cpp:311
#67 0x00821abf in KWin::Application::notify (this=0xbfdb6314, o=0x90fc4d0, e=0xbfdb5ffc) at ../../kwin/main.cpp:376
#68 0x03adf0bb in QCoreApplication::notifyInternal (this=0xbfdb6314, receiver=0x90fc4d0, event=0xbfdb5ffc) at kernel/qcoreapplication.cpp:731
#69 0x03b0f1e4 in sendEvent (this=0x8d18a98) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#70 QTimerInfoList::activateTimers (this=0x8d18a98) at kernel/qeventdispatcher_unix.cpp:604
#71 0x03b0f338 in QEventDispatcherUNIX::processEvents (this=0x8cd2aa8, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#72 0x020c57ea in QEventDispatcherX11::processEvents (this=0x8cd2aa8, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#73 0x03ade289 in QEventLoop::processEvents (this=0xbfdb6254, flags=...) at kernel/qeventloop.cpp:149
#74 0x03ade522 in QEventLoop::exec (this=0xbfdb6254, flags=...) at kernel/qeventloop.cpp:201
#75 0x03ae2ecc in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#76 0x0200e8e7 in QApplication::exec () at kernel/qapplication.cpp:3736
#77 0x008245b2 in kdemain (argc=3, argv=0xbfdb6594) at ../../kwin/main.cpp:542
#78 0x080485bb in main (argc=3, argv=0xbfdb6594) at kwin_dummy.cpp:3

Possible duplicates by query: bug 272690, bug 272646, bug 272524, bug 272506, bug 272484.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-05-07 14:24:28 UTC
driver bug

*** This bug has been marked as a duplicate of bug 252817 ***