Bug 271876

Summary: Plasma desktop crash while listening to music in Amarok (with trace)
Product: plasma4 Reporter: Johan Persson <johanp>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: lamarque
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: openSUSE RPMs   
OS: Linux   
Latest Commit: Version Fixed In:

Description Johan Persson 2011-04-27 23:11:52 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.6.2 (4.6.2)
Qt Version: 4.7.2
Operating System: Linux 2.6.37.1-1.2-desktop i686
Distribution: "openSUSE 11.4 (i586)"

-- Information about the crash:
- What I was doing when the application crashed:

Browsing WEB and listening to Amarok. Started to notice slowdown and a non responsive systray. Took anywhere between 5-10 second to get respons from desktop panel. Finally Plasma desktop crashed.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb58d3710 (LWP 21725))]

Thread 2 (Thread 0xa82ffb70 (LWP 21731)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb60d603e in poll () from /lib/libc.so.6
#2  0xb5b4d0bb in g_poll () from /lib/libglib-2.0.so.0
#3  0xb5b3cc46 in ?? () from /lib/libglib-2.0.so.0
#4  0xb5b3cfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0xb6ecefc7 in QEventDispatcherGlib::processEvents (this=0x87d0b40, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#6  0xb6e9fa6d in QEventLoop::processEvents (this=0xa82ff200, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6e9fc99 in QEventLoop::exec (this=0xa82ff200, flags=...) at kernel/qeventloop.cpp:201
#8  0xb6da0d49 in QThread::exec (this=0x87bb7a0) at thread/qthread.cpp:492
#9  0xb6e7f7fd in QInotifyFileSystemWatcherEngine::run (this=0x87bb7a0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0xb6da3993 in QThreadPrivate::start (arg=0x87bb7a0) at thread/qthread_unix.cpp:320
#11 0xb2dc1de7 in ?? () from /usr/X11R6/lib/libGL.so.1
#12 0xb60e0d5e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb58d3710 (LWP 21725)):
[KCrash Handler]
#7  0xb74e1d33 in QString (this=0x9240061, group=0, state=0) at /usr/include/QtCore/qstring.h:728
#8  KIconEffect::fingerprint (this=0x9240061, group=0, state=0) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconeffect.cpp:169
#9  0xb74e3638 in KIconLoaderPrivate::makeCacheKey (this=0x924004d, name=..., group=KIconLoader::Desktop, overlays=..., size=24, state=0) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconloader.cpp:782
#10 0xb763a73c in KIconLoader::loadIcon (this=0x900f280, _name=..., group=KIconLoader::Desktop, size=24, state=0, overlays=..., path_store=0x0, canReturnNull=false) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconloader.cpp:1226
#11 0xb763ba34 in KIconEngine::pixmap (this=0x91ecdc8, size=..., mode=QIcon::Normal, state=QIcon::Off) at /usr/src/debug/kdelibs-4.6.2/kdeui/icons/kiconengine.cpp:93
#12 0xb64616c4 in QIcon::pixmap (this=0x92aa28c, size=..., mode=QIcon::Normal, state=QIcon::Off) at image/qicon.cpp:676
#13 0xb4d4f621 in Plasma::IconWidgetPrivate::decoration (this=0x92aa1e8, option=0x81076a0, useHoverEffect=false, usePressedEffect=false) at /usr/src/debug/kdelibs-4.6.2/plasma/widgets/iconwidget.cpp:812
#14 0xb4d566f4 in Plasma::IconWidget::paint (this=0x823de38, painter=0xbfd0b8dc, option=0x81076a0, widget=0x0) at /usr/src/debug/kdelibs-4.6.2/plasma/widgets/iconwidget.cpp:1128
#15 0xae48929a in SystemTray::DBusSystemTrayWidget::paint (this=0x823de38, painter=0xbfd0b8dc, option=0x81076a0, widget=0x0) at /usr/src/debug/kdebase-workspace-4.6.2/plasma/generic/applets/systemtray/protocols/dbussystemtray/dbussystemtraywidget.cpp:189
#16 0xb6a3b375 in _q_paintItem (item=<value optimized out>, painter=0xbfd0b8dc, option=0x81076a0, widget=0x0, useWindowOpacity=false, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4314
#17 0xb6a3b6ca in _q_paintIntoCache (pix=0xbfd0bdbc, item=0x823de40, pixmapExposed=..., itemToPixmap=..., renderHints=) at graphicsview/qgraphicsscene.cpp:4352
#18 0xb6a507d8 in QGraphicsScenePrivate::drawItemHelper (this=0x8107550, item=0x823de40, painter=0xbfd0d5f4, option=0x81076a0, widget=0x8a76bf0, painterStateProtection=true) at graphicsview/qgraphicsscene.cpp:4690
#19 0xb6a51482 in QGraphicsScenePrivate::draw (this=0x8107550, item=0x823de40, painter=0xbfd0d5f4, viewTransform=0xbfd0d3dc, transformPtr=0xbfd0c1b0, exposedRegion=0x8a63f48, widget=0x8a76bf0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4962
#20 0xb6a5221e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8107550, item=0x823de40, painter=0xbfd0d5f4, viewTransform=0xbfd0d3dc, exposedRegion=0x8a63f48, widget=0x8a76bf0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#21 0xb6a512af in QGraphicsScenePrivate::draw (this=0x8107550, item=0x8391160, painter=0xbfd0d5f4, viewTransform=0xbfd0d3dc, transformPtr=0xbfd0c660, exposedRegion=0x8a63f48, widget=0x8a76bf0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#22 0xb6a5221e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8107550, item=0x8391160, painter=0xbfd0d5f4, viewTransform=0xbfd0d3dc, exposedRegion=0x8a63f48, widget=0x8a76bf0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#23 0xb6a512af in QGraphicsScenePrivate::draw (this=0x8107550, item=0x835ecf0, painter=0xbfd0d5f4, viewTransform=0xbfd0d3dc, transformPtr=0xbfd0cb10, exposedRegion=0x8a63f48, widget=0x8a76bf0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#24 0xb6a5221e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8107550, item=0x835ecf0, painter=0xbfd0d5f4, viewTransform=0xbfd0d3dc, exposedRegion=0x8a63f48, widget=0x8a76bf0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#25 0xb6a512af in QGraphicsScenePrivate::draw (this=0x8107550, item=0x8245978, painter=0xbfd0d5f4, viewTransform=0xbfd0d3dc, transformPtr=0xbfd0cfc0, exposedRegion=0x8a63f48, widget=0x8a76bf0, opacity=1, effectTransform=0x0, wasDirtyParentSceneTransform=false, drawItem=true) at graphicsview/qgraphicsscene.cpp:4979
#26 0xb6a5221e in QGraphicsScenePrivate::drawSubtreeRecursive (this=0x8107550, item=0x8245978, painter=0xbfd0d5f4, viewTransform=0xbfd0d3dc, exposedRegion=0x8a63f48, widget=0x8a76bf0, parentOpacity=1, effectTransform=0x0) at graphicsview/qgraphicsscene.cpp:4853
#27 0xb6a52ac7 in QGraphicsScenePrivate::drawItems (this=0x8107550, painter=0xbfd0d5f4, viewTransform=0xbfd0d3dc, exposedRegion=0x8a63f48, widget=0x8a76bf0) at graphicsview/qgraphicsscene.cpp:4735
#28 0xb6a739be in QGraphicsView::paintEvent (this=0x8a63478, event=0x0) at graphicsview/qgraphicsview.cpp:3469
#29 0xb0e29f13 in PanelView::paintEvent (this=0x8a63478, event=0xbfd0dcd4) at /usr/src/debug/kdebase-workspace-4.6.2/plasma/desktop/shell/panelview.cpp:1593
#30 0xb6403b4a in QWidget::event (this=0x8a63478, event=0xbfd0dcd4) at kernel/qwidget.cpp:8405
#31 0xb68130f5 in QFrame::event (this=0x8a63478, e=0xbfd0dcd4) at widgets/qframe.cpp:557
#32 0xb68a4b91 in QAbstractScrollArea::viewportEvent (this=0x8a63478, e=0xbfd0dcd4) at widgets/qabstractscrollarea.cpp:1043
#33 0xb6a74ddc in QGraphicsView::viewportEvent (this=0x8a63478, event=0xbfd0dcd4) at graphicsview/qgraphicsview.cpp:2864
#34 0xb68a7486 in viewportEvent (this=0x88ef2f8, o=0x8a76bf0, e=0xbfd0dcd4) at widgets/qabstractscrollarea_p.h:100
#35 QAbstractScrollAreaFilter::eventFilter (this=0x88ef2f8, o=0x8a76bf0, e=0xbfd0dcd4) at widgets/qabstractscrollarea_p.h:116
#36 0xb6ea0926 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8108a20, receiver=0x8a76bf0, event=0xbfd0dcd4) at kernel/qcoreapplication.cpp:846
#37 0xb63a8654 in QApplicationPrivate::notify_helper (this=0x8108a20, receiver=0x8a76bf0, e=0xbfd0dcd4) at kernel/qapplication.cpp:4458
#38 0xb63b14d4 in QApplication::notify (this=0x80feec0, receiver=0x8a76bf0, e=0xbfd0dcd4) at kernel/qapplication.cpp:4341
#39 0xb74fc5b1 in KApplication::notify (this=0x80feec0, receiver=0x8a76bf0, event=0xbfd0dcd4) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#40 0xb6ea078e in QCoreApplication::notifyInternal (this=0x80feec0, receiver=0x8a76bf0, event=0xbfd0dcd4) at kernel/qcoreapplication.cpp:731
#41 0xb64007e2 in sendSpontaneousEvent (this=0x8a76c08, pdev=0x8a76e94, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a62950) at ../../src/corelib/kernel/qcoreapplication.h:218
#42 QWidgetPrivate::drawWidget (this=0x8a76c08, pdev=0x8a76e94, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a62950) at kernel/qwidget.cpp:5492
#43 0xb6401537 in QWidgetPrivate::paintSiblingsRecursive (this=0x8a63bf8, pdev=0x8a76e94, siblings=..., index=<value optimized out>, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a62950) at kernel/qwidget.cpp:5699
#44 0xb64013fd in QWidgetPrivate::paintSiblingsRecursive (this=0x8a63bf8, pdev=0x8a76e94, siblings=..., index=4, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a62950) at kernel/qwidget.cpp:5686
#45 0xb64013fd in QWidgetPrivate::paintSiblingsRecursive (this=0x8a63bf8, pdev=0x8a76e94, siblings=..., index=5, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x8a62950) at kernel/qwidget.cpp:5686
#46 0xb6400538 in QWidgetPrivate::drawWidget (this=0x8a63bf8, pdev=0x8a76e94, rgn=..., offset=..., flags=5, sharedPainter=0x0, backingStore=0x8a62950) at kernel/qwidget.cpp:5545
#47 0xb65ef198 in QWidgetBackingStore::sync (this=0x8a62950) at painting/qbackingstore.cpp:1333
#48 0xb63f545b in QWidgetPrivate::syncBackingStore (this=0x8a63bf8) at kernel/qwidget.cpp:1842
#49 0xb640461a in QWidget::event (this=0x8a63478, event=0x900f280) at kernel/qwidget.cpp:8552
#50 0xb68130f5 in QFrame::event (this=0x8a63478, e=0x900f280) at widgets/qframe.cpp:557
#51 0xb68a6914 in QAbstractScrollArea::event (this=0x8a63478, e=0x900f280) at widgets/qabstractscrollarea.cpp:996
#52 0xb6a675c8 in QGraphicsView::event (this=0x8a63478, event=0x900f280) at graphicsview/qgraphicsview.cpp:2741
#53 0xb0e2a169 in PanelView::event (this=0x8a63478, event=0x900f280) at /usr/src/debug/kdebase-workspace-4.6.2/plasma/desktop/shell/panelview.cpp:1604
#54 0xb63a8684 in QApplicationPrivate::notify_helper (this=0x8108a20, receiver=0x8a63478, e=0x900f280) at kernel/qapplication.cpp:4462
#55 0xb63b14d4 in QApplication::notify (this=0x80feec0, receiver=0x8a63478, e=0x900f280) at kernel/qapplication.cpp:4341
#56 0xb74fc5b1 in KApplication::notify (this=0x80feec0, receiver=0x8a63478, event=0x900f280) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#57 0xb6ea078e in QCoreApplication::notifyInternal (this=0x80feec0, receiver=0x8a63478, event=0x900f280) at kernel/qcoreapplication.cpp:731
#58 0xb6ea451c in sendEvent (receiver=0x8a63478, event_type=77, data=0x80582a0) at kernel/qcoreapplication.h:215
#59 QCoreApplicationPrivate::sendPostedEvents (receiver=0x8a63478, event_type=77, data=0x80582a0) at kernel/qcoreapplication.cpp:1372
#60 0xb6ea466c in QCoreApplication::sendPostedEvents (receiver=0x8a63478, event_type=77) at kernel/qcoreapplication.cpp:1265
#61 0xb6a4879e in dispatchPendingUpdateRequests (this=0x8107550) at ../../src/gui/graphicsview/qgraphicsview_p.h:189
#62 QGraphicsScenePrivate::_q_processDirtyItems (this=0x8107550) at graphicsview/qgraphicsscene.cpp:510
#63 0xb6a48bb3 in QGraphicsScene::qt_metacall (this=0x810dcf8, _c=QMetaObject::InvokeMetaMethod, _id=14, _a=0x8ef2988) at .moc/release-shared/moc_qgraphicsscene.cpp:130
#64 0xb4c8c392 in Plasma::Corona::qt_metacall (this=0x810dcf8, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x8ef2988) at /usr/src/debug/kdelibs-4.6.2/build/plasma/corona.moc:109
#65 0xb0e1c192 in DesktopCorona::qt_metacall (this=0x810dcf8, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x8ef2988) at /usr/src/debug/kdebase-workspace-4.6.2/build/plasma/desktop/shell/desktopcorona.moc:101
#66 0xb6ea707d in QMetaObject::metacall (object=0x810dcf8, cl=QMetaObject::InvokeMetaMethod, idx=18, argv=0x8ef2988) at kernel/qmetaobject.cpp:237
#67 0xb6eb1b55 in QMetaCallEvent::placeMetaCall (this=0x92d40c8, object=0x810dcf8) at kernel/qobject.cpp:535
#68 0xb6eb5dbf in QObject::event (this=0x810dcf8, e=0x92d40c8) at kernel/qobject.cpp:1217
#69 0xb6a567a0 in QGraphicsScene::event (this=0x810dcf8, event=0x92d40c8) at graphicsview/qgraphicsscene.cpp:3544
#70 0xb63a8684 in QApplicationPrivate::notify_helper (this=0x8108a20, receiver=0x810dcf8, e=0x92d40c8) at kernel/qapplication.cpp:4462
#71 0xb63b1427 in QApplication::notify (this=0x80feec0, receiver=0x810dcf8, e=0x92d40c8) at kernel/qapplication.cpp:3862
#72 0xb74fc5b1 in KApplication::notify (this=0x80feec0, receiver=0x810dcf8, event=0x92d40c8) at /usr/src/debug/kdelibs-4.6.2/kdeui/kernel/kapplication.cpp:311
#73 0xb6ea078e in QCoreApplication::notifyInternal (this=0x80feec0, receiver=0x810dcf8, event=0x92d40c8) at kernel/qcoreapplication.cpp:731
#74 0xb6ea451c in sendEvent (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.h:215
#75 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x80582a0) at kernel/qcoreapplication.cpp:1372
#76 0xb6ea466c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1265
#77 0xb6ecedf4 in sendPostedEvents (s=0x810a180) at kernel/qcoreapplication.h:220
#78 postEventSourceDispatch (s=0x810a180) at kernel/qeventdispatcher_glib.cpp:277
#79 0xb5b3c509 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#80 0xb5b3cd10 in ?? () from /lib/libglib-2.0.so.0
#81 0xb5b3cfce in g_main_context_iteration () from /lib/libglib-2.0.so.0
#82 0xb6ecef7b in QEventDispatcherGlib::processEvents (this=0x805cc38, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#83 0xb645f1da in QGuiEventDispatcherGlib::processEvents (this=0x805cc38, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#84 0xb6e9fa6d in QEventLoop::processEvents (this=0xbfd0f794, flags=...) at kernel/qeventloop.cpp:149
#85 0xb6e9fc99 in QEventLoop::exec (this=0xbfd0f794, flags=...) at kernel/qeventloop.cpp:201
#86 0xb6ea4740 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1008
#87 0xb63a63d4 in QApplication::exec () at kernel/qapplication.cpp:3736
#88 0xb0e23ada in kdemain (argc=1, argv=0x80ef160) at /usr/src/debug/kdebase-workspace-4.6.2/plasma/desktop/shell/main.cpp:118
#89 0x0804e514 in _start ()

This bug may be a duplicate of or related to bug 271801.

Possible duplicates by query: bug 271845, bug 271801, bug 271782, bug 271550, bug 271256.

Reported using DrKonqi
Comment 1 Lamarque V. Souza 2011-04-28 21:21:36 UTC

*** This bug has been marked as a duplicate of bug 258706 ***