Bug 268975

Summary: kwrite crashes (_not_ closes!!, when close by button
Product: kate Reporter: Axel Krebs <axel.krebs>
Component: kwriteAssignee: KWrite Developers <kwrite-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: aseigo, cfeck, cullmann
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: BleachBit settings I assume to be related to Christophs question

Description Axel Krebs 2011-03-20 19:54:07 UTC
Application: kwrite (4.6.1 (4.6.1))
KDE Platform Version: 4.6.1 (4.6.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-28-generic-pae i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
I just wanted to close write by clicking on "close"-button.
Instead of closing, kwrite crashed.

-- Backtrace:
Application: KWrite (kwrite), signal: Bus error
[Current thread is 1 (Thread 0xb52379f0 (LWP 2091))]

Thread 3 (Thread 0xb4c6db70 (LWP 2101)):
#0  0xb78c3424 in __kernel_vsyscall ()
#1  0xb77f9df6 in poll () from /lib/libc.so.6
#2  0xb57a8a1b in g_poll () from /lib/libglib-2.0.so.0
#3  0xb579b43c in ?? () from /lib/libglib-2.0.so.0
#4  0xb579bba7 in g_main_loop_run () from /lib/libglib-2.0.so.0
#5  0xb4d969c4 in ?? () from /usr/lib/libgio-2.0.so.0
#6  0xb57c248f in ?? () from /lib/libglib-2.0.so.0
#7  0xb5845cc9 in start_thread () from /lib/libpthread.so.0
#8  0xb780869e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xb1129b70 (LWP 2478)):
#0  0xb78c3424 in __kernel_vsyscall ()
#1  0xb584a4dc in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb7815d9d in pthread_cond_wait () from /lib/libc.so.6
#3  0xb1443877 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0xb15421a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#4  0xb14438c1 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb15421a0) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#5  0xb5845cc9 in start_thread () from /lib/libpthread.so.0
#6  0xb780869e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb52379f0 (LWP 2091)):
[KCrash Handler]
#7  0xb652c42c in KSharedDataCache::Private::CacheLocker::CacheLocker(KSharedDataCache::Private const*) () from /usr/lib/libkdecore.so.5
#8  0xb65294a3 in KSharedDataCache::find (this=0x9b2d830, key=..., destination=0xbfa45d6c) at ../../kdecore/util/kshareddatacache.cpp:1462
#9  0xb71dd778 in KIconLoaderPrivate::findCachedPixmapWithPath (this=0x9b2b228, key=..., data=..., path=...) at ../../kdeui/icons/kiconloader.cpp:868
#10 0xb71e4f5f in KIconLoader::loadIcon (this=0x9b29db0, _name=..., group=KIconLoader::Desktop, size=22, state=1, overlays=..., path_store=0x0, canReturnNull=false) at ../../kdeui/icons/kiconloader.cpp:1231
#11 0xb71db3f6 in KIconEngine::pixmap (this=0xa172230, size=..., mode=QIcon::Active, state=QIcon::Off) at ../../kdeui/icons/kiconengine.cpp:93
#12 0xb675d626 in QIcon::pixmap (this=0xbfa47d04, size=..., mode=QIcon::Active, state=QIcon::Off) at image/qicon.cpp:676
#13 0xb6a08e4c in QCommonStyle::drawControl (this=0x9afc928, element=QStyle::CE_ToolButtonLabel, opt=0xbfa47ccc, p=0xbfa49b34, widget=0xa18bee0) at styles/qcommonstyle.cpp:1598
#14 0xb6ab0239 in QWindowsStyle::drawControl (this=0x9afc928, ce=QStyle::CE_ToolButtonLabel, opt=0xbfa47ccc, p=0xbfa49b34, widget=0xa18bee0) at styles/qwindowsstyle.cpp:2560
#15 0xb6a9a0c4 in QCleanlooksStyle::drawControl (this=0x9afc928, element=QStyle::CE_ToolButtonLabel, option=0xbfa47ccc, painter=0xbfa49b34, widget=0xa18bee0) at styles/qcleanlooksstyle.cpp:2367
#16 0xb6a10eb1 in QCommonStyle::drawComplexControl (this=0x9afc928, cc=QStyle::CC_ToolButton, opt=0xbfa49ad4, p=0xbfa49b34, widget=0xa18bee0) at styles/qcommonstyle.cpp:3370
#17 0xb6ab5ef3 in QWindowsStyle::drawComplexControl (this=0x9afc928, cc=-1282453504, opt=0xbfa49ad4, p=0xbfa49b34, widget=0xa18bee0) at styles/qwindowsstyle.cpp:3159
#18 0xb6aa0e03 in QCleanlooksStyle::drawComplexControl (this=0x9afc928, control=QStyle::CC_ToolButton, option=0xbfa49ad4, painter=0xbfa49b34, widget=0xa18bee0) at styles/qcleanlooksstyle.cpp:3702
#19 0xb6bb216e in drawComplexControl (this=0xa18bee0) at ../../include/QtGui/../../src/gui/painting/qstylepainter.h:94
#20 QToolButton::paintEvent (this=0xa18bee0) at widgets/qtoolbutton.cpp:556
#21 0xb66f6cc6 in QWidget::event (this=0xa18bee0, event=0xbfa4a134) at kernel/qwidget.cpp:8333
#22 0xb6ac6e9e in QAbstractButton::event (this=0xa18bee0, e=0x0) at widgets/qabstractbutton.cpp:1080
#23 0xb6bb20ca in QToolButton::event (this=0xa18bee0, event=0xbfa4a134) at widgets/qtoolbutton.cpp:1163
#24 0xb6698fdc in QApplicationPrivate::notify_helper (this=0x9abb2a8, receiver=0xa18bee0, e=0xbfa4a134) at kernel/qapplication.cpp:4396
#25 0xb669f0e9 in QApplication::notify (this=0xbfa4b480, receiver=0xa18bee0, e=0xbfa4a134) at kernel/qapplication.cpp:4361
#26 0xb72407da in KApplication::notify (this=0xbfa4b480, receiver=0xa18bee0, event=0xbfa4a134) at ../../kdeui/kernel/kapplication.cpp:311
#27 0xb618fb3b in QCoreApplication::notifyInternal (this=0xbfa4b480, receiver=0xa18bee0, event=0xbfa4a134) at kernel/qcoreapplication.cpp:732
#28 0xb66fdee6 in sendSpontaneousEvent (this=0xa18cdc0, pdev=0xa0dd204, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9ac9820) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#29 QWidgetPrivate::drawWidget (this=0xa18cdc0, pdev=0xa0dd204, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9ac9820) at kernel/qwidget.cpp:5420
#30 0xb66fecff in QWidgetPrivate::paintSiblingsRecursive (this=0xa18f268, pdev=0xa0dd204, siblings=..., index=22, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9ac9820) at kernel/qwidget.cpp:5627
#31 0xb66fdc35 in QWidgetPrivate::drawWidget (this=0xa18f268, pdev=0xa0dd204, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9ac9820) at kernel/qwidget.cpp:5473
#32 0xb66fecff in QWidgetPrivate::paintSiblingsRecursive (this=0x9bfd220, pdev=0xa0dd204, siblings=..., index=22, rgn=..., offset=..., flags=4, sharedPainter=0x0, backingStore=0x9ac9820) at kernel/qwidget.cpp:5627
#33 0xb66fdc35 in QWidgetPrivate::drawWidget (this=0x9bfd220, pdev=0xa0dd204, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x9ac9820) at kernel/qwidget.cpp:5473
#34 0xb68eec74 in QWidgetBackingStore::sync (this=0x9ac9820) at painting/qbackingstore.cpp:1328
#35 0xb66f02b3 in QWidgetPrivate::syncBackingStore (this=0x9bfd220) at kernel/qwidget.cpp:1805
#36 0xb66f7466 in QWidget::event (this=0x9b71bb8, event=0xa017030) at kernel/qwidget.cpp:8480
#37 0xb6b37917 in QMainWindow::event (this=0x9b71bb8, event=0xa017030) at widgets/qmainwindow.cpp:1417
#38 0xb732d224 in KMainWindow::event (this=0x9b71bb8, ev=0xa017030) at ../../kdeui/widgets/kmainwindow.cpp:1100
#39 0xb737907f in KXmlGuiWindow::event (this=0x9b71bb8, ev=0xa017030) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#40 0xb6698fdc in QApplicationPrivate::notify_helper (this=0x9abb2a8, receiver=0x9b71bb8, e=0xa017030) at kernel/qapplication.cpp:4396
#41 0xb669f0e9 in QApplication::notify (this=0xbfa4b480, receiver=0x9b71bb8, e=0xa017030) at kernel/qapplication.cpp:4361
#42 0xb72407da in KApplication::notify (this=0xbfa4b480, receiver=0x9b71bb8, event=0xa017030) at ../../kdeui/kernel/kapplication.cpp:311
#43 0xb618fb3b in QCoreApplication::notifyInternal (this=0xbfa4b480, receiver=0x9b71bb8, event=0xa017030) at kernel/qcoreapplication.cpp:732
#44 0xb6192d8b in sendEvent (receiver=0x0, event_type=0, data=0x9aa3e98) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#45 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9aa3e98) at kernel/qcoreapplication.cpp:1373
#46 0xb6192f4d in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1266
#47 0xb61bea74 in sendPostedEvents (s=0x9abd710) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#48 postEventSourceDispatch (s=0x9abd710) at kernel/qeventdispatcher_glib.cpp:277
#49 0xb5797855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#50 0xb579b668 in ?? () from /lib/libglib-2.0.so.0
#51 0xb579b848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#52 0xb61be565 in QEventDispatcherGlib::processEvents (this=0x9aa3b58, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#53 0xb675abe5 in QGuiEventDispatcherGlib::processEvents (this=0x9aa3b58, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0xb618e609 in QEventLoop::processEvents (this=0xbfa4b3e4, flags=) at kernel/qeventloop.cpp:149
#55 0xb618ea8a in QEventLoop::exec (this=0xbfa4b3e4, flags=...) at kernel/qeventloop.cpp:201
#56 0xb619300f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#57 0xb6697e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#58 0xb78b804b in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_kwrite.so
#59 0x080485ab in _start ()

Possible duplicates by query: bug 263822, bug 261960, bug 254741.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-05-06 17:14:50 UTC
could be related to/caused by BR#258706
Comment 2 Christoph Feck 2011-05-13 01:18:15 UTC
Are you using the BleachBit tool to clean up the system files?
Comment 3 Axel Krebs 2011-05-13 06:00:49 UTC
Created attachment 59950 [details]
BleachBit settings I assume to be related to Christophs question
Comment 4 Axel Krebs 2011-05-13 06:03:15 UTC
Yes, I use BleachBit, but only sometimes and _not_ as root! 
Some settings potentially related as screenshot.
Comment 5 Christoph Cullmann 2011-06-05 17:32:58 UTC

*** This bug has been marked as a duplicate of bug 258706 ***