Bug 268218

Summary: Multiple KWin crashes
Product: [Plasma] kwin Reporter: James Sturgis <jnsturgis>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu   
OS: Linux   
Latest Commit: Version Fixed In:

Description James Sturgis 2011-03-11 13:24:35 UTC
Application: kwin (4.5.1 (KDE 4.5.1))
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-27-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
- What I was doing when the application crashed:
Moving mouse to change desktop

- Unusual behavior I noticed:
Frequent crashes of kwin under several circumstances....
1> When watching a video
2> When changing desktop
3> Using KDevelop

Possibly associated a configuration problem gives very slow animations (sometimes)

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Aborted
[Current thread is 1 (Thread 0xb785f720 (LWP 5660))]

Thread 2 (Thread 0xaefa5b70 (LWP 5666)):
#0  0x00a86e36 in clock_gettime (clock_id=11055092, tp=0xaefa4f50) at ../sysdeps/unix/clock_gettime.c:100
#1  0x0209350b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x0216a6e5 in QTimerInfoList::updateCurrentTime (this=0x8ed94e8) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0216ad55 in QEventDispatcherUNIXPrivate::doSelect (this=0x8ed8e48, flags=..., timeout=0x0) at kernel/qeventdispatcher_unix.cpp:182
#5  0x0216bc25 in QEventDispatcherUNIX::processEvents (this=0x928a768, flags=...) at kernel/qeventdispatcher_unix.cpp:919
#6  0x02138609 in QEventLoop::processEvents (this=0xaefa51d0, flags=) at kernel/qeventloop.cpp:149
#7  0x02138a8a in QEventLoop::exec (this=0xaefa51d0, flags=...) at kernel/qeventloop.cpp:201
#8  0x02034b7e in QThread::exec (this=0x9286a60) at thread/qthread.cpp:490
#9  0x0211735b in QInotifyFileSystemWatcherEngine::run (this=0x9286a60) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x02037df9 in QThreadPrivate::start (arg=0x9286a60) at thread/qthread_unix.cpp:266
#11 0x0090cde7 in ?? () from /usr/lib/libGL.so.1
#12 0x0080269e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb785f720 (LWP 5660)):
[KCrash Handler]
#7  0x0046c416 in __kernel_vsyscall ()
#8  0x0075c941 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#9  0x0075fe42 in abort () at abort.c:92
#10 0x003844af in KWin::EffectWindowImpl::unrefWindow (this=0x9308698) at ../../kwin/effects.cpp:1289
#11 0x03cf1d42 in KWin::DesktopGridEffect::finish (this=0x93deaf0) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:1322
#12 0x03cf493b in KWin::DesktopGridEffect::prePaintScreen (this=0x93deaf0, data=..., time=87) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:146
#13 0x0038685b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x9075ab8, data=..., time=87) at ../../kwin/effects.cpp:158
#14 0x03d2ea71 in KWin::SlideEffect::prePaintScreen (this=0x93f4ab8, data=..., time=87) at ../../../kwin/effects/slide/slide.cpp:60
#15 0x0038685b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x9075ab8, data=..., time=87) at ../../kwin/effects.cpp:158
#16 0x00ac7d30 in KWin::Effect::prePaintScreen (this=0x93dcf38, data=..., time=87) at ../../../kwin/lib/kwineffects.cpp:222
#17 0x0038685b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x9075ab8, data=..., time=87) at ../../kwin/effects.cpp:158
#18 0x03d0cf2e in KWin::MinimizeAnimationEffect::prePaintScreen (this=0x91618b0, data=..., time=87) at ../../../kwin/effects/minimizeanimation/minimizeanimation.cpp:64
#19 0x0038685b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x9075ab8, data=..., time=87) at ../../kwin/effects.cpp:158
#20 0x03d06297 in KWin::LoginEffect::prePaintScreen (this=0x93f7238, data=..., time=87) at ../../../kwin/effects/login/login.cpp:52
#21 0x0038685b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x9075ab8, data=..., time=87) at ../../kwin/effects.cpp:158
#22 0x03d3945d in KWin::ZoomEffect::prePaintScreen (this=0x9451f48, data=..., time=6) at ../../../kwin/effects/zoom/zoom.cpp:59
#23 0x0038685b in KWin::EffectsHandlerImpl::prePaintScreen (this=0x9075ab8, data=..., time=87) at ../../kwin/effects.cpp:158
#24 0x0036b0f6 in KWin::Scene::paintScreen (this=0x8ff4f70, mask=0xbf8493d8, region=0xbf8494a4) at ../../kwin/scene.cpp:116
#25 0x00374e7b in KWin::SceneXrender::paint (this=0x8ff4f70, damage=..., toplevels=...) at ../../kwin/scene_xrender.cpp:278
#26 0x00365be4 in KWin::Workspace::performCompositing (this=0x8f492c0) at ../../kwin/composite.cpp:454
#27 0x002d6c1e in KWin::Workspace::qt_metacall (this=0x8f492c0, _c=QMetaObject::InvokeMetaMethod, _id=190, _a=0xbf8495cc) at ./workspace.moc:583
#28 0x0213f8ca in QMetaObject::metacall (object=0x8f492c0, cl=5660, idx=190, argv=0xbf8495cc) at kernel/qmetaobject.cpp:237
#29 0x021526ad in QMetaObject::activate (sender=0x8f49570, m=0x226c5a4, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3280
#30 0x021a41e7 in QTimer::timeout (this=0x8f49570) at .moc/release-shared/moc_qtimer.cpp:134
#31 0x021581ce in QTimer::timerEvent (this=0x8f49570, e=0xbf849b20) at kernel/qtimer.cpp:271
#32 0x0214c504 in QObject::event (this=0x8f49570, e=0x6) at kernel/qobject.cpp:1183
#33 0x073bffdc in QApplicationPrivate::notify_helper (this=0x8ea0b28, receiver=0x8f49570, e=0xbf849b20) at kernel/qapplication.cpp:4396
#34 0x073c604e in QApplication::notify (this=0xbf849e24, receiver=0x8f49570, e=0xbf849b20) at kernel/qapplication.cpp:3798
#35 0x00cfb68a in KApplication::notify (this=0xbf849e24, receiver=0x8f49570, event=0xbf849b20) at ../../kdeui/kernel/kapplication.cpp:310
#36 0x002f3aef in KWin::Application::notify (this=0xbf849e24, o=0x8f49570, e=0xbf849b20) at ../../kwin/main.cpp:372
#37 0x02139b3b in QCoreApplication::notifyInternal (this=0xbf849e24, receiver=0x8f49570, event=0xbf849b20) at kernel/qcoreapplication.cpp:732
#38 0x0216bad6 in sendEvent (this=0x8ea12b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#39 QTimerInfoList::activateTimers (this=0x8ea12b0) at kernel/qeventdispatcher_unix.cpp:602
#40 0x0216bc37 in QEventDispatcherUNIX::processEvents (this=0x8e83e40, flags=...) at kernel/qeventdispatcher_unix.cpp:923
#41 0x074830d2 in QEventDispatcherX11::processEvents (this=0x8e83e40, flags=...) at kernel/qeventdispatcher_x11.cpp:152
#42 0x02138609 in QEventLoop::processEvents (this=0xbf849d74, flags=) at kernel/qeventloop.cpp:149
#43 0x02138a8a in QEventLoop::exec (this=0xbf849d74, flags=...) at kernel/qeventloop.cpp:201
#44 0x0213d00f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#45 0x073bee07 in QApplication::exec () at kernel/qapplication.cpp:3672
#46 0x002f5c54 in kdemain (argc=3, argv=0xbf84a084) at ../../kwin/main.cpp:531
#47 0x080485ab in main (argc=3, argv=0xbf84a084) at kwin_dummy.cpp:3

This bug may be a duplicate of or related to bug 244813.

Possible duplicates by query: bug 263431, bug 262099, bug 259344, bug 259194, bug 255890.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-03-11 13:59:00 UTC
fixed in 4.5.4 an up

*** This bug has been marked as a duplicate of bug 244813 ***