Bug 266406

Summary: Chrashed when zooming
Product: marble Reporter: Jeppe Bundsgaard <jeppe>
Component: generalAssignee: marble-bugs
Status: RESOLVED DUPLICATE    
Severity: crash CC: alex.buell, nienhueser
Priority: NOR    
Version: unspecified   
Target Milestone: 1.1.0   
Platform: Ubuntu Packages   
OS: Linux   
Latest Commit: Version Fixed In:

Description Jeppe Bundsgaard 2011-02-15 22:49:25 UTC
Application: marble (1.0.0 (Stable Release))
KDE Platform Version: 4.6.00 (4.6.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-26-generic i686
Distribution: Ubuntu 10.10

-- Information about the crash:
I was zooming in using the mouse wheel, when the application suddenly crashed and dissapeared.

-- Backtrace:
Application: Marble Virtual Globe (marble), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77c8710 (LWP 2819))]

Thread 6 (Thread 0xb554cb70 (LWP 2820)):
#0  0x01221e36 in clock_gettime () from /lib/librt.so.1
#1  0x0177650b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x0184d6e5 in QTimerInfoList::updateCurrentTime (this=0x96f5f5c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0184d72a in QTimerInfoList::timerWait (this=0x96f5f5c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0184b7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb554c0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0184b83d in timerSourcePrepare (source=0x0, timeout=0x1225ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x031f3e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x031f4279 in ?? () from /lib/libglib-2.0.so.0
#9  0x031f4848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0184b59f in QEventDispatcherGlib::processEvents (this=0x96f3ab0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x0181b609 in QEventLoop::processEvents (this=0xb554c290, flags=) at kernel/qeventloop.cpp:149
#12 0x0181ba8a in QEventLoop::exec (this=0xb554c290, flags=...) at kernel/qeventloop.cpp:201
#13 0x01717b7e in QThread::exec (this=0x96f3600) at thread/qthread.cpp:490
#14 0x017fa35b in QInotifyFileSystemWatcherEngine::run (this=0x96f3600) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0171adf9 in QThreadPrivate::start (arg=0x96f3600) at thread/qthread_unix.cpp:266
#16 0x01205cc9 in start_thread () from /lib/libpthread.so.0
#17 0x08d5e69e in clone () from /lib/libc.so.6

Thread 5 (Thread 0xb4c83b70 (LWP 2822)):
#0  0x012083eb in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0x08d6bf66 in pthread_mutex_lock () from /lib/libc.so.6
#2  0x031f3b68 in g_main_context_check () from /lib/libglib-2.0.so.0
#3  0x031f445e in ?? () from /lib/libglib-2.0.so.0
#4  0x031f4848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0184b59f in QEventDispatcherGlib::processEvents (this=0x97d64a8, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#6  0x0181b609 in QEventLoop::processEvents (this=0xb4c83290, flags=) at kernel/qeventloop.cpp:149
#7  0x0181ba8a in QEventLoop::exec (this=0xb4c83290, flags=...) at kernel/qeventloop.cpp:201
#8  0x01717b7e in QThread::exec (this=0x96ba390) at thread/qthread.cpp:490
#9  0x017fa35b in QInotifyFileSystemWatcherEngine::run (this=0x96ba390) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0171adf9 in QThreadPrivate::start (arg=0x96ba390) at thread/qthread_unix.cpp:266
#11 0x01205cc9 in start_thread () from /lib/libpthread.so.0
#12 0x08d5e69e in clone () from /lib/libc.so.6

Thread 4 (Thread 0xb4482b70 (LWP 2823)):
#0  0x01221e36 in clock_gettime () from /lib/librt.so.1
#1  0x0177650b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x0184d6e5 in QTimerInfoList::updateCurrentTime (this=0x989208c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0184d72a in QTimerInfoList::timerWait (this=0x989208c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0184b7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xb44820bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0184b83d in timerSourcePrepare (source=0x0, timeout=0x1225ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x031f3e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x031f4279 in ?? () from /lib/libglib-2.0.so.0
#9  0x031f4848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0184b59f in QEventDispatcherGlib::processEvents (this=0x952ea88, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x0181b609 in QEventLoop::processEvents (this=0xb4482290, flags=) at kernel/qeventloop.cpp:149
#12 0x0181ba8a in QEventLoop::exec (this=0xb4482290, flags=...) at kernel/qeventloop.cpp:201
#13 0x01717b7e in QThread::exec (this=0x96e8b88) at thread/qthread.cpp:490
#14 0x017fa35b in QInotifyFileSystemWatcherEngine::run (this=0x96e8b88) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0171adf9 in QThreadPrivate::start (arg=0x96e8b88) at thread/qthread_unix.cpp:266
#16 0x01205cc9 in start_thread () from /lib/libpthread.so.0
#17 0x08d5e69e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xb2c7fb70 (LWP 2830)):
#0  0x0321adea in g_thread_self () from /lib/libglib-2.0.so.0
#1  0x031f4833 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#2  0x0184b59f in QEventDispatcherGlib::processEvents (this=0x99473b0, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#3  0x0181b609 in QEventLoop::processEvents (this=0xb2c7f280, flags=) at kernel/qeventloop.cpp:149
#4  0x0181ba8a in QEventLoop::exec (this=0xb2c7f280, flags=...) at kernel/qeventloop.cpp:201
#5  0x01717b7e in QThread::exec (this=0x96f7798) at thread/qthread.cpp:490
#6  0x007b0f60 in Marble::FileStorageWatcher::run (this=0x96f7798) at ../../../../marble/src/lib/FileStorageWatcher.cpp:401
#7  0x0171adf9 in QThreadPrivate::start (arg=0x96f7798) at thread/qthread_unix.cpp:266
#8  0x01205cc9 in start_thread () from /lib/libpthread.so.0
#9  0x08d5e69e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaf9ffb70 (LWP 2840)):
#0  0x01221e36 in clock_gettime () from /lib/librt.so.1
#1  0x0177650b in do_gettime () at tools/qelapsedtimer_unix.cpp:105
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:119
#3  0x0184d6e5 in QTimerInfoList::updateCurrentTime (this=0x971021c) at kernel/qeventdispatcher_unix.cpp:339
#4  0x0184d72a in QTimerInfoList::timerWait (this=0x971021c, tm=...) at kernel/qeventdispatcher_unix.cpp:442
#5  0x0184b7a8 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xaf9ff0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x0184b83d in timerSourcePrepare (source=0x0, timeout=0x1225ff4) at kernel/qeventdispatcher_glib.cpp:169
#7  0x031f3e6a in g_main_context_prepare () from /lib/libglib-2.0.so.0
#8  0x031f4279 in ?? () from /lib/libglib-2.0.so.0
#9  0x031f4848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#10 0x0184b59f in QEventDispatcherGlib::processEvents (this=0x9700958, flags=...) at kernel/qeventdispatcher_glib.cpp:417
#11 0x0181b609 in QEventLoop::processEvents (this=0xaf9ff290, flags=) at kernel/qeventloop.cpp:149
#12 0x0181ba8a in QEventLoop::exec (this=0xaf9ff290, flags=...) at kernel/qeventloop.cpp:201
#13 0x01717b7e in QThread::exec (this=0x96f14c0) at thread/qthread.cpp:490
#14 0x017fa35b in QInotifyFileSystemWatcherEngine::run (this=0x96f14c0) at io/qfilesystemwatcher_inotify.cpp:248
#15 0x0171adf9 in QThreadPrivate::start (arg=0x96f14c0) at thread/qthread_unix.cpp:266
#16 0x01205cc9 in start_thread () from /lib/libpthread.so.0
#17 0x08d5e69e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb77c8710 (LWP 2819)):
[KCrash Handler]
#7  0x007a1a25 in Marble::AbstractScanlineTextureMapper::pixelValue (this=0x98dd7a8, lon=0.089873285743057321, lat=1.0370691168016015, scanLine=0xb0a56008) at ../../../../marble/src/lib/AbstractScanlineTextureMapper.cpp:163
#8  0x007a3680 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x98dd7a8, viewParams=0x96fc1e4, texColorizer=0x9900e90) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:235
#9  0x007a3883 in Marble::SphericalScanlineTextureMapper::mapTexture (this=0x98dd7a8, painter=0xbfa91d0c, viewParams=0x96fc1e4, dirtyRect=..., texColorizer=0x9900e90) at ../../../../marble/src/lib/SphericalScanlineTextureMapper.cpp:51
#10 0x00797426 in Marble::TextureLayer::paintGlobe (this=0x96fc204, painter=0xbfa91d0c, viewParams=0x96fc1e4, dirtyRect=...) at ../../../../marble/src/lib/TextureLayer.cpp:161
#11 0x006ff1f1 in Marble::MarbleMapPrivate::paintGround (this=0x96fc1d8, painter=..., dirtyRect=...) at ../../../../marble/src/lib/MarbleMap.cpp:188
#12 0x006f04c6 in Marble::MarbleWidget::paintEvent (this=0x96f2bb8, evt=0xbfa922d4) at ../../../../marble/src/lib/MarbleWidget.cpp:805
#13 0x05572cc6 in QWidget::event (this=0x96f2bb8, event=0xbfa922d4) at kernel/qwidget.cpp:8333
#14 0x05514fdc in QApplicationPrivate::notify_helper (this=0x948eab0, receiver=0x96f2bb8, e=0xbfa922d4) at kernel/qapplication.cpp:4396
#15 0x0551b0e9 in QApplication::notify (this=0xbfa93f84, receiver=0x96f2bb8, e=0xbfa922d4) at kernel/qapplication.cpp:4361
#16 0x00d1df7a in KApplication::notify (this=0xbfa93f84, receiver=0x96f2bb8, event=0xbfa922d4) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x0181cb3b in QCoreApplication::notifyInternal (this=0xbfa93f84, receiver=0x96f2bb8, event=0xbfa922d4) at kernel/qcoreapplication.cpp:732
#18 0x05579ee6 in sendSpontaneousEvent (this=0x96f2c78, pdev=0x98b5d04, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x95324d0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#19 QWidgetPrivate::drawWidget (this=0x96f2c78, pdev=0x98b5d04, rgn=..., offset=..., flags=<value optimized out>, sharedPainter=0x0, backingStore=0x95324d0) at kernel/qwidget.cpp:5420
#20 0x0576abff in QWidgetBackingStore::sync (this=0x95324d0) at painting/qbackingstore.cpp:1320
#21 0x0556c2b3 in QWidgetPrivate::syncBackingStore (this=0x9532e40) at kernel/qwidget.cpp:1805
#22 0x05573466 in QWidget::event (this=0x95326d0, event=0xbfa92cb4) at kernel/qwidget.cpp:8480
#23 0x059b3917 in QMainWindow::event (this=0x95326d0, event=0xbfa92cb4) at widgets/qmainwindow.cpp:1417
#24 0x00e0a9c4 in KMainWindow::event (this=0x95326d0, ev=0xbfa92cb4) at ../../kdeui/widgets/kmainwindow.cpp:1100
#25 0x00e5681f in KXmlGuiWindow::event (this=0x95326d0, ev=0xbfa92cb4) at ../../kdeui/xmlgui/kxmlguiwindow.cpp:126
#26 0x05514fdc in QApplicationPrivate::notify_helper (this=0x948eab0, receiver=0x95326d0, e=0xbfa92cb4) at kernel/qapplication.cpp:4396
#27 0x0551b0e9 in QApplication::notify (this=0xbfa93f84, receiver=0x95326d0, e=0xbfa92cb4) at kernel/qapplication.cpp:4361
#28 0x00d1df7a in KApplication::notify (this=0xbfa93f84, receiver=0x95326d0, event=0xbfa92cb4) at ../../kdeui/kernel/kapplication.cpp:311
#29 0x0181cb3b in QCoreApplication::notifyInternal (this=0xbfa93f84, receiver=0x95326d0, event=0xbfa92cb4) at kernel/qcoreapplication.cpp:732
#30 0x05767c17 in sendEvent (widget=0x95326d0, updateImmediately=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#31 sendUpdateRequest (widget=0x95326d0, updateImmediately=<value optimized out>) at painting/qbackingstore.cpp:507
#32 0x0576b431 in QWidgetBackingStore::markDirty (this=0x95324d0, rect=..., widget=0x96f2bb8, updateImmediately=true, invalidateBuffer=false) at painting/qbackingstore.cpp:695
#33 0x0556ecb9 in QWidget::repaint (this=0x96f2bb8, rect=...) at kernel/qwidget.cpp:10237
#34 0x0556edcc in QWidget::repaint (this=0x96f2bb8) at kernel/qwidget.cpp:10193
#35 0x006f3cd4 in repaint (this=0x96f2bb8, newLookAt=..., mode=Marble::Linear) at ../../../../marble/src/lib/MarbleWidget.cpp:272
#36 Marble::MarbleWidget::flyTo (this=0x96f2bb8, newLookAt=..., mode=Marble::Linear) at ../../../../marble/src/lib/MarbleWidget.cpp:1316
#37 0x0071e004 in Marble::MarbleWidgetDefaultInputHandler::Private::ZoomAt (this=0x96fc7a0, marbleWidget=0x96f2bb8, pos=..., newDistance=578.64889226790024) at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:271
#38 0x0072109e in Marble::MarbleWidgetDefaultInputHandler::eventFilter (this=0x974a048, o=0x96f2bb8, e=0xbfa935f4) at ../../../../marble/src/lib/MarbleWidgetInputHandler.cpp:738
#39 0x0181c29a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x948eab0, receiver=0x96f2bb8, event=0xbfa935f4) at kernel/qcoreapplication.cpp:847
#40 0x05514fb9 in QApplicationPrivate::notify_helper (this=0x948eab0, receiver=0x96f2bb8, e=0xbfa935f4) at kernel/qapplication.cpp:4392
#41 0x0551b6f5 in QApplication::notify (this=0xbfa93f84, receiver=0x96f2bb8, e=0xbfa935f4) at kernel/qapplication.cpp:4014
#42 0x00d1df7a in KApplication::notify (this=0xbfa93f84, receiver=0x96f2bb8, event=0xbfa935f4) at ../../kdeui/kernel/kapplication.cpp:311
#43 0x0181cb3b in QCoreApplication::notifyInternal (this=0xbfa93f84, receiver=0x96f2bb8, event=0xbfa935f4) at kernel/qcoreapplication.cpp:732
#44 0x05597963 in sendSpontaneousEvent (this=0x95326d0, global_x=1009, global_y=588, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#45 QETWidget::translateWheelEvent (this=0x95326d0, global_x=1009, global_y=588, delta=120, buttons=..., modifiers=..., orient=Qt::Vertical) at kernel/qapplication_x11.cpp:4441
#46 0x055a93cc in QETWidget::translateMouseEvent (this=0x95326d0, event=<value optimized out>) at kernel/qapplication_x11.cpp:4218
#47 0x055a8151 in QApplication::x11ProcessEvent (this=0xbfa93f84, event=0xbfa93bec) at kernel/qapplication_x11.cpp:3414
#48 0x055d736a in x11EventSourceDispatch (s=0x948d940, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#49 0x031f0855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#50 0x031f4668 in ?? () from /lib/libglib-2.0.so.0
#51 0x031f4848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#52 0x0184b565 in QEventDispatcherGlib::processEvents (this=0x94779c0, flags=...) at kernel/qeventdispatcher_glib.cpp:415
#53 0x055d6be5 in QGuiEventDispatcherGlib::processEvents (this=0x94779c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x0181b609 in QEventLoop::processEvents (this=0xbfa93ee4, flags=) at kernel/qeventloop.cpp:149
#55 0x0181ba8a in QEventLoop::exec (this=0xbfa93ee4, flags=...) at kernel/qeventloop.cpp:201
#56 0x0182000f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#57 0x05513e07 in QApplication::exec () at kernel/qapplication.cpp:3672
#58 0x08064c65 in main (argc=1, argv=0xbfa945a4) at ../../../marble/src/kdemain.cpp:351

Reported using DrKonqi
Comment 1 Dennis Nienhüser 2011-02-19 22:29:56 UTC
*** Bug 266690 has been marked as a duplicate of this bug. ***
Comment 2 Dennis Nienhüser 2011-02-27 10:36:12 UTC

*** This bug has been marked as a duplicate of bug 265599 ***