Bug 264258

Summary: Testing OpenGL Screensavers
Product: [Plasma] kwin Reporter: Cassiano Leal <cassianoleal>
Component: generalAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED DUPLICATE    
Severity: crash CC: traajik
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Debian stable   
OS: Linux   
Latest Commit: Version Fixed In:
Attachments: New crash information added by DrKonqi

Description Cassiano Leal 2011-01-25 15:27:15 UTC
Application: kwin (4.5.1 (KDE 4.5.1))
KDE Platform Version: 4.5.3 (KDE 4.5.3)
Qt Version: 4.7.1
Operating System: Linux 2.6.38-rc2e6510+ x86_64
Distribution: Debian GNU/Linux 6.0 (squeeze)

-- Information about the crash:
- What I was doing when the application crashed:

I chose an OpenGL screensaver and pressed the Test button. After leaving the screensaver, KWin crashed.

- Custom settings of the application:

KWin's effects are configured like this:

Compositing type: OpenGL
Keep window thumbs: Only for Shown Windows
[ ] Disable functionality checks (it's unchecked)

= OpenGL Options =
OpenGL mode: Texture From Pixmap
Texture filter: Bilinear
[x] Enable direct rendering
[x] Use VSync

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[KCrash Handler]
#6  intel_region_buffer (intel=0x46abbb0, region=0x0, flag=2) at intel_regions.c:514
#7  0x00007f8dbc50657f in intelClearWithBlit (ctx=0x46abbb0, mask=<value optimized out>) at intel_blit.c:262
#8  0x00007f8dbc50926a in intelClear (ctx=0x46abbb0, mask=2) at intel_clear.c:177
#9  0x00007f8dd3d0af75 in KWin::SceneOpenGL::paintBackground (this=<value optimized out>, region=<value optimized out>) at ../../kwin/scene_opengl.cpp:892
#10 0x00007f8dd3d00946 in KWin::Scene::paintGenericScreen (this=0x2d951f0, orig_mask=<value optimized out>) at ../../kwin/scene.cpp:187
#11 0x00007f8dd3cfe60a in KWin::Scene::finalPaintScreen (this=0x2d951f0, mask=32, region=<value optimized out>, data=...) at ../../kwin/scene.cpp:177
#12 0x00007f8dd3d17e06 in KWin::EffectsHandlerImpl::paintScreen (this=<value optimized out>, mask=32, region=) at ../../kwin/effects.cpp:172
#13 0x00007f8db78cd56f in KWin::LogoutEffect::paintScreen (this=0x306aa90, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/logout/logout.cpp:207
#14 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#15 0x00007f8db78ed08c in KWin::ShadowEffect::paintScreen (this=0x2de60e0, mask=32, region=) at ../../../kwin/effects/shadow/shadow.cpp:189
#16 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#17 0x00007f8db78fb2be in KWin::BlurEffect::paintScreen (this=<value optimized out>, mask=32, region=) at ../../../kwin/effects/blur/blur.cpp:219
#18 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#19 0x00007f8db78d3b92 in KWin::PresentWindowsEffect::paintScreen (this=0x1c35ae0, mask=32, region=) at ../../../kwin/effects/presentwindows/presentwindows.cpp:196
#20 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#21 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#22 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#23 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#24 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#25 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#26 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#27 0x00007f8db78b7ee9 in KWin::DesktopGridEffect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/effects/desktopgrid/desktopgrid.cpp:155
#28 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#29 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#30 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#31 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#32 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#33 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#34 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#35 0x00007f8db78b2df2 in KWin::BoxSwitchEffect::paintScreen (this=0x1aeef80, mask=32, region=) at ../../../kwin/effects/boxswitch/boxswitch.cpp:142
#36 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#37 0x00007f8db78f1ce5 in KWin::SlideEffect::paintScreen (this=<value optimized out>, mask=<value optimized out>, region=<value optimized out>, data=...) at ../../../kwin/effects/slide/slide.cpp:86
#38 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#39 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#40 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#41 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#42 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#43 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#44 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#45 0x00007f8dd22d3bdf in KWin::Effect::paintScreen (this=<value optimized out>, mask=32, region=<value optimized out>, data=...) at ../../../kwin/lib/kwineffects.cpp:227
#46 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#47 0x00007f8db78facd1 in KWin::ZoomEffect::paintScreen (this=<value optimized out>, mask=32, region=) at ../../../kwin/effects/zoom/zoom.cpp:73
#48 0x00007f8dd3d17e9e in KWin::EffectsHandlerImpl::paintScreen (this=0x2e27280, mask=32, region=) at ../../kwin/effects.cpp:168
#49 0x00007f8dd3d00b35 in KWin::Scene::paintScreen (this=0x2d951f0, mask=0x7fff9de2d71c, region=0x7fff9de2d840) at ../../kwin/scene.cpp:137
#50 0x00007f8dd3d10620 in KWin::SceneOpenGL::paint (this=0x2d951f0, damage=<value optimized out>, toplevels=<value optimized out>) at ../../kwin/scene_opengl.cpp:748
#51 0x00007f8dd3cfaed7 in KWin::Workspace::performCompositing (this=<value optimized out>) at ../../kwin/composite.cpp:454
#52 0x00007f8dd3c7f5cd in KWin::Workspace::qt_metacall (this=0x1b78430, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff9de2d9f0) at ./workspace.moc:583
#53 0x00007f8dd02471f7 in QMetaObject::activate (sender=0x1b788f8, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3272
#54 0x00007f8dd0240889 in QObject::event (this=0x1b788f8, e=0x0) at kernel/qobject.cpp:1175
#55 0x00007f8dcf5924ac in QApplicationPrivate::notify_helper (this=0x1aae6f0, receiver=0x1b788f8, e=0x7fff9de2e130) at kernel/qapplication.cpp:4445
#56 0x00007f8dcf598e4d in QApplication::notify (this=0x7fff9de2e520, receiver=0x1b788f8, e=0x7fff9de2e130) at kernel/qapplication.cpp:4324
#57 0x00007f8dd34c9ef6 in KApplication::notify (this=0x7fff9de2e520, receiver=0x1b788f8, event=0x7fff9de2e130) at ../../kdeui/kernel/kapplication.cpp:310
#58 0x00007f8dd022f4fc in QCoreApplication::notifyInternal (this=0x7fff9de2e520, receiver=0x1b788f8, event=0x7fff9de2e130) at kernel/qcoreapplication.cpp:732
#59 0x00007f8dd025e88e in sendEvent (this=0x1aaf100) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#60 QTimerInfoList::activateTimers (this=0x1aaf100) at kernel/qeventdispatcher_unix.cpp:603
#61 0x00007f8dd025e9dc in QEventDispatcherUNIX::processEvents (this=0x1a8c7a0, flags=) at kernel/qeventdispatcher_unix.cpp:922
#62 0x00007f8dcf64637d in QEventDispatcherX11::processEvents (this=<value optimized out>, flags=) at kernel/qeventdispatcher_x11.cpp:152
#63 0x00007f8dd022e222 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#64 0x00007f8dd022e60c in QEventLoop::exec (this=0x7fff9de2e460, flags=) at kernel/qeventloop.cpp:201
#65 0x00007f8dd02326db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#66 0x00007f8dd3c9a48a in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../kwin/main.cpp:531
#67 0x00007f8dd3903c4d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fff9de2eb28) at libc-start.c:228
#68 0x00000000004006a9 in _start ()

This bug may be a duplicate of or related to bug 257115.

Possible duplicates by query: bug 257115, bug 256128, bug 252824, bug 252817.

Reported using DrKonqi
Comment 1 Thomas L├╝bking 2011-01-25 16:32:13 UTC
driver bug, sorry :-(

try to upgrade mesa and or (globally)
export LIBGL_ALWAYS_INDIRECT=1

*** This bug has been marked as a duplicate of bug 252817 ***
Comment 2 anthony 2011-03-12 08:30:05 UTC
Created attachment 57894 [details]
New crash information added by DrKonqi

kwin (4.6.00 (4.6.0) "release 6") on KDE Platform 4.6.00 (4.6.0) "release 6" using Qt 4.7.1

- What I was doing when the application crashed:

any screensaver test causes kwin to crash(if i remember correctly i had the same issue in 11.3 release).

aswell as the "globe" desktop wallpaper.

-- Backtrace (Reduced):
#7  intel_region_buffer (intel=0x8128ec0, region=0x0, flag=2) at intel_regions.c:514
#8  0xaf5a716a in intelClearWithBlit (ctx=0x8128ec0, mask=2) at intel_blit.c:262
#9  0xaf5a990d in intelClear (ctx=0x8128ec0, mask=2) at intel_clear.c:177
#10 0xaf7a7698 in _mesa_Clear (mask=<value optimized out>) at main/clear.c:241
#11 0xb776febb in KWin::SceneOpenGL::paintBackground (this=0x815cf60, region=...) at /usr/src/debug/kdebase-workspace-4.6.0/kwin/scene_opengl.cpp:921