Bug 263565

Summary: plasma crashes on bootup
Product: [Plasma] plasma4 Reporter: jos poortvliet <jospoortvliet>
Component: generalAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: OpenSUSE   
OS: Linux   
Latest Commit: Version Fixed In:

Description jos poortvliet 2011-01-18 18:33:02 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.5.95 (4.6 RC2)
Qt Version: 4.7.1
Operating System: Linux 2.6.37-39-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

just starting up my laptop... It crashed again once I started it for a second time but then it automatically restarted a third time and came up working...

The crash can be reproduced some of the time.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f32e4e05760 (LWP 2279))]

Thread 3 (Thread 0x7f32d52df710 (LWP 2282)):
#0  0x0000003001e0b39c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f32e09ae634 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f32e0cd0180) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f32e09ae669 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0x7f32e0cde254) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x0000003001e06a4f in start_thread () from /lib64/libpthread.so.0
#4  0x00000030016d082d in clone () from /lib64/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f32d1f85710 (LWP 2285)):
#0  0x000000300423ffb6 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#1  0x0000003004240e69 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x0000003004241510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f32e8630ae6 in QEventDispatcherGlib::processEvents (this=0xdfd9f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f32e8605262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f32e8605475 in QEventLoop::exec (this=0x7f32d1f84de0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f32e85181a4 in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#7  0x00007f32e85e6918 in QInotifyFileSystemWatcherEngine::run (this=0xe34680) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f32e851aa1e in QThreadPrivate::start (arg=0xe34680) at thread/qthread_unix.cpp:285
#9  0x0000003001e06a4f in start_thread () from /lib64/libpthread.so.0
#10 0x00000030016d082d in clone () from /lib64/libc.so.6
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f32e4e05760 (LWP 2279)):
[KCrash Handler]
#6  Plasma::ExtenderItem::group (this=0x12eb790) at /usr/src/debug/kdelibs-4.5.95/plasma/extenders/extenderitem.cpp:479
#7  0x00007f32e25cd316 in Plasma::Extender::itemAddedEvent (this=0x13302a0, item=0x12eb790, pos=...) at /usr/src/debug/kdelibs-4.5.95/plasma/extenders/extender.cpp:492
#8  0x00007f32e25cdb04 in Plasma::ExtenderPrivate::delayItemAddedEvent (this=0x12bb6e0) at /usr/src/debug/kdelibs-4.5.95/plasma/extenders/extender.cpp:814
#9  0x00007f32e25cf3b2 in Plasma::Extender::qt_metacall (this=0x13302a0, _c=QMetaObject::InvokeMetaMethod, _id=3, _a=0xe54e10) at /usr/src/debug/kdelibs-4.5.95/build/plasma/extender.moc:105
#10 0x00007f32e8619c6a in QObject::event (this=0x13302a0, e=<value optimized out>) at kernel/qobject.cpp:1211
#11 0x00007f32e7fe7aab in QGraphicsWidget::event (this=0x13302a0, event=0x130da80) at graphicsview/qgraphicswidget.cpp:1407
#12 0x00007f32e79c2cd4 in QApplicationPrivate::notify_helper (this=0x6f3270, receiver=0x13302a0, e=0x130da80) at kernel/qapplication.cpp:4445
#13 0x00007f32e79cb1ca in QApplication::notify (this=<value optimized out>, receiver=0x13302a0, e=0x130da80) at kernel/qapplication.cpp:4324
#14 0x00007f32e92beec6 in KApplication::notify (this=0x6b4f40, receiver=0x13302a0, event=0x130da80) at /usr/src/debug/kdelibs-4.5.95/kdeui/kernel/kapplication.cpp:311
#15 0x00007f32e8605e2c in QCoreApplication::notifyInternal (this=0x6b4f40, receiver=0x13302a0, event=0x130da80) at kernel/qcoreapplication.cpp:732
#16 0x00007f32e8609625 in sendEvent (receiver=0x0, event_type=0, data=0x610420) at kernel/qcoreapplication.h:215
#17 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x610420) at kernel/qcoreapplication.cpp:1373
#18 0x00007f32e86308f3 in sendPostedEvents (s=0x6f67d0) at kernel/qcoreapplication.h:220
#19 postEventSourceDispatch (s=0x6f67d0) at kernel/qeventdispatcher_glib.cpp:277
#20 0x0000003004240a93 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#21 0x0000003004241270 in ?? () from /usr/lib64/libglib-2.0.so.0
#22 0x0000003004241510 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#23 0x00007f32e8630a8f in QEventDispatcherGlib::processEvents (this=0x6f2f80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#24 0x00007f32e7a67eae in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#25 0x00007f32e8605262 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#26 0x00007f32e8605475 in QEventLoop::exec (this=0x7fff612315b0, flags=...) at kernel/qeventloop.cpp:201
#27 0x00007f32e86098db in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#28 0x00007f32ddd42d68 in kdemain () from /usr/lib64/libkdeinit4_plasma-desktop.so
#29 0x0000000000407609 in launch (argc=1, _name=0x678f38 "/usr/bin/plasma-desktop", args=<value optimized out>, cwd=0x0, envc=<value optimized out>, envs=<value optimized out>, reset_env=false, tty=
    0x0, avoid_loops=false, startup_id_str=0x40b397 "0") at /usr/src/debug/kdelibs-4.5.95/kinit/kinit.cpp:730
#30 0x0000000000408125 in handle_launcher_request (sock=8, who=<value optimized out>) at /usr/src/debug/kdelibs-4.5.95/kinit/kinit.cpp:1222
#31 0x000000000040889a in handle_requests (waitForPid=<value optimized out>) at /usr/src/debug/kdelibs-4.5.95/kinit/kinit.cpp:1415
#32 0x00000000004094f0 in main (argc=4, argv=0x7fff61232a88, envp=0x7fff61232ab0) at /usr/src/debug/kdelibs-4.5.95/kinit/kinit.cpp:1903

This bug may be a duplicate of or related to bug 257658.

Possible duplicates by query: bug 259109, bug 258362, bug 257658.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2011-01-18 20:00:45 UTC
SVN commit 1215440 by aseigo:

remove the item pointer from all collections when it is deleted as it is also added to all of them when first added
BUG:263565


 M  +5 -6      extender.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1215440
Comment 2 Aaron J. Seigo 2011-01-18 20:02:17 UTC
SVN commit 1215441 by aseigo:

remove the item pointer from all collections when it is deleted as it is also added to all of them when first added
CCBUG:263565


 M  +5 -6      extender.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1215441