Bug 221968

Summary: Kontact crash after trying to "un-minimize" from taskbar
Product: [Applications] kontact Reporter: Mark Garrow <scunizi>
Component: generalAssignee: kdepim bugs <kdepim-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash    
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description Mark Garrow 2010-01-09 21:20:41 UTC
Application that crashed: kontact
Version of the application: 4.3.2
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

 -- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
The current source language is "auto; currently c".
[Current thread is 1 (Thread 0x7f9a7904d750 (LWP 2845))]

Thread 2 (Thread 0x7f9a53b03910 (LWP 3187)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1  0x00007f9a76caf4fb in QWaitConditionPrivate::wait (this=<value optimized out>, mutex=0x2ad5c68, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:87
#2  QWaitCondition::wait (this=<value optimized out>, mutex=0x2ad5c68, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:159
#3  0x00007f9a71ee478c in QHostInfoAgent::run (this=0x2ad5c50) at kernel/qhostinfo.cpp:260
#4  0x00007f9a76cae445 in QThreadPrivate::start (arg=0x2ad5c50) at thread/qthread_unix.cpp:188
#5  0x00007f9a703bda04 in start_thread (arg=<value optimized out>) at pthread_create.c:300
#6  0x00007f9a766b07bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9a7904d750 (LWP 2845)):
[KCrash Handler]
#5  0x0000000000000020 in ?? ()
#6  0x00007f9a78a39cf9 in Kontact::Plugin::part (this=0xbc7cb0) at ../../kontactinterfaces/plugin.cpp:187
#7  0x00007f9a63526e21 in KOrganizerUniqueAppHandler::newInstance (this=0xbee420) at ../../../../kontact/plugins/korganizer/korg_uniqueapp.cpp:35
#8  0x00007f9a78a3c0f9 in Kontact::UniqueAppHandler::newInstance (this=0xbee420, asn_id=<value optimized out>, args=...) at ../../kontactinterfaces/uniqueapphandler.cpp:128
#9  0x00007f9a78a3c164 in Kontact::UniqueAppHandler::qt_metacall (this=0xbee420, _c=QMetaObject::InvokeMetaMethod, _id=12405360, _a=0x7fff0dd00a20) at ./uniqueapphandler.moc:73
#10 0x00007f9a74ec4ad4 in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>)
    at qdbusintegrator.cpp:891
#11 0x00007f9a74ec5c69 in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0xbee420, flags=272, msg=...) at qdbusintegrator.cpp:796
#12 0x00007f9a74ec62d5 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=..., msg=<value optimized out>, pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1370
#13 0x00007f9a74ec67c8 in QDBusActivateObjectEvent::placeMetaCall (this=0x1c7e010) at qdbusintegrator.cpp:1464
#14 0x00007f9a76da40f9 in QObject::event (this=0xbee420, e=0x1c7e010) at kernel/qobject.cpp:1111
#15 0x00007f9a776b4efc in QApplicationPrivate::notify_helper (this=0x728ae0, receiver=0xbee420, e=0x1c7e010) at kernel/qapplication.cpp:4056
#16 0x00007f9a776bc1ce in QApplication::notify (this=0x7fff0dd01630, receiver=0xbee420, e=0x1c7e010) at kernel/qapplication.cpp:4021
#17 0x00007f9a782ebab6 in KApplication::notify (this=0x7fff0dd01630, receiver=0xbee420, event=0x1c7e010) at ../../kdeui/kernel/kapplication.cpp:302
#18 0x00007f9a76d94c2c in QCoreApplication::notifyInternal (this=0x7fff0dd01630, receiver=0xbee420, event=0x1c7e010) at kernel/qcoreapplication.cpp:610
#19 0x00007f9a76d9580a in QCoreApplication::sendEvent (receiver=0x0, event_type=<value optimized out>, data=0x701080) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0x701080) at kernel/qcoreapplication.cpp:1247
#21 0x00007f9a76dbd533 in QCoreApplication::sendPostedEvents (s=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:218
#22 postEventSourceDispatch (s=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:210
#23 0x00007f9a7060ebce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#24 0x00007f9a70612598 in ?? () from /lib/libglib-2.0.so.0
#25 0x00007f9a706126c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#26 0x00007f9a76dbd1a6 in QEventDispatcherGlib::processEvents (this=0x700cb0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#27 0x00007f9a777494be in QGuiEventDispatcherGlib::processEvents (this=0xbc7cb0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#28 0x00007f9a76d93532 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#29 0x00007f9a76d93904 in QEventLoop::exec (this=0x7fff0dd01570, flags=) at kernel/qeventloop.cpp:201
#30 0x00007f9a76d95ab9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#31 0x0000000000403f47 in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:218
The current source language is "auto; currently asm".
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 220020

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2010-03-28 04:17:14 UTC

*** This bug has been marked as a duplicate of bug 194268 ***