Bug 213342

Summary: Copying then pasting bookmarks into folder crashes bookmark manager
Product: keditbookmarks Reporter: Manuel Stol <ManuelStol>
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description Manuel Stol 2009-11-05 23:16:27 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.1 (KDE 4.3.1) "release 6"
KDE Version: 4.3.1 (KDE 4.3.1) "release 6"
Qt Version: 4.5.3
Operating System: Linux 2.6.31.5-0.1-desktop x86_64
Distribution: "openSUSE 11.2 (x86_64)"

What I was doing when the application crashed:
This is a duplicate of Bug 187892

 -- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f0a6096767d in QDomElementPrivate::save (this=0x92d790, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4603
#6  0x00007f0a6095c314 in QDomNodePrivate::save (this=<value optimized out>, s=..., depth=5, indent=1) at dom/qdom.cpp:1916
#7  0x00007f0a6096723b in QDomElementPrivate::save (this=0x883780, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4640
#8  0x00007f0a6095c314 in QDomNodePrivate::save (this=<value optimized out>, s=..., depth=4, indent=1) at dom/qdom.cpp:1916
#9  0x00007f0a6096723b in QDomElementPrivate::save (this=0x86ea80, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4640
#10 0x00007f0a6095c314 in QDomNodePrivate::save (this=<value optimized out>, s=..., depth=3, indent=1) at dom/qdom.cpp:1916
#11 0x00007f0a6096723b in QDomElementPrivate::save (this=0x8cbd60, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4640
#12 0x00007f0a6095c314 in QDomNodePrivate::save (this=<value optimized out>, s=..., depth=2, indent=1) at dom/qdom.cpp:1916
#13 0x00007f0a6096723b in QDomElementPrivate::save (this=0x82b7d0, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4640
#14 0x00007f0a6095c314 in QDomNodePrivate::save (this=<value optimized out>, s=..., depth=1, indent=1) at dom/qdom.cpp:1916
#15 0x00007f0a6096723b in QDomElementPrivate::save (this=0x82b320, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4640
#16 0x00007f0a6096b4b4 in QDomDocumentPrivate::saveDocument (this=0x824f40, s=..., indent=1, encUsed=<value optimized out>) at dom/qdom.cpp:6473
#17 0x00007f0a6096bab7 in QDomDocument::toString (this=0x7fff16c253a0, indent=1) at dom/qdom.cpp:6845
#18 0x00007f0a60d5afc5 in KBookmarkManager::saveAs (this=<value optimized out>, filename=..., toolbarCache=<value optimized out>) at /usr/src/debug/kdelibs-4.3.1/kio/bookmarks/kbookmarkmanager.cc:402
#19 0x00007f0a60d5b493 in KBookmarkManager::emitChanged (this=0x6cc4f0, group=...) at /usr/src/debug/kdelibs-4.3.1/kio/bookmarks/kbookmarkmanager.cc:516
#20 0x00007f0a6191ee92 in CmdHistory::slotCommandExecuted (this=<value optimized out>, k=<value optimized out>) at /usr/src/debug/kdebase-4.3.1/apps/keditbookmarks/toplevel.cpp:82
#21 0x00007f0a6193bc8a in KBookmarkModel::dropMimeData (this=<value optimized out>, data=<value optimized out>, action=<value optimized out>, row=<value optimized out>, column=<value optimized out>, 
    parent=<value optimized out>) at /usr/src/debug/kdebase-4.3.1/apps/keditbookmarks/bookmarkmodel.cpp:306
#22 0x00007f0a5f2ebf6d in QAbstractItemView::dropEvent (this=0x6e26a0, event=0x7fff16c26240) at itemviews/qabstractitemview.cpp:1849
#23 0x00007f0a5ee87747 in QWidget::event (this=0x6e26a0, event=0x7fff16c26240) at kernel/qwidget.cpp:7736
#24 0x00007f0a5f1c6ab6 in QFrame::event (this=0x6e26a0, e=0x7fff16c26240) at widgets/qframe.cpp:559
#25 0x00007f0a5f2f8f1b in QAbstractItemView::viewportEvent (this=0x6e26a0, event=0x7fff16c26240) at itemviews/qabstractitemview.cpp:1476
#26 0x00007f0a5f330090 in QTreeView::viewportEvent (this=0x6e26a0, event=0x7fff16c26240) at itemviews/qtreeview.cpp:1266
#27 0x00007f0a5f96d127 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x851240, event=0x7fff16c26240) at kernel/qcoreapplication.cpp:726
#28 0x00007f0a5ee3927c in QApplicationPrivate::notify_helper (this=0x623170, receiver=0x851240, e=0x7fff16c26240) at kernel/qapplication.cpp:4061
#29 0x00007f0a5ee40a7d in QApplication::notify (this=<value optimized out>, receiver=0x851240, e=0x7fff16c26240) at kernel/qapplication.cpp:4018
#30 0x00007f0a605538d6 in KApplication::notify (this=0x7fff16c2b880, receiver=0x851240, event=0x7fff16c26240) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#31 0x00007f0a5f96dddc in QCoreApplication::notifyInternal (this=0x7fff16c2b880, receiver=0x851240, event=0x7fff16c26240) at kernel/qcoreapplication.cpp:610
#32 0x00007f0a5eeb2ffa in sendEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:213
#33 QX11Data::xdndHandleDrop (event=<value optimized out>, receiver=<value optimized out>) at kernel/qdnd_x11.cpp:1174
#34 0x00007f0a5eeb79a6 in QDragManager::drop (this=0x6e0b30) at kernel/qdnd_x11.cpp:1710
#35 0x00007f0a5eeb7b60 in QDragManager::eventFilter (this=0x6e0b30, o=<value optimized out>, e=<value optimized out>) at kernel/qdnd_x11.cpp:1303
#36 0x00007f0a5f96d1eb in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x623170, receiver=0x860190, event=0x7fff16c269d0) at kernel/qcoreapplication.cpp:707
#37 0x00007f0a5ee39226 in QApplicationPrivate::notify_helper (this=0x6cc4f0, receiver=0x100000011000400, e=0x965808) at kernel/qapplication.cpp:4040
#38 0x00007f0a5ee403c1 in QApplication::notify (this=<value optimized out>, receiver=0x860190, e=0x7fff16c269d0) at kernel/qapplication.cpp:3767
#39 0x00007f0a605538d6 in KApplication::notify (this=0x7fff16c2b880, receiver=0x860190, event=0x7fff16c269d0) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#40 0x00007f0a5f96dddc in QCoreApplication::notifyInternal (this=0x7fff16c2b880, receiver=0x860190, event=0x7fff16c269d0) at kernel/qcoreapplication.cpp:610
#41 0x00007f0a5ee3fc90 in sendSpontaneousEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:216
#42 QApplicationPrivate::sendMouseEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qapplication.cpp:2924
#43 0x00007f0a5eea5cfe in QETWidget::translateMouseEvent (this=0x860190, event=<value optimized out>) at kernel/qapplication_x11.cpp:4409
#44 0x00007f0a5eea4d9a in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff16c28500) at kernel/qapplication_x11.cpp:3550
#45 0x00007f0a5eeccb6c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#46 0x00007f0a5acc6dde in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
#47 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
#48 0x00007f0a5acca7a8 in g_main_context_iterate (context=0x6259f0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#49 0x00007f0a5acca8d0 in IA__g_main_context_iteration (context=0x6259f0, may_block=1) at gmain.c:2654
#50 0x00007f0a5f9963a3 in QEventDispatcherGlib::processEvents (this=0x6098f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#51 0x00007f0a5eecc31e in QGuiEventDispatcherGlib::processEvents (this=0x6cc4f0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#52 0x00007f0a5f96c712 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#53 0x00007f0a5f96cae4 in QEventLoop::exec (this=0x793800, flags=) at kernel/qeventloop.cpp:201
#54 0x00007f0a5eeb74ac in QDragManager::drag (this=0x6e0b30, o=<value optimized out>) at kernel/qdnd_x11.cpp:1970
#55 0x00007f0a5ee4b518 in QDrag::exec (this=0x7b5ca0, supportedActions=) at kernel/qdrag.cpp:282
#56 0x00007f0a5f2f6ebc in QAbstractItemView::startDrag (this=0x6e26a0, supportedActions=<value optimized out>) at itemviews/qabstractitemview.cpp:3218
#57 0x00007f0a5f2f3966 in QAbstractItemView::mouseMoveEvent (this=0x6e26a0, event=<value optimized out>) at itemviews/qabstractitemview.cpp:1552
#58 0x00007f0a5ee87b52 in QWidget::event (this=0x6e26a0, event=0x7fff16c29820) at kernel/qwidget.cpp:7539
#59 0x00007f0a5f1c6ab6 in QFrame::event (this=0x6e26a0, e=0x7fff16c29820) at widgets/qframe.cpp:559
#60 0x00007f0a5f2f8f1b in QAbstractItemView::viewportEvent (this=0x6e26a0, event=0x7fff16c29820) at itemviews/qabstractitemview.cpp:1476
#61 0x00007f0a5f330090 in QTreeView::viewportEvent (this=0x6e26a0, event=0x7fff16c29820) at itemviews/qtreeview.cpp:1266
#62 0x00007f0a5f96d127 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x851240, event=0x7fff16c29820) at kernel/qcoreapplication.cpp:726
#63 0x00007f0a5ee3927c in QApplicationPrivate::notify_helper (this=0x623170, receiver=0x851240, e=0x7fff16c29820) at kernel/qapplication.cpp:4061
#64 0x00007f0a5ee403c1 in QApplication::notify (this=<value optimized out>, receiver=0x851240, e=0x7fff16c29820) at kernel/qapplication.cpp:3767
#65 0x00007f0a605538d6 in KApplication::notify (this=0x7fff16c2b880, receiver=0x851240, event=0x7fff16c29820) at /usr/src/debug/kdelibs-4.3.1/kdeui/kernel/kapplication.cpp:302
#66 0x00007f0a5f96dddc in QCoreApplication::notifyInternal (this=0x7fff16c2b880, receiver=0x851240, event=0x7fff16c29820) at kernel/qcoreapplication.cpp:610
#67 0x00007f0a5ee3fc90 in sendSpontaneousEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:216
#68 QApplicationPrivate::sendMouseEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qapplication.cpp:2924
#69 0x00007f0a5eea5cfe in QETWidget::translateMouseEvent (this=0x786750, event=<value optimized out>) at kernel/qapplication_x11.cpp:4409
#70 0x00007f0a5eea4d9a in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff16c2b350) at kernel/qapplication_x11.cpp:3550
#71 0x00007f0a5eeccb6c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#72 0x00007f0a5acc6dde in g_main_dispatch (context=<value optimized out>) at gmain.c:1960
#73 IA__g_main_context_dispatch (context=<value optimized out>) at gmain.c:2513
#74 0x00007f0a5acca7a8 in g_main_context_iterate (context=0x6259f0, block=<value optimized out>, dispatch=<value optimized out>, self=<value optimized out>) at gmain.c:2591
#75 0x00007f0a5acca8d0 in IA__g_main_context_iteration (context=0x6259f0, may_block=1) at gmain.c:2654
#76 0x00007f0a5f9963a3 in QEventDispatcherGlib::processEvents (this=0x6098f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:407
#77 0x00007f0a5eecc31e in QGuiEventDispatcherGlib::processEvents (this=0x6cc4f0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#78 0x00007f0a5f96c712 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#79 0x00007f0a5f96cae4 in QEventLoop::exec (this=0x7fff16c2b680, flags=) at kernel/qeventloop.cpp:201
#80 0x00007f0a5f96ec99 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#81 0x00007f0a6191ac15 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /usr/src/debug/kdebase-4.3.1/apps/keditbookmarks/main.cpp:203
#82 0x00007f0a615bfa7d in __libc_start_main (main=<value optimized out>, argc=<value optimized out>, ubp_av=<value optimized out>, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fff16c2c408) at libc-start.c:220
#83 0x0000000000400699 in _start () at ../sysdeps/x86_64/elf/start.S:113
Warning: the current language does not match this frame.
The current source language is "auto; currently c".

This bug may be a duplicate of or related to bug 204547

Reported using DrKonqi
Comment 1 Dario Andres 2009-11-06 02:48:47 UTC

*** This bug has been marked as a duplicate of bug 187892 ***