Bug 208805

Summary: crash while dropping a folder in another folder
Product: keditbookmarks Reporter: p92
Component: generalAssignee: Konqueror Developers <konq-bugs>
Status: RESOLVED DUPLICATE    
Severity: crash CC: andresbajotierra
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Unlisted Binaries   
OS: Linux   
Latest Commit: Version Fixed In:

Description p92 2009-09-28 19:22:39 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.28-11-generic i686
Distribution: Ubuntu 9.04

What I was doing when the application crashed:
crash  at drop moment       while drag and dropping a folder in another folder 

 -- Backtrace:
Application: Éditeur de signet (keditbookmarks), signal: Segmentation fault
[KCrash Handler]
#6  0xb769da50 in QDomElementPrivate::save (this=0x88f0000, s=@0xbfe0ecdc, depth=7, indent=1) at dom/qdom.cpp:4603
#7  0xb7690e92 in QDomNodePrivate::save (this=0x88effc0, s=@0xbfe0ecdc, depth=7, indent=1) at dom/qdom.cpp:1916
#8  0xb769d677 in QDomElementPrivate::save (this=0x88effc0, s=@0xbfe0ecdc, depth=6, indent=1) at dom/qdom.cpp:4640
#9  0xb7690e92 in QDomNodePrivate::save (this=0x879d338, s=@0xbfe0ecdc, depth=6, indent=1) at dom/qdom.cpp:1916
#10 0xb769d677 in QDomElementPrivate::save (this=0x879d338, s=@0xbfe0ecdc, depth=5, indent=1) at dom/qdom.cpp:4640
#11 0xb7690e92 in QDomNodePrivate::save (this=0x86c7d78, s=@0xbfe0ecdc, depth=5, indent=1) at dom/qdom.cpp:1916
#12 0xb769d677 in QDomElementPrivate::save (this=0x86c7d78, s=@0xbfe0ecdc, depth=4, indent=1) at dom/qdom.cpp:4640
#13 0xb7690e92 in QDomNodePrivate::save (this=0x872c7c8, s=@0xbfe0ecdc, depth=4, indent=1) at dom/qdom.cpp:1916
#14 0xb769d677 in QDomElementPrivate::save (this=0x872c7c8, s=@0xbfe0ecdc, depth=3, indent=1) at dom/qdom.cpp:4640
#15 0xb7690e92 in QDomNodePrivate::save (this=0x87196b0, s=@0xbfe0ecdc, depth=3, indent=1) at dom/qdom.cpp:1916
#16 0xb769d677 in QDomElementPrivate::save (this=0x87196b0, s=@0xbfe0ecdc, depth=2, indent=1) at dom/qdom.cpp:4640
#17 0xb7690e92 in QDomNodePrivate::save (this=0x8689ef0, s=@0xbfe0ecdc, depth=2, indent=1) at dom/qdom.cpp:1916
#18 0xb769d677 in QDomElementPrivate::save (this=0x8689ef0, s=@0xbfe0ecdc, depth=1, indent=1) at dom/qdom.cpp:4640
#19 0xb76a26ee in QDomNode::save (this=0xbfe0ed28, str=@0xbfe0ecdc, indent=1, encodingPolicy=QDomNode::EncodingFromDocument) at dom/qdom.cpp:2707
#20 0xb76a2763 in QDomNode::save (this=0xbfe0ed28, str=@0xbfe0ecdc, indent=1) at dom/qdom.cpp:2684
#21 0xb76a28d1 in operator<< (str=@0xbfe0ecdc, node=@0xbfe0ed28) at dom/qdom.cpp:2718
#22 0xb798f22c in KBookmarkManager::saveAs (this=0x85aa1d8, filename=@0x851b338, toolbarCache=true) at /build/buildd/kde4libs-4.3.1/kio/bookmarks/kbookmarkmanager.cc:385
#23 0xb798f30f in KBookmarkManager::save (this=0x85aa1d8, toolbarCache=<value optimized out>) at /build/buildd/kde4libs-4.3.1/kio/bookmarks/kbookmarkmanager.cc:368
#24 0xb798f350 in KBookmarkManager::emitChanged (this=0x85aa1d8, group=@0xbfe0edf0) at /build/buildd/kde4libs-4.3.1/kio/bookmarks/kbookmarkmanager.cc:516
#25 0xb7ea8fdb in CurrentMgr::notifyManagers (this=0x8556d78, grp=@0xbfe0edf0) at /build/buildd/kdebase-4.3.1/apps/keditbookmarks/toplevel.cpp:183
#26 0xb7eac6a1 in CmdHistory::slotCommandExecuted (this=0x85361b0, k=0x8a22218) at /build/buildd/kdebase-4.3.1/apps/keditbookmarks/toplevel.cpp:82
#27 0xb7ecc0c0 in KBookmarkModel::dropMimeData (this=0x8561318, data=0x874c0c0, action=Qt::CopyAction, row=-1, column=-1, parent=@0xbfe0ef10)
    at /build/buildd/kdebase-4.3.1/apps/keditbookmarks/bookmarkmodel.cpp:306
#28 0xb7ece26f in BookmarkFolderViewFilterModel::dropMimeData (this=0x87d9508, data=0x874c0c0, action=Qt::CopyAction, row=-1, column=-1, parent=@0xbfe0ef94)
    at /build/buildd/kdebase-4.3.1/apps/keditbookmarks/bookmarklistview.cpp:184
#29 0xb6a96e31 in QAbstractItemView::dropEvent (this=0x856f048, event=0xbfe0f76c) at itemviews/qabstractitemview.cpp:1849
#30 0xb659f551 in QWidget::event (this=0x856f048, event=0xbfe0f76c) at kernel/qwidget.cpp:7731
#31 0xb6950a53 in QFrame::event (this=0x856f048, e=0xbfe0f76c) at widgets/qframe.cpp:559
#32 0xb69f0c2f in QAbstractScrollArea::viewportEvent (this=0x856f048, e=0xb7004448) at widgets/qabstractscrollarea.cpp:962
#33 0xb6aa34a7 in QAbstractItemView::viewportEvent (this=0x856f048, event=0xbfe0f76c) at itemviews/qabstractitemview.cpp:1476
#34 0xb6addff6 in QTreeView::viewportEvent (this=0x856f048, event=0xbfe0f76c) at itemviews/qtreeview.cpp:1266
#35 0xb69f3235 in QAbstractScrollAreaFilter::eventFilter (this=0x857b030, o=0x8476940, e=0xbfe0f76c) at widgets/qabstractscrollarea_p.h:100
#36 0xb6f0fdea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x842bf00, receiver=0x8476940, event=0xbfe0f76c) at kernel/qcoreapplication.cpp:726
#37 0xb6548d1a in QApplicationPrivate::notify_helper (this=0x842bf00, receiver=0x8476940, e=0xbfe0f76c) at kernel/qapplication.cpp:4052
#38 0xb6551651 in QApplication::notify (this=0xbfe13c1c, receiver=0x8476940, e=0xbfe0f76c) at kernel/qapplication.cpp:4009
#39 0xb74c785d in KApplication::notify (this=0xbfe13c1c, receiver=0x8476940, event=0xbfe0f76c) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#40 0xb6f10bcb in QCoreApplication::notifyInternal (this=0xbfe13c1c, receiver=0x8476940, event=0xbfe0f76c) at kernel/qcoreapplication.cpp:610
#41 0xb65ce9cd in QX11Data::xdndHandleDrop (this=0x842fb48, xe=0xbfe0f868, passive=false) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#42 0xb65d3693 in QDragManager::drop (this=0x86ec400) at kernel/qdnd_x11.cpp:1709
#43 0xb65d3856 in QDragManager::eventFilter (this=0x86ec400, o=0x8a274c0, e=0xbfe0fd08) at kernel/qdnd_x11.cpp:1302
#44 0xb6f0feac in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x842bf00, receiver=0x8a274c0, event=0xbfe0fd08) at kernel/qcoreapplication.cpp:707
#45 0xb6548cb3 in QApplicationPrivate::notify_helper (this=0x842bf00, receiver=0x8a274c0, e=0xbfe0fd08) at kernel/qapplication.cpp:4031
#46 0xb65519b1 in QApplication::notify (this=0xbfe13c1c, receiver=0x8a274c0, e=0xbfe0fd08) at kernel/qapplication.cpp:3758
#47 0xb74c785d in KApplication::notify (this=0xbfe13c1c, receiver=0x8a274c0, event=0xbfe0fd08) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#48 0xb6f10bcb in QCoreApplication::notifyInternal (this=0xbfe13c1c, receiver=0x8a274c0, event=0xbfe0fd08) at kernel/qcoreapplication.cpp:610
#49 0xb6550a1e in QApplicationPrivate::sendMouseEvent (receiver=0x8a274c0, event=0xbfe0fd08, alienWidget=0x0, nativeWidget=0x8a274c0, buttonDown=0xb6dcaaa0, lastMouseReceiver=@0xb6dcaaa4)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#50 0xb65c0cce in QETWidget::translateMouseEvent (this=0x8a274c0, event=0xbfe1139c) at kernel/qapplication_x11.cpp:4409
#51 0xb65c0085 in QApplication::x11ProcessEvent (this=0xbfe13c1c, event=0xbfe1139c) at kernel/qapplication_x11.cpp:3428
#52 0xb65eb37a in x11EventSourceDispatch (s=0x842eea8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#53 0xb5d5bb88 in IA__g_main_context_dispatch (context=0x842e098) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#54 0xb5d5f0eb in g_main_context_iterate (context=0x842e098, block=1, dispatch=1, self=0x842bd68) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#55 0xb5d5f268 in IA__g_main_context_iteration (context=0x842e098, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#56 0xb6f3c2f8 in QEventDispatcherGlib::processEvents (this=0x8415d10, flags={i = -1075767976}) at kernel/qeventdispatcher_glib.cpp:327
#57 0xb65eaa75 in QGuiEventDispatcherGlib::processEvents (this=0x8415d10, flags={i = -1075767928}) at kernel/qguieventdispatcher_glib.cpp:202
#58 0xb6f0f1fa in QEventLoop::processEvents (this=0x875afa8, flags={i = -1075767864}) at kernel/qeventloop.cpp:149
#59 0xb6f0f642 in QEventLoop::exec (this=0x875afa8, flags={i = -1075767752}) at kernel/qeventloop.cpp:201
#60 0xb65d305b in QDragManager::drag (this=0x86ec400, o=0x87f58e8) at kernel/qdnd_x11.cpp:1969
#61 0xb655c3da in QDrag::exec (this=0x87f58e8, supportedActions={i = -1075767500}, defaultDropAction=Qt::CopyAction) at kernel/qdrag.cpp:282
#62 0xb6aa19fc in QAbstractItemView::startDrag (this=0x85aa4a8, supportedActions={i = -1075767244}) at itemviews/qabstractitemview.cpp:3205
#63 0xb6a9e90d in QAbstractItemView::mouseMoveEvent (this=0x85aa4a8, event=0xbfe120d8) at itemviews/qabstractitemview.cpp:1552
#64 0xb6adddf4 in QTreeView::mouseMoveEvent (this=0x85aa4a8, event=0xbfe120d8) at itemviews/qtreeview.cpp:1872
#65 0xb659f7dd in QWidget::event (this=0x85aa4a8, event=0xbfe120d8) at kernel/qwidget.cpp:7534
#66 0xb6950a53 in QFrame::event (this=0x85aa4a8, e=0xbfe120d8) at widgets/qframe.cpp:559
#67 0xb69f0c2f in QAbstractScrollArea::viewportEvent (this=0x85aa4a8, e=0xb7004448) at widgets/qabstractscrollarea.cpp:962
#68 0xb6aa34a7 in QAbstractItemView::viewportEvent (this=0x85aa4a8, event=0xbfe120d8) at itemviews/qabstractitemview.cpp:1476
#69 0xb6addff6 in QTreeView::viewportEvent (this=0x85aa4a8, event=0xbfe120d8) at itemviews/qtreeview.cpp:1266
#70 0xb69f3235 in QAbstractScrollAreaFilter::eventFilter (this=0x85ab868, o=0x85aaa38, e=0xbfe120d8) at widgets/qabstractscrollarea_p.h:100
#71 0xb6f0fdea in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x842bf00, receiver=0x85aaa38, event=0xbfe120d8) at kernel/qcoreapplication.cpp:726
#72 0xb6548d1a in QApplicationPrivate::notify_helper (this=0x842bf00, receiver=0x85aaa38, e=0xbfe120d8) at kernel/qapplication.cpp:4052
#73 0xb65519b1 in QApplication::notify (this=0xbfe13c1c, receiver=0x85aaa38, e=0xbfe120d8) at kernel/qapplication.cpp:3758
#74 0xb74c785d in KApplication::notify (this=0xbfe13c1c, receiver=0x85aaa38, event=0xbfe120d8) at /build/buildd/kde4libs-4.3.1/kdeui/kernel/kapplication.cpp:302
#75 0xb6f10bcb in QCoreApplication::notifyInternal (this=0xbfe13c1c, receiver=0x85aaa38, event=0xbfe120d8) at kernel/qcoreapplication.cpp:610
#76 0xb6550a1e in QApplicationPrivate::sendMouseEvent (receiver=0x85aaa38, event=0xbfe120d8, alienWidget=0x85aa4a8, nativeWidget=0x842ba18, buttonDown=0xb6dcaaa0, lastMouseReceiver=@0xb6dcaaa4)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#77 0xb65c0cce in QETWidget::translateMouseEvent (this=0x842ba18, event=0xbfe1376c) at kernel/qapplication_x11.cpp:4409
#78 0xb65c0085 in QApplication::x11ProcessEvent (this=0xbfe13c1c, event=0xbfe1376c) at kernel/qapplication_x11.cpp:3428
#79 0xb65eb37a in x11EventSourceDispatch (s=0x842eea8, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#80 0xb5d5bb88 in IA__g_main_context_dispatch (context=0x842e098) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:1814
#81 0xb5d5f0eb in g_main_context_iterate (context=0x842e098, block=1, dispatch=1, self=0x842bd68) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2448
#82 0xb5d5f268 in IA__g_main_context_iteration (context=0x842e098, may_block=1) at /build/buildd/glib2.0-2.20.1/glib/gmain.c:2511
#83 0xb6f3c2f8 in QEventDispatcherGlib::processEvents (this=0x8415d10, flags={i = -1075758808}) at kernel/qeventdispatcher_glib.cpp:327
#84 0xb65eaa75 in QGuiEventDispatcherGlib::processEvents (this=0x8415d10, flags={i = -1075758760}) at kernel/qguieventdispatcher_glib.cpp:202
#85 0xb6f0f1fa in QEventLoop::processEvents (this=0xbfe139d0, flags={i = -1075758696}) at kernel/qeventloop.cpp:149
#86 0xb6f0f642 in QEventLoop::exec (this=0xbfe139d0, flags={i = -1075758632}) at kernel/qeventloop.cpp:201
#87 0xb6f11ae9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#88 0xb6548bb7 in QApplication::exec () at kernel/qapplication.cpp:3525
#89 0xb7ea8109 in kdemain (argc=6, argv=0xbfe13f74) at /build/buildd/kdebase-4.3.1/apps/keditbookmarks/main.cpp:203
#90 0x080486a2 in main (argc=1, argv=0x857fa18) at /build/buildd/kdebase-4.3.1/obj-i486-linux-gnu/apps/keditbookmarks/keditbookmarks_dummy.cpp:3

This bug may be a duplicate of or related to bug 207794

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-29 03:40:51 UTC
Merging with bug 187892 Thanks

*** This bug has been marked as a duplicate of bug 187892 ***