Bug 207794 - keditbookmarks crashes whenever pasting bookmarks which have been cut
Summary: keditbookmarks crashes whenever pasting bookmarks which have been cut
Status: RESOLVED DUPLICATE of bug 199195
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-18 15:29 UTC by Jay
Modified: 2009-09-18 15:51 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jay 2009-09-18 15:29:06 UTC
Application that crashed: keditbookmarks
Version of the application: 4.3.1 (KDE 4.3.1)
KDE Version: 4.3.1 (KDE 4.3.1)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-9-generic x86_64
Distribution: Ubuntu karmic (development branch)

What I was doing when the application crashed:
This crash occurs whenever pasting bookmarks which have been cut. It does so right after start of the keditbookmarks; no other actions taken or whatsoever.

 -- Backtrace:
Application: Bladwijzerbewerker (kdeinit4), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f5a48c3363d in QDomElementPrivate::save (this=0x1b91000, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4603
#6  0x00007f5a48c28314 in QDomNodePrivate::save (this=<value optimized out>, s=..., depth=4, indent=1) at dom/qdom.cpp:1916
#7  0x00007f5a48c331fb in QDomElementPrivate::save (this=0x1a02430, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4640
#8  0x00007f5a48c28314 in QDomNodePrivate::save (this=<value optimized out>, s=..., depth=3, indent=1) at dom/qdom.cpp:1916
#9  0x00007f5a48c331fb in QDomElementPrivate::save (this=0x1d28380, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4640
#10 0x00007f5a48c28314 in QDomNodePrivate::save (this=<value optimized out>, s=..., depth=2, indent=1) at dom/qdom.cpp:1916
#11 0x00007f5a48c331fb in QDomElementPrivate::save (this=0x1bc68c0, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4640
#12 0x00007f5a48c28314 in QDomNodePrivate::save (this=<value optimized out>, s=..., depth=1, indent=1) at dom/qdom.cpp:1916
#13 0x00007f5a48c331fb in QDomElementPrivate::save (this=0x1a66050, s=..., depth=<value optimized out>, indent=<value optimized out>) at dom/qdom.cpp:4640
#14 0x00007f5a48c37474 in QDomDocumentPrivate::saveDocument (this=0x1a5f570, s=..., indent=1, encUsed=<value optimized out>) at dom/qdom.cpp:6473
#15 0x00007f5a48c37a77 in QDomDocument::toString (this=0x7fff10647ee0, indent=1) at dom/qdom.cpp:6845
#16 0x00007f5a4c3eec05 in KBookmarkManager::saveAs (this=<value optimized out>, filename=..., toolbarCache=<value optimized out>) at ../../kio/bookmarks/kbookmarkmanager.cc:402
#17 0x00007f5a4c3ef0d3 in KBookmarkManager::emitChanged (this=0x1d40c20, group=...) at ../../kio/bookmarks/kbookmarkmanager.cc:516
#18 0x00007f5a415c7e92 in CmdHistory::slotCommandExecuted (this=<value optimized out>, k=<value optimized out>) at ../../../apps/keditbookmarks/toplevel.cpp:82
#19 0x00007f5a415cb55d in ActionsImpl::slotPaste (this=<value optimized out>) at ../../../apps/keditbookmarks/actionsimpl.cpp:362
#20 0x00007f5a415cb81a in ActionsImpl::qt_metacall (this=0x19c3910, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff10648280) at ./actionsimpl.moc:116
#21 0x00007f5a4d248d2c in QMetaObject::activate (sender=0x19bf980, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x1a024b0) at kernel/qobject.cpp:3113
#22 0x00007f5a4b1e00a7 in QAction::triggered (this=0x1d40c20, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
#23 0x00007f5a4b1e14ef in QAction::activate (this=0x19bf980, event=<value optimized out>) at kernel/qaction.cpp:1160
#24 0x00007f5a4b5cdcdd in QMenuPrivate::activateCausedStack (this=<value optimized out>, causedStack=..., action=0x19bf980, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:967
#25 0x00007f5a4b5d3bea in QMenuPrivate::activateAction (this=0x19d6a50, action=0x19bf980, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1060
#26 0x00007f5a4beef52e in KMenu::mouseReleaseEvent (this=0x19d6a10, e=0x10000001100) at ../../kdeui/widgets/kmenu.cpp:456
#27 0x00007f5a4b234950 in QWidget::event (this=0x19d6a10, event=0x7fff10648ca0) at kernel/qwidget.cpp:7549
#28 0x00007f5a4b5d63ab in QMenu::event (this=0x19d6a10, e=0x7fff10648ca0) at widgets/qmenu.cpp:2353
#29 0x00007f5a4b1e5efc in QApplicationPrivate::notify_helper (this=0x18e4780, receiver=0x19d6a10, e=0x7fff10648ca0) at kernel/qapplication.cpp:4056
#30 0x00007f5a4b1ed011 in QApplication::notify (this=<value optimized out>, receiver=0x19d6a10, e=0x7fff10648ca0) at kernel/qapplication.cpp:3758
#31 0x00007f5a4be1cdb6 in KApplication::notify (this=0x7fff1064ad00, receiver=0x19d6a10, event=0x7fff10648ca0) at ../../kdeui/kernel/kapplication.cpp:302
#32 0x00007f5a4d233b7c in QCoreApplication::notifyInternal (this=0x7fff1064ad00, receiver=0x19d6a10, event=0x7fff10648ca0) at kernel/qcoreapplication.cpp:610
#33 0x00007f5a4b1ec8e0 in QCoreApplication::sendSpontaneousEvent (receiver=0x19d6a10, event=0x7fff10648ca0, alienWidget=0x0, nativeWidget=0x19d6a10, buttonDown=<value optimized out>, 
    lastMouseReceiver=<value optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
#34 QApplicationPrivate::sendMouseEvent (receiver=0x19d6a10, event=0x7fff10648ca0, alienWidget=0x0, nativeWidget=0x19d6a10, buttonDown=<value optimized out>, lastMouseReceiver=<value optimized out>)
    at kernel/qapplication.cpp:2924
#35 0x00007f5a4b252d7e in QETWidget::translateMouseEvent (this=0x19d6a10, event=<value optimized out>) at kernel/qapplication_x11.cpp:4343
#36 0x00007f5a4b2519f9 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fff1064a7d0) at kernel/qapplication_x11.cpp:3550
#37 0x00007f5a4b27ac2c in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
#38 0x00007f5a4a115c4e in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#39 0x00007f5a4a119618 in ?? () from /usr/lib/libglib-2.0.so.0
#40 0x00007f5a4a119740 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#41 0x00007f5a4d25c0f6 in QEventDispatcherGlib::processEvents (this=0x1887040, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
#42 0x00007f5a4b27a3de in QGuiEventDispatcherGlib::processEvents (this=0x1d40c20, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#43 0x00007f5a4d232482 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#44 0x00007f5a4d232854 in QEventLoop::exec (this=0x7fff1064ab00, flags=) at kernel/qeventloop.cpp:201
#45 0x00007f5a4d234a09 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#46 0x00007f5a415c3c15 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at ../../../apps/keditbookmarks/main.cpp:203
#47 0x0000000000406da8 in launch (argc=1, _name=<value optimized out>, args=<value optimized out>, cwd=<value optimized out>, envc=1, envs=<value optimized out>, reset_env=false, tty=0x0, 
    avoid_loops=false, startup_id_str=0x40a299 "0") at ../../kinit/kinit.cpp:677
#48 0x0000000000407aa0 in handle_launcher_request (sock=8, who=<value optimized out>) at ../../kinit/kinit.cpp:1169
#49 0x0000000000407f51 in handle_requests (waitForPid=0) at ../../kinit/kinit.cpp:1362
#50 0x0000000000408bb2 in main (argc=1, argv=<value optimized out>, envp=<value optimized out>) at ../../kinit/kinit.cpp:1793

Reported using DrKonqi
Comment 1 Dario Andres 2009-09-18 15:51:25 UTC
Thanks

*** This bug has been marked as a duplicate of bug 199195 ***