Bug 202274

Summary: Compositing temporarily disabled after login
Product: kwin Reporter: G Cohen <untitled.no4>
Component: compositingAssignee: KWin default assignee <kwin-bugs-null>
Status: RESOLVED FIXED    
Severity: normal CC: adri.forzaferrari, alberto3d.1984, andrei.ilie, angel386273, arimaniac, bernhard.kohn, chaos.proton, cristian_anita, david, debu66er, digitalpioneer, dustin.calhoun, hayarms, hoameomu, ipetts, jmaibaum, martin.tlustos, mistrynitesh, mstrobl2, nemeskey.david, nick, pgnet.dev+kde, sergio.guibert, simon.lewis, speedy, sven.ginka, vivekbhat9, yzhernand
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: Ubuntu Packages   
OS: Unspecified   
Latest Commit: Version Fixed In:
Attachments: glxinfo output
glxinfo
Log In Error File
Log In Info File.
Log Out Info
Info that occurs when I enable compositing.
glxinfo full output

Description G Cohen 2009-08-02 10:58:57 UTC
Version:            (using KDE 4.2.98)
Installed from:    Ubuntu Packages

Since KDE 4.3 RC1 compositing is marked as temporarily disabled in Desktop Effects on every login. Clicking on "Resume Compositing" brings up the following error:

The KDE Window Manager: Compositing has been suspended by another application. You can resume using the Alt+Shift+F12 shortcut.

Clicking on Resume Compositing again, does enable compositing and it works well.

If I just use Alt+Shift+F12 without going into System Settings, I also need to press it twice for compositing to resume.

My GPU is ATI Mobility Radeon HD 3650 with 256MB using fglrx drivers.
Comment 1 speedy 2009-08-15 19:08:59 UTC
same here with 4.3.00 (KDE 4.3.0) "release 155" openSUSE 11.1 (x86_64)
ATI 4850 I tried the 9.5 and 9.7 catalyst drivers.
This error occured after upgrading from KDE 4.2.
Comment 2 sergio.guibert 2009-08-21 23:04:53 UTC
Same behavior running Kubuntu 9.04 64 bits with GPU ATI HD4870 and catalyst 9.8 driver.
Comment 3 G Cohen 2009-08-21 23:58:25 UTC
Since so far this is being ignored, here's a workaround:
In your ~/.kde/share/config/kwinrc file make sure that the following two lines under [Compositing] are as such:
DisableChecks=true
Enabled=true
Comment 4 sergio.guibert 2009-08-24 09:33:40 UTC
Thank you for the workaround.
Is this issue specific to catalyst drivers ?
What is the method used to check is compositing can be enabled ?
Comment 5 G Cohen 2009-08-24 10:09:22 UTC
I'm not a KDE developer or anything, but so far reports of this bug I've seen were on systems with ATI graphic cards using Catalyst.

I don't know of a method to check if compositing can be enabled on a machine. As far as I know compositing should be automatically enabled by KDE on systems which have the capabilities.
Comment 6 G Cohen 2009-08-28 11:18:04 UTC
Re: my comment #3

Apparently KDE doesn't create a compositing section in the kwinrc file by default so if you don't have a compositing section you will have to get KDE to create it. 

To do that go to System Settings -> Desktop, change and enable or disable the "Enable desktop effects" and apply changes. This should get KDE to add the compositing section to your kwinrc file and you can then change the two options to true.
Comment 7 Thomas Lübking 2009-08-28 18:30:11 UTC
*** Bug 202736 has been marked as a duplicate of this bug. ***
Comment 8 Martin Flöser 2009-09-06 23:27:38 UTC
could someone please post the output of "glxinfo | grep -i version"
Comment 9 G Cohen 2009-09-06 23:42:59 UTC
server glx version string: 1.2
client glx version string: 1.4
GLX version: 1.2
OpenGL version string: 2.1.8575
OpenGL shading language version string: 1.20
Comment 10 Martin Flöser 2009-09-06 23:57:49 UTC
as it does not show me everything I wanted to check for, please just upload complete glxinfo.
Comment 11 G Cohen 2009-09-07 00:14:22 UTC
Created attachment 36749 [details]
glxinfo output

Here you go. Enjoy.
Comment 12 de Bue 2009-09-07 06:46:25 UTC
Created attachment 36755 [details]
glxinfo
Comment 13 de Bue 2009-09-07 06:49:43 UTC
I can confirm this bug. I have added a glxinfo output.

I have Debian Sid, w. fglrx and a Radeon 4870
Comment 14 Martin Flöser 2009-09-07 09:14:02 UTC
thanks for posting glxinfo. I think I have to setup my ATI environment once more to understand this bug. My take some time though.
Comment 15 G Cohen 2009-09-07 09:55:42 UTC
Hi,

I can donate an ATI FireMV 2250 PCIE if it can help.

Regards,
Golan.

On Mon, Sep 7, 2009 at 8:14 AM, Martin Gräßlin
<ubuntu@martin-graesslin.com>wrote:

> https://bugs.kde.org/show_bug.cgi?id=202274
>
>
>
>
>
> --- Comment #14 from Martin Gräßlin <ubuntu martin-graesslin com>
>  2009-09-07 09:14:02 ---
> thanks for posting glxinfo. I think I have to setup my ATI environment once
> more to understand this bug. My take some time though.
>
> --
> Configure bugmail: https://bugs.kde.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 16 Martin Flöser 2009-09-07 10:39:27 UTC
(In reply to comment #15)
> I can donate an ATI FireMV 2250 PCIE if it can help.
Thanks for the offer, but I have an ATI card, which is in my second system. But I do not use it very often so I have to setup KDE 4.3 first and basically I don't have the time for something like that till next weekend.
Comment 17 Thomas Lübking 2009-09-07 13:18:34 UTC
Does this also happen when restarting kwin during a running session?
Open konsole, enter "kwin --replace&", watch the debug output, /if/ this behaviour occurs, copy it into a file and post that.

if it does not, but only during login:
to get kwin's debug output at login (or just ever...)
1. run "kdebugdialog --fullmode"
2. select "1212 kwin"
3. assign file outputs to any output type (can be the same file, use a full path in doubt)
4. logout
5. enter a text shell (ctrl+alt+f1)
6. login
7. delete the output files (or just echo > /into/the/file.txt) - so it will be empty
8. return to kdm (GUI login, usually ctrl+alt+f7)
9. login - wait - kwin doesn't enable composoting
10. before reactivating compositing move or copy the output file somewhere or just disbale debug redirection using "kdebugdialog --fullmode" again
11. see if the output isn't empy
12. if not, post it here
Comment 18 Thomas Lübking 2009-09-07 13:39:51 UTC
this might also be related to bug #189957
Comment 19 Markus Strobl 2009-09-07 14:47:33 UTC
Kwin debug log is attached to duplicate bug 202736
Comment 20 Thomas Lübking 2009-09-07 17:12:51 UTC
ähem - sorry :-\
Ok, at least bug #202736 doesn't fail the driver test but stumbles on the pixel color testing selfCheck() routine.
Apparently (some?) ATi cards aren't entirely ready on the first paint cycle? (If the check doesn't happen during init but called by kcm the paint cycle check doesn't have to happen.)

Does anybody -except Martin- compile kwin from sources?
In case, please try to do a check though currently initialising, kdebase/kwin/scene_opengl.cpp, line 190
"if( !initting )" -> "if( true )"
Comment 21 Dustin Calhoun 2009-09-19 19:03:48 UTC
Created attachment 37064 [details]
Log In Error File
Comment 22 Dustin Calhoun 2009-09-19 19:04:19 UTC
Created attachment 37065 [details]
Log In Info File.
Comment 23 Dustin Calhoun 2009-09-19 19:04:44 UTC
Created attachment 37066 [details]
Log Out Info
Comment 24 Dustin Calhoun 2009-09-19 19:06:31 UTC
I have attached the files for when I log in and log out info and error files, I will soon attach a file when I try to enable compositing, this is quite hard due to the fact that it lags out my computer.
Comment 25 Dustin Calhoun 2009-09-19 19:11:07 UTC
Created attachment 37067 [details]
Info that occurs when I enable compositing.

I'd like to note that I went to Ctrl+Alt+F1 after I tried to enable compositing (the second time), to check if the files had been created/filled. Well, Info.dbg had information, when I went back to Ctrl+Alt+F7, compositing was enabled and not eating up 100% CPU, very strange.

ATI Radeon HD 4850, CPU= C2D E8400 at 3.6GHz
Comment 26 Thomas Lübking 2009-09-19 21:38:37 UTC
probably same issue as in bug #202736, can you try the suggested modification at the end of comment #20?
Comment 27 Dustin Calhoun 2009-09-19 21:50:15 UTC
I don't know how to compile kwin by source, or what he means.
Comment 28 Dustin Calhoun 2009-09-25 05:10:46 UTC
Just downloaded ATI 9.9 drivers and installed them, compositing is working like a champ, Kubuntu 9.04 KDE 4.3.1 ATI Radeon HD 4850
Comment 29 Nathaniel 2009-10-24 02:34:09 UTC
This is happening to me to, KDE 4.3.2, ATI Radeon HD4850 and Catalyst 9.10, though it's been happening for several versions of KDE and Catalyst now.
Comment 30 pgnet 2009-11-02 21:57:31 UTC
same issue/behavior, on Opensuse 11.2 RC2 +

 kde4-config --version
  Qt: 4.5.3
  KDE: 4.3.1 (KDE 4.3.1) "release 183"
  kde4-config: 1.0

and,

  NVidia GeForce 9600 GT
Comment 31 Nick Elliott 2009-11-13 11:00:44 UTC
I am running Kubuntu 9.10 (amd64)

KDE 4.3.2
ATI Radeon HD4850
Core 2 Duo E8500

Prior to 9.10 desktop effects made my system unusable but after installing proprietary ATI drivers on 9.10 they started working with no problems.

However I also experience desktop effects being disabled on startup but not 100% of the time. Occasionally effects are working on login though most times they are not, when they are not working I can nearly always get them to restart but not always.
Comment 32 Adrián 2009-11-14 20:22:23 UTC
Hi, i have the same issue, on Kubuntu 9.10 (amd64).

KDE 4.3.2
ATI Radeon HD2400XT
Core 2 Duo E8400
Comment 33 Marcello Maggioni 2009-11-15 19:44:24 UTC
Same problem here with a Radeon HD 5850 - Catalyst 9.10 Xorg 1.6.3

Pressing two times Shift+Alt+F12 enable the effects that then work without problems.
Comment 34 Telmo Xtra 2009-11-21 10:44:15 UTC
Ok. I have the same problem:

After login, composing effects are disabled. If I go to System Settings and try to enable them I get an error that an application has disabled them, and I need to enable it with shift-alt-f2. The weird thing is that I need to do this twice to proper enable the effects. After that everything works as it should:

KDE 4.3.3
ATI 4870
ATI Catalyst 9.10. (Going to upgrade to 9.11)
I7 920 processor.
Comment 35 sergio.guibert 2009-11-23 06:22:13 UTC
The problem still occurs on
Kubuntu 9.10
with kde 4.3.3
and pre-release catalyst driver 9.11 with Radeon HD4870.
Comment 36 cristian_anita 2009-12-05 20:11:30 UTC
Hi All,

I want to confirm this bug.

My system:
- processor: i5 750
- distro: openSUSE 11.2 x86_64
- kernel: 2.6.31.5-0.1-desktop
- GPU: ATI Radeon HD 4770 (RV740 94B3)
- video driver: fglrx
ati-fglrxG02-kmp-desktop-8.661_2.6.31.5_0.1-23.1.x86_64
x11-video-fglrxG02-8.661-25.1.x86_64
installed from ATI's openSUSE 11.2 repo: http://www2.ati.com/suse/11.2/

- X.Org X Server 1.6.5

> kde4-config --version
Qt: 4.6.0
KDE: 4.3.4 (KDE 4.3.4) "release 2"
kde4-config: 1.0

> glxinfo | grep -i version
server glx version string: 1.4
client glx version string: 1.4
OpenGL version string: 2.1.9026
glu version: 1.3

As workaround I've checked "Disable functionality checks" in Personal Settings->Look & Feel->Desktop->Desktop Effects, Advanced tab and it works.

Thanks,
Cristian
Comment 37 cristian_anita 2009-12-05 20:33:48 UTC
Created attachment 38853 [details]
glxinfo full output
Comment 38 Grissiom 2009-12-19 08:04:58 UTC
Yes, I can confirm this bug in my box.

ATI Technologies Inc RS485 [Radeon Xpress 200M]
Driver: xf86-video-ati-6.12.2
Comment 39 Sven Ginka 2009-12-27 15:45:54 UTC
I have the same problem (mandriva amd64):

After login, compositing effects are disabled. If I go to System Settings and try
to enable them I get an error that an application has disabled them, and I need
to enable it with shift-alt-f2. After that everything works as it should:


Qt: 4.5.3
KDE: 4.3.2 (KDE 4.3.2)
kde4-config: 1.0

Xorg 1.6.5

server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
OpenGL version string: 2.1.8918
OpenGL shading language version string: 1.40


ATI HD 4770
AMD X4 905e
Comment 40 Bernhard Kohn 2010-01-29 12:31:19 UTC
I've got the same problem.

OpenSUSE 11.2 x86_64
KDE 4.3.4 "release 2"
Linux 2.6.31.8-0.1-desktop x86_64
ATI RV710 [Radeon HD 4350]
Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz

server glx version string: 1.4
client glx version string: 1.4
OpenGL version string: 2.1.9026
glu version: 1.3
Comment 41 Alberto 2010-02-12 11:27:00 UTC
I can confirm this problem

KDE 4.4.0
Ubuntu 9.10 x64
ATI HD 4850
Comment 42 Andrei ILIE 2010-02-21 17:15:45 UTC
I also confirm this bug.

Hard: Intel Q6600, Intel MB, ATI HD 2600 XT
Soft: OpenSUSE 11.2, KDE 4.3.5

PS. glxinfo output attached
Comment 43 Andrei ILIE 2010-02-21 17:17:45 UTC
*** There was a problem with the attachement, so I just copy / paste here yhe glxinfo output:

name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method, 
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
client glx vendor string: ATI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory, 
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_NV_swap_group, 
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control, 
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig, 
    GLX_SGIX_pbuffer, GLX_SGIX_swap_barrier, GLX_SGIX_swap_group, 
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap, 
    GLX_EXT_framebuffer_sRGB, GLX_ARB_fbconfig_float
GLX extensions:
    GLX_ARB_create_context, GLX_ARB_create_context_profile, 
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_swap_control, 
    GLX_NV_swap_group, GLX_OML_swap_method, GLX_SGI_make_current_read, 
    GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample, 
    GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, GLX_SGIX_swap_barrier, 
    GLX_SGIX_swap_group, GLX_SGIX_visual_select_group, 
    GLX_EXT_texture_from_pixmap
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 2600 XT
OpenGL version string: 3.2.9551 Compatibility Profile Context
OpenGL extensions:
    GL_AMDX_name_gen_delete, GL_AMDX_vertex_shader_tessellator, 
    GL_AMD_draw_buffers_blend, GL_AMD_performance_monitor, 
    GL_AMD_shader_stencil_export, GL_AMD_vertex_shader_tessellator, 
    GL_ARB_blend_func_extended, GL_ARB_color_buffer_float, GL_ARB_copy_buffer, 
    GL_ARB_depth_buffer_float, GL_ARB_depth_clamp, GL_ARB_depth_texture, 
    GL_ARB_draw_buffers, GL_ARB_draw_buffers_blend, 
    GL_ARB_draw_elements_base_vertex, GL_ARB_draw_instanced, 
    GL_ARB_fragment_coord_conventions, GL_ARB_fragment_program, 
    GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader, 
    GL_ARB_framebuffer_object, GL_ARB_framebuffer_sRGB, 
    GL_ARB_geometry_shader4, GL_ARB_half_float_pixel, 
    GL_ARB_half_float_vertex, GL_ARB_instanced_arrays, 
    GL_ARB_map_buffer_range, GL_ARB_multisample, GL_ARB_multitexture, 
    GL_ARB_occlusion_query, GL_ARB_pixel_buffer_object, 
    GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_provoking_vertex, 
    GL_ARB_seamless_cube_map, GL_ARB_shader_objects, 
    GL_ARB_shader_texture_lod, GL_ARB_shading_language_100, GL_ARB_shadow, 
    GL_ARB_shadow_ambient, GL_ARB_sync, GL_ARB_texture_border_clamp, 
    GL_ARB_texture_buffer_object, GL_ARB_texture_compression, 
    GL_ARB_texture_compression_rgtc, GL_ARB_texture_cube_map, 
    GL_ARB_texture_env_add, GL_ARB_texture_env_combine, 
    GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3, 
    GL_ARB_texture_float, GL_ARB_texture_mirrored_repeat, 
    GL_ARB_texture_multisample, GL_ARB_texture_non_power_of_two, 
    GL_ARB_texture_rectangle, GL_ARB_texture_rg, GL_ARB_texture_snorm, 
    GL_ARB_transpose_matrix, GL_ARB_uniform_buffer_object, 
    GL_ARB_vertex_array_bgra, GL_ARB_vertex_array_object, 
    GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_vertex_shader, 
    GL_ARB_window_pos, GL_ATI_draw_buffers, GL_ATI_envmap_bumpmap, 
    GL_ATI_fragment_shader, GL_ATI_meminfo, GL_ATI_separate_stencil, 
    GL_ATI_texture_compression_3dc, GL_ATI_texture_env_combine3, 
    GL_ATI_texture_float, GL_ATI_texture_mirror_once, GL_EXT_abgr, 
    GL_EXT_bgra, GL_EXT_bindable_uniform, GL_EXT_blend_color, 
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate, 
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_compiled_vertex_array, 
    GL_EXT_copy_buffer, GL_EXT_copy_texture, GL_EXT_draw_buffers2, 
    GL_EXT_draw_instanced, GL_EXT_draw_range_elements, GL_EXT_fog_coord, 
    GL_EXT_framebuffer_blit, GL_EXT_framebuffer_multisample, 
    GL_EXT_framebuffer_object, GL_EXT_framebuffer_sRGB, 
    GL_EXT_geometry_shader4, GL_EXT_gpu_program_parameters, 
    GL_EXT_gpu_shader4, GL_EXT_histogram, GL_EXT_multi_draw_arrays, 
    GL_EXT_packed_depth_stencil, GL_EXT_packed_float, GL_EXT_packed_pixels, 
    GL_EXT_pixel_buffer_object, GL_EXT_point_parameters, 
    GL_EXT_provoking_vertex, GL_EXT_rescale_normal, GL_EXT_secondary_color, 
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, 
    GL_EXT_subtexture, GL_EXT_texgen_reflection, GL_EXT_texture3D, 
    GL_EXT_texture_array, GL_EXT_texture_buffer_object, 
    GL_EXT_texture_buffer_object_rgb32, GL_EXT_texture_compression_latc, 
    GL_EXT_texture_compression_rgtc, GL_EXT_texture_compression_s3tc, 
    GL_EXT_texture_cube_map, GL_EXT_texture_edge_clamp, 
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine, 
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic, 
    GL_EXT_texture_integer, GL_EXT_texture_lod, GL_EXT_texture_lod_bias, 
    GL_EXT_texture_mirror_clamp, GL_EXT_texture_object, 
    GL_EXT_texture_rectangle, GL_EXT_texture_sRGB, 
    GL_EXT_texture_shared_exponent, GL_EXT_texture_snorm, 
    GL_EXT_texture_swizzle, GL_EXT_timer_query, GL_EXT_transform_feedback, 
    GL_EXT_vertex_array, GL_EXT_vertex_array_bgra, 
    GL_IBM_texture_mirrored_repeat, GL_KTX_buffer_region, GL_NV_blend_square, 
    GL_NV_conditional_render, GL_NV_copy_depth_to_color, 
    GL_NV_explicit_multisample, GL_NV_primitive_restart, 
    GL_NV_texgen_reflection, GL_SGIS_generate_mipmap, 
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays, 
    GL_WIN_swap_hint, WGL_EXT_swap_control
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x2b 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x2c 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x2d 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x2e 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x2f 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  2 1 None
0x30 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  2 1 None
0x31 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  2 1 None
0x32 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  2 1 None
0x33 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x34 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x35 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x36 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x37 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  4 1 None
0x38 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  4 1 None
0x39 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  4 1 None
0x3a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  4 1 None
0x3b 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x3c 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x3d 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x3e 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x3f 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  6 1 None
0x40 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  6 1 None
0x41 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  6 1 None
0x42 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  6 1 None
0x43 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x44 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x45 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x46 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x47 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  8 1 None
0x48 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  8 1 None
0x49 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  8 1 None
0x4a 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  8 1 None
0x4b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x4c 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x4d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x4e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x4f 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x50 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x51 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x52 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  0 0 None
0x53 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x54 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x55 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x56 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x57 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  2 1 None
0x58 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  2 1 None
0x59 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  2 1 None
0x5a 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  2 1 None
0x5b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x5c 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x5d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x5e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x5f 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  4 1 None
0x60 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  4 1 None
0x61 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  4 1 None
0x62 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  4 1 None
0x63 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x64 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x65 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x66 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x67 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  6 1 None
0x68 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  6 1 None
0x69 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  6 1 None
0x6a 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  6 1 None
0x6b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x6c 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 None
0x6d 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x6e 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0 16 16 16 16  0 0 None
0x6f 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  8 1 None
0x70 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  8 1 None
0x71 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  8 1 None
0x72 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  0  0  0  0  0  8 1 None
0xa9 32 tc  0 32  0 r  y  .  8  8  8  8  0 24  0  0  0  0  0  4 1 Ncon
Comment 44 Nick Elliott 2010-03-15 09:59:03 UTC
Since I upgraded to 4.4 (Kubuntu 9.10 x64) compositing is always suspended after boot whereas before it was an occasional problem.

Also when I use Alt+Shift+F12 to re-start it requires 2 or more attempts and is sometimes accompanied by a plasma desktop crash or lancelot crash.
Comment 45 arimaniac 2010-03-18 01:01:25 UTC
WORKAROUND:
-----------
1) Open terminal and type: nano ~/.kde4/share/config/kwinrc
2) In "[Compositing]" section:
3) Enable the DisableChecks option: "DisableChecks=true" (without quotes)   
 
To test log out and log in again.
I confirm that it works on openSUSE 11.2 KDE x64 perfectly!
My hardware: Dell Studio 1737 (graphics: ATI Mobility Radeon 3650)
Comment 46 Nick Elliott 2010-03-18 09:17:37 UTC
Thanks for the workaround arimaniac, I can confirm this works on Kubuntu 9.10 x64 ATI Radeon HD4850.

Note on some systems kwinrc is in ~/.kde/share/config/
Comment 47 Andrei ILIE 2010-03-18 17:08:14 UTC
Same problem here with:
   OpenSUSE 11.2 x64
   ATI Radeon HD 2600 XT (ATI Catalyst Display Driver)

Setting "DisableChecks=true" is sadly just a trick. Please solve the real (root) problem.
Comment 48 Nick Elliott 2010-03-19 09:06:04 UTC
@Andrei

It is more than 'just a trick'. It has since been pointed out to me that this is a standard KDE system setting (System Settings...Desktop...Desktop Effects...Advanced...Disable functionality checks).
Comment 49 arimaniac 2010-03-19 14:30:38 UTC
Trick, workaround, or not ...  it appears to serve the community. 
Please post feedback regarding your system. 

If it is confirmed that works on many Linux 
flavours, this temp fix will do for now.  

Always been like that.. 

Cheers
Comment 50 G Cohen 2010-03-19 15:07:15 UTC
This trick/workaround is known for a while now (since comment #3) and it worked for me on Kubuntu, openSuse and others, and I assume it would work on most of them if not all. 
This bug is related to the fglrx drivers rather than ATI cards themselves since it doesn't happen when using the open source drivers (not to mention that compositing is faster when using open source drivers, where said drivers support compositing).
Comment 51 Jan F. 2010-04-08 09:54:00 UTC
I'm experiencing the same bug on kde 4.4.2, openSuse 11.2 and I'm using xorg-driver-video not a driver from ATI itself.
Comment 52 Ian Petts 2010-04-25 03:24:49 UTC
*** This bug has been confirmed by popular vote. ***
Comment 53 David Nemeskey 2010-10-24 18:52:14 UTC
I experience the same problem with KDE 4.5.1. The only difference is that I have an Intel GPU, so it's no (longer) an ATI problem.

Kubuntu 10.10
Dell Inspiron 1420
Intel 965GM
Comment 54 Nitesh Mistry 2010-10-29 20:21:11 UTC
I confirm this bug in KDE 4.5.1 on Kubuntu 10.10

Intel P4 3Ghz processor
Intel 82945G/GZ Integrated Graphics Controller
Comment 55 Thomas Lübking 2010-10-29 20:34:30 UTC
*** Bug 255565 has been marked as a duplicate of this bug. ***
Comment 56 Simon Lewis 2010-12-02 08:58:52 UTC
I have the same problem on hp550 laptop with Intel 965GME/GLE graphics controller with both Fedora 13 / KDE 4.5.3 (x86_64) and Fedora 14 KDE 4.5.3 (x86_64). This problem does not occur with Fedora 12 (x86_64) / KDE 4.5.3.

To recap:

The KDE Window Manager compositing is suspended by another application when Kwin is started. I can resume compositing using the Alt+Shift+F12 shortcut.

Clicking on Resume Compositing again, does enable compositing and it works
well.

I can also use Alt+Shift+F12 without going into System Settings, sometimes pressing press it twice for compositing to resume.

How to avoid suspension of compositing when starting kwin?
Comment 57 Angel 2010-12-13 19:04:48 UTC
WORKAROUND:
-----------
1) Go to:  ~/.kde/share/config/ and open the file kwinrc using any text editor 
2) In "[Compositing]" section:
3) Enable the DisableChecks option: "DisableChecks=true" (without quotes)   

To test log out and log in again.

I confirm that it works on Fedora 14 KDE 4.5.4 x64 perfectly!
My hardware: Intel Pentium Dual Core E5200, Intel DG41TY, Intel GMA X4500.
Comment 58 Simon Lewis 2010-12-13 19:33:35 UTC
(In reply to comment #57)

Thanks for your reply

I have subsequently found an easier method:

In the systems setting desktop effects dialogue, third tab, there is a tick-box to disable checks. This setting seems to be remembered when logging off/shutting down. This has to be done on a user by user basis. This laptop has 4 users.

I just wondered if there was a global setting somewhere?

Simon
Comment 59 Martin Flöser 2011-01-14 22:49:50 UTC
The self-check on startup has been removed since a minor release of the  4.5. If anyone is still experiencing this problem with either 4.5.5 or 4.6 please reopen.
Comment 60 David Johnson 2011-04-09 21:28:56 UTC
I have exactly the same problem with a default install of kubuntu 10.10 (KDE 4.5.1). The video card is a Radeon 4650HD. I do not have this problem under FreeBSD on the same system KDE version.

I have disabled functionality checks, but I consider that a work around and not a solution.
Comment 61 Martin Flöser 2011-04-09 22:59:29 UTC
(In reply to comment #60)
> I have exactly the same problem with a default install of kubuntu 10.10 (KDE
> 4.5.1).
yes as the fix is after 4.5.1