Bug 187241

Summary: FolderView doesn't support navigate using keyboard
Product: plasma4 Reporter: Michal <michalodstrcil>
Component: widget-folderviewAssignee: Plasma Bugs List <plasma-bugs>
Status: RESOLVED FIXED    
Severity: wishlist CC: finex, noragen, shantanu, ultrabla
Priority: NOR    
Version: unspecified   
Target Milestone: ---   
Platform: unspecified   
OS: Linux   
Latest Commit: Version Fixed In:

Description Michal 2009-03-15 17:30:12 UTC
Version:           unknown (using 4.2.66 (KDE 4.2.66 (KDE 4.3 >= 20090310)), compiled sources)
Compiler:          gcc
OS:                Linux (i686) release 2.6.28-gentoo-r3

This feature really missing me, just click on desktop and press the key on which is beginning some name of file and it will select. Or just navigate through icons using arrows and open it pressing Enter. 
FolderView can't be 100%  replacement of normal desktop until this features will be missing.
Comment 1 Shantanu Tushar 2009-04-09 19:51:19 UTC
Fixed by SVN revision 951580. Keyboard navigation and launch support added. Please mark BUG as resolved.
Comment 2 Michal 2009-04-09 22:19:46 UTC
Perfect, moving with keyboard and launching works nice, but still I can't jump on the right icon by writing a few first letters, do you plan to add this feature?
Comment 3 FiNeX 2009-08-08 22:39:48 UTC
Arrow keys works. INS and HOME buttons should be supported too.
Comment 4 Shantanu Tushar 2009-08-09 06:01:19 UTC
Ok, HOME expected to goto the first icon. I'm not sure what INS is supposed to do?
Comment 5 FiNeX 2009-08-09 10:47:37 UTC
@Shantau: I'm sorry, I wanted to write "END" button. I really don't know why I've wrote "INS".

"END" should move the selection to the last file.

Thanks for implementing this feature :-)
Comment 6 Michal 2009-09-05 18:35:38 UTC
I don't know why this is not still fixed. Moving in folderview using first letters of name is really basic feature and I believe this is the only thing missing in folderview applet to be suitable substitution of Desktop. 
Thanks for fixing at least moving using arrows but using other letters would be much better.
Comment 7 Shantanu Tushar 2010-01-21 06:09:38 UTC
Fix proposed at http://reviewboard.kde.org/r/2659/
Comment 8 Dario Andres 2010-02-24 14:01:01 UTC
*** Bug 190582 has been marked as a duplicate of this bug. ***
Comment 9 Dario Andres 2010-02-24 14:01:09 UTC
*** Bug 228301 has been marked as a duplicate of this bug. ***
Comment 10 Shantanu Tushar 2010-04-25 18:03:27 UTC
Revision 1118646 adds Type and select feature.
Fixed for KDE SC 4.5 Please close the bug as RESOLVED.

Thanks for reporting.
Comment 11 FiNeX 2010-07-11 12:05:09 UTC
I've just tried on KDE 4.5 RC2 and it is partially fixed: you have double press the keyboard key in order to select the file which starts whith that char.
Comment 12 Shantanu Tushar 2010-07-11 19:27:47 UTC
I tried it on current trunk and it works even if I press the key once. For example, if I press m it selects my Music directory.
Comment 13 FiNeX 2010-07-12 00:16:45 UTC
and what if you have the following directories:

- bar
- foo
- fii
- melody
- music
- zoo

press "m" quickly followed by "u" and you switch to "melody" and after to "music". Wait a bit and press "b".

I need to press "b" a second time in order to select "bar". Maybe the delay for resetting the key search is too long... I don't know if it could be this case.
Comment 14 Shantanu Tushar 2010-07-12 08:00:07 UTC
yes, If you press something before the reset timer expires, it won't select it. Actually there should be a visual feedback on that, which we couldn't do because this fix just made it before the 4.5 feature freeze. So, we will fix it (with either a visual feedback for the reset timer, or an entirely better approach) for 4.6 , but unfortunately you'll have to live with it for 4.5 .
Comment 15 FiNeX 2010-07-12 10:14:05 UTC
Try dolphin. It works well without any visual indicator. You could simply copy it's behaviour.

Probably it's only a matter of timeout value... in this way it could be possible to add the fix for 4.5.1, for example, and users will not need to wait other 6 months :-)

Thanks!!! :-)
Comment 16 Shantanu Tushar 2010-07-12 10:46:54 UTC
Yes, we can copy the behavior, but sadly not the code, as its something Qt provides. I might be implementing the same behavior, but I can't assure you when. And yes it's only a matter of timeout value, but deciding what the value should be is very very controversial. So, I guess its better to do it the QAbstractItemView way (i.e. Dolphin way), so you are free to blame me for pseudo-fixing the bug ;)