Bug 99861 - kmail marks messages as read when syncing a dimap mail folder
Summary: kmail marks messages as read when syncing a dimap mail folder
Status: RESOLVED REMIND
Alias: None
Product: kmail
Classification: Applications
Component: IMAP (show other bugs)
Version: 1.7.92
Platform: unspecified Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: triaged
Depends on:
Blocks:
 
Reported: 2005-02-20 15:02 UTC by Holger Schröder
Modified: 2008-11-07 17:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Holger Schröder 2005-02-20 15:02:06 UTC
Version:           1.7.92 (using KDE 3.3.92 (beta2), Gentoo)
Compiler:          gcc version 3.3.5 (Gentoo Linux 3.3.5-r1, ssp-3.3.2-3, pie-8.7.7.1)
OS:                Linux (i686) release 2.6.9-gentoo-r1

Hi,

i checked kmail from kde 3.4 beta2 today. so here it goes:

i copied my config files for kmail from a kde 3.3.2 install over to a new $KDEHOME. then i made a backup of $HOME/Mail to be safe.

then i synced a cached imap folder from a kolab 2 server for the first time. everything worked fine.

but now i have the following problem:

when i go into a subfolder in that account, say inbox/kde-core-devel, and then sync again via File->check mail in-> [Account], then in downloads the new files just fine. but when the step "syncing kde-core-devel" is reached, and i am reading a message, which is 100 messages above the last one (with more than 1000 messages in that subfolder), and there are some but not all messages before that one marked read, and most of the ones below that one marked unread, the following happens:
the message i am just reading is reached, and then somehow the next message is activated for reading (as if you would press "cursor right" by yourself), and it is marked as read, and this "loop" continues until i hit "Esc" to stop the syncing. so between the time when it first started going to the next message, and the time when i hit Esc it went through about ten messages, and showed them and marked them as read.
this isn´t always reproducible, but i had this already five times with an older kmail, and today i saw that it is still in the beta2 version. i don´t know if it is important, but i filter the mails locally from the inbox on [Account] into the different subfolders in it.


i guess it will not be easy to find this one, but i hope for the best, as it is a little bit annoying to loose track of which messages you already read and which ones not.

thanks, Holger
Comment 1 Luca Silvestrini 2005-02-25 13:43:17 UTC
I also experienced a similar problem. When I check for new mail on the IMAP server, I apply filters so that some incoming messages are moved to subfolders on the IMAP server. At the subsequent check, these are marked as read when the subfolder is checked for new mail/sync'ed.
Comment 2 Donatas Glodenis 2005-07-26 08:30:48 UTC
I can confirm this bug too. I am using KDE 3.4.1 on Kubuntu. I also filter mail in my dimap folders by mailing lists (those are in INBOX.forums.forumname type of directories) and when I download new mail, read some of it and then press F5 to make sure the read messages are marked as read in the server, so I can read the rest at work, I get all the unread messages marked as read...

It does defeat the purpose of IMAP, so it is a very urgent problem.
Comment 3 Bastian Venthur 2005-10-10 09:58:38 UTC
I think this bug can be merged with #104320 which has a more general description of this bug (status flags of messages of a DIMAP account get lost on synchronizing via check mail)
Comment 4 Donatas Glodenis 2007-09-13 08:34:21 UTC
This bug is STILL present in kmail 1.9.7 (kubuntu feisty) and has been present ever since I first contributed to this bug report. 

Please fix it.
Comment 5 David Faure 2007-09-14 13:28:00 UTC
Must be server-dependent, because it certainly doesn't happen to me.
Comment 6 Donatas Glodenis 2007-09-21 16:46:12 UTC
OK, one of the accounts with this problem is on a server with debian sarge and cyrus-imapd (1.5.19-20+sarge1) package.
Comment 7 Shem Valentine 2008-09-14 22:00:48 UTC
Unable to reproduce with kmail 1.10.1 and Courier IMAP.
Could be the specific filter being used as well.

Test taken to try and reproduce on both imap and dimap.

Have folder with ~250 email messages.
Create filter to move email messages to folder on arrival (To: <receiver> Move to: <folder>)
Generated 100 new email messages.

The new email messages were moved to the proper folder and remained unread.

I think we need the specific filter being used to attempt to reproduce accurately.
Comment 8 Michael Leupold 2008-11-07 17:18:26 UTC
I'm closing this for now because it's not reproducible without further information. Please reopen if the problem is still there and provide the filter you're using.