Bug 99804 - introduce templates in kmail
Summary: introduce templates in kmail
Status: RESOLVED DUPLICATE of bug 1015
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Mandrake RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-19 18:41 UTC by Ber Kessels
Modified: 2005-02-19 19:51 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ber Kessels 2005-02-19 18:41:41 UTC
Version:           1.7.1 (using KDE KDE 3.3.1)
Installed from:    Mandrake RPMs
OS:                Linux

Heavier email users will relly miss the ability to use templates in KMail.
Off course one can use an extermnal application that calls kmail, but integration would be nice. 

I am thinking of two possible ways to implement this. 
Simple: a folder, like drafts, but where messages are stored, and not removed after sending.
Heavier: A kontact plugin where you store templates, with variables. When selecting a variable, you will get a dialog screen where you cn fill in these variables. 
An example could be: 
Dear [name:text],
On [date:date] you blablabla
with kind regards, 
[signature:text]

This template will present a dialog with the fields you can fill in. When you press "preview" it is made into text, and parsed into a new-mail screen.

Useage of templates should be added to "create new mail", "forward" and "reply". For example: "reply" would have a subdirectory, "reply with", which will contain a list of all templates. "Create new mail" would contain subdir "create mail from" with a list with all templates.

off course it would be even better is this is also added to the command line option: $ kmail --template template|templatename

Thank you for reading. 
Bèr Kessels
Comment 1 Stephan Binner 2005-02-19 19:51:17 UTC

*** This bug has been marked as a duplicate of 1015 ***