Bug 99570 - amaroK stutters when I change song
Summary: amaroK stutters when I change song
Status: RESOLVED DUPLICATE of bug 102708
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 1.2
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-17 03:17 UTC by Jonathan Leighton
Modified: 2006-06-11 12:32 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Leighton 2005-02-17 03:17:02 UTC
Version:           1.2 (using KDE KDE 3.3.0)
Installed from:    Gentoo Packages
Compiler:          gcc 
OS:                Linux

When I change to a different song, CPU usage goes to 100% for approx. a second, and the currently playing song will momentarily stop. It will then continue playing whilst fading out and moving to the next song.

It was suggested in IRC that the problem may be this: http://amarok.kde.org/wiki/index.php/FAQ#Why_is_there_always_a_gap_although_I_have_crossfading_enabled.3F, but I don't have that plugin installed. Someone else in IRC said they were experiencing the same problem on a Debian box.
Comment 1 Mark 2005-02-17 14:10:34 UTC
I have this problem as well, and also, do not have the gst-ffmpeg plugin installed. I would love to have this problem resolved as the program is awesome otherwise.
Comment 2 Mark 2005-02-17 14:11:40 UTC
Additional info: using amaroK (and KDE) from CVS_HEAD with GStreamer. Athlon 1.4GHz system with 768MB RAM.
Comment 3 Jonathan Leighton 2005-02-17 14:43:06 UTC
I've been investigating today, and this bug seems to be GST related, as it doesn't happen when using aRts.
Comment 4 Mark 2005-02-17 22:33:11 UTC
Downgrading GStreamer to 0.8.7 and gst-plugins 0.8.4 fixed it for me, actually.
Comment 5 Jonathan Leighton 2005-02-18 00:08:37 UTC
Hmmm, interesting. I'm using xine for the moment. Can any devs shed some light on this? Should this be reported to the GStreamer project?
Comment 6 Jonathan Leighton 2005-02-19 00:51:34 UTC
I recently realised that I was using software from the testing tree, so I've downgraded and also no longer experience the problem.

So it would seem that the bug is with GST 0.8.9 and/or GST-plugins 0.8.7. Are you on Gentoo too? If so then maybe it's a problem with the packages as opposed to GST itself.

I'll resolve this for now, and reopen it if you were using packages that are outside of testing for your distro.
Comment 7 Jonathan Leighton 2005-03-01 18:01:42 UTC
I'm now using Amarok 1.2.1 which requires GST-plugins 0.8.7 and GST 0.8.9. Now the problem is back again. Should I report this to the GStreamer project?
Comment 8 Lars Heer 2005-03-01 20:45:17 UTC
I've got the same problem in debian sarge.
Compiled the 1.2.1 by myself with the gstreamer-plugins of debian sarge:
0.8.7-3

libgstreamer0.8 0.8.8-1
 
Comment 9 Mark Kretschmann 2005-03-01 21:48:16 UTC
CVS commit by markey: 

update

BUG: 99570


  M +2 -2      ChangeLog   1.537


--- kdeextragear-1/amarok/ChangeLog  #1.536:1.537
@@ -7,6 +7,6 @@
   FIX: GStreamer-engine can now play vorbis radio streams properly, with
        full metadata support. (BR 89821)
-  FIX: GStreamer-engine now uses the modern "decodebin" autoplugger, which
-       fixes the lag issues that some users had during crossfading.
+  FIX: GStreamer-engine now uses the "decodebin" autoplugger, which fixes
+       the lag issues that some users had during crossfading. (BR 99570)
 
 VERSION 1.2.1:


Comment 10 Mark Kretschmann 2005-03-01 21:49:32 UTC
Should be fixed in CVS HEAD. Please test.
Comment 11 Jonathan Leighton 2005-03-02 18:37:20 UTC
Tested, works for me. Thanks a lot :D.
Comment 12 Jonathan Leighton 2005-03-19 23:59:32 UTC
This seems to have re-appeared in CVS, to an extent. Maybe it was still kind of there all along.

Basically, crossfading is generally smooth(ish) between songs, but if you are cycling through multiple tracks then it starts to get very laggy. Is there anything that can be done?
Comment 13 Jonathan Leighton 2005-03-27 22:24:44 UTC
I'm re-opening this because it's quite bad. Literally _every song change_ stutters. Also, the first second or two of a song will play quietly, then it will play at normal volume.
Comment 14 Caveman 2005-03-29 09:09:20 UTC
Is this bug like this one (http://bugs.kde.org/show_bug.cgi?id=102708).

The last comment makes it sound very much like that.

Comment 15 Jonathan Leighton 2005-03-29 21:46:26 UTC
Yes, it is *exactly* like that one, but I also get some stuttering. I don't know if the two are related, so let's leave them both open and see if the developers are able to give us any more information.
Comment 16 Matiss Piesins 2005-05-05 01:13:19 UTC
I also have this problem. See the following for some details: http://bugs.kde.org/show_bug.cgi?id=102708#c5
Comment 17 Alexandre Oliveira 2005-05-05 02:23:40 UTC
As said in BR #96680, it seems we had five bugs for two problems, so let's try to make the bug database sane.
This bug seems to be a mix of #96680 and #102708, so please, add your specific comments to one of those bugs.

*** This bug has been marked as a duplicate of 102708 ***