Bug 99166 - kword: automatic hyphenation is lost on copy/paste
Summary: kword: automatic hyphenation is lost on copy/paste
Status: RESOLVED FIXED
Alias: None
Product: kword
Classification: Miscellaneous
Component: general (show other bugs)
Version: 1.5 or before
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-12 01:11 UTC by Ben Burton
Modified: 2006-04-27 11:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2005-02-12 01:11:08 UTC
Version:           1.3.5 (using KDE KDE 3.3.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

(Received through the debian BTS as #277768.)

Hi.  It seems that the auto-hyphenation property is not preserved over copy-paste.

Specifically:  Create a new document and switch auto-hyphenation on.  Type lots of text and observe that hyphenation works as expected.

Now copy some long word (from your document) to the clipboard.  Type towards the end of a new line and then paste this word from the clipboard.  The word is not hyphenated, even though hypenation has been switched on for the entire kword session.

The original reporter of this bug says that he has to paste multiple times to observe this problem, but I can reproduce it with just a single paste on my machine.

Thanks - Ben.
Comment 1 David Faure 2005-12-05 22:43:52 UTC
This is fixed in trunk (will become koffice-1.5), most probably due to the rewrite of copy/paste to use the OASIS OpenDocument format.