Bug 98974 - kweather: international ICAO lookup site is confusing; perhaps try alternatives?
Summary: kweather: international ICAO lookup site is confusing; perhaps try alternatives?
Status: RESOLVED NOT A BUG
Alias: None
Product: kweather-kde3
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: geiseri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-09 23:20 UTC by Ben Burton
Modified: 2007-03-03 17:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2005-02-09 23:20:15 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

(Received through the debian BTS as #294093).

Hi.  A debian user reported that kweather's ICAO lookup site (http://www.nws.noaa.gov/tg/siteloc.shtml) does not contain ICAO codes for Australia.  After some further discussion we sorted things out -- the problem was that there are _lots_ of stations with WMO index numbers but only very few with ICAO codes.

One issue here was that it wasn't immediately obvious that you want the four letters (ICAO) and not the five digits (WMO) -- especially given that (for Australia at least) the page is by far dominated by WMO numbers.

Having pinpointed the issue, the user has made the following request:

"I have now tried and failed twice to use that website to get that information (it's not very clear at all which code is the ICAO code, or that ICAO codes are not available for all locations).  I suspect that other users would also be confused by this, and give up on using kweather, as a result.   I did this a few months ago, and I was only trying again today because someone else was asking me about it, and having exactly the same problem with that website.

"I think that it would be good if kweather could use a less confusing website for finding international ICAO codes.  I had a look, and found the following possibilities:

http://www.airport-technology.com/icao-codes/
https://pilotweb.nas.faa.gov/qryhtml/icao/

"I'm sure there would be other websites with the same information."

Thanks - Ben.
Comment 1 Martin Koller 2007-03-03 17:58:09 UTC
kweather no longer has the possibility to enter the ICAO code directly. Instead it shows a more user friendly country/location selector in a tree widget.

Therefore this report is no longer valid.