Bug 98972 - kile: please add a print menu option in postscript preview
Summary: kile: please add a print menu option in postscript preview
Status: RESOLVED FIXED
Alias: None
Product: kile
Classification: Applications
Component: general (show other bugs)
Version: 1.7.1
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Jeroen Wijnhout
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-09 22:36 UTC by Ben Burton
Modified: 2006-04-27 11:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2005-02-09 22:36:19 UTC
Version:           1.7.1 (using KDE KDE 3.3.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

(Received through the debian BTS as #285035).

Hi.  A debian user has reported that, when viewing postscript from within kile, there is no File->Print menu entry.  There is a print button on the toolbar, but no corresponding action in the menu.  Note that the embedded DVI viewer does have a print menu item as expected.

I'm reporting this against kile, but I'm not sure where the bug really belongs.  I don't know if the problem is with the kghostviewpart itself or with the way that kile uses the kghostviewpart (e.g., a broken kileui.rc).

Thanks - Ben.
Comment 1 Jeroen Wijnhout 2005-02-10 09:08:06 UTC
Actually getting the toolbar button there was already hell, as far as the menu 
item goes: I didn't even bother...

The reason is in KGhostView, it doesn't show the print button unless you are 
Konqueror (yes, this is strange). The KGhostView author couldn't come up with 
a solution either. However we could try again, I guess.

best,
Jeroen

Comment 2 Thomas Braun 2006-01-22 19:11:45 UTC
Hello,
thanks for your report.
We fixed this bug in the development (svn) version of kile.
The fix will be included in the upcoming Kile 1.9 release.

Regards,
Thomas Braun