Bug 98665 - kturtle: compiler error messages have wrong line number
Summary: kturtle: compiler error messages have wrong line number
Status: RESOLVED FIXED
Alias: None
Product: kturtle
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Cies Breijs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-06 02:04 UTC by Ben Burton
Modified: 2005-02-11 00:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Burton 2005-02-06 02:04:17 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    Debian testing/unstable Packages
OS:                Linux

(Received through the debian BTS as #293582.)

Hi.  I realise a bug regarding error line numbers was already reported against kturtle (#96552), but that appeared to be an underflow/overflow issue; this seems to be something different.

I can confirm this; thought I get different numbers.  The debian user seems to find the line numbers are counted by non-comment lines, whereas in my tests the errors are all reported on line 3 (regardless of where they actually are).

Anyway: below is the debian user's original report.  If the issue has in fact been fixed in current CVS, is it easy to provide a backport to KDE_3_3_BRANCH?

Thanks - Ben.


KTurtle shows wrong line number when a Parse Error is found. Looks like it is always first non-empty non-comment line. For example:

Begin withoug matching end on line 3
Details
  Error code: 1050
  Exact location: 3,29

I got the above messages from this program:

#Kukka 2

reset
canvassize 170,170
canvascolor 204,57,106
go 50,130
pencolor 150,50,200
penwidth 3

repeat 8 [
  repeat 4 [
    forward 20
    turnright 30
    wait 0.2
  ]
  repeat 7 [
    forward 7
    turnright 15
     wait 0.2
  ]
  repeat 9 [
    forward 3
    turnright 10
    wait 0.2 [
-------------^
Actual error is here, on line 24
  ]
]

go 150,150
Comment 1 Cies Breijs 2005-02-07 23:46:23 UTC
> Anyway: below is the debian user's original report.
> If the issue has in fact been fixed in current CVS, 
> is it easy to provide a backport to KDE_3_3_BRANCH?

Thanks for reporting... the bug will be fixed in kde 3.4, the release is out in a few weeks. I'm sorry but i dont have time enought for backporting a lot, i also messed heavily eith the code, so it might even not be possible.

P.S.: I (cies.breijs*AT*gmail!com) looks for user reports of KTurtle :)

bye!
Comment 2 Cies Breijs 2005-02-11 00:34:01 UTC
for this one i guess you saw my comment on it:

http://bugs.kde.org/show_bug.cgi?id=98665

sorry my time is rather limited.

_cies.


On Thu, 10 Feb 2005 10:51:23 -0800 (PST), Ben Burton <bab@debian.org> wrote:
> ------- You are receiving this mail because: -------
> You are the assignee for the bug, or are watching the assignee.
> 
> http://bugs.kde.org/show_bug.cgi?id=98665
>            Summary: kturtle: compiler error messages have wrong line number
>            Product: kturtle
>            Version: unspecified
>           Platform: Debian testing
>         OS/Version: Linux
>             Status: NEW
>           Severity: normal
>           Priority: NOR
>          Component: general
>         AssignedTo: kde showroommama nl
>         ReportedBy: bab debian org
> 
> Version:            (using KDE KDE 3.3.2)
> Installed from:    Debian testing/unstable Packages
> OS:                Linux
> 
> (Received through the debian BTS as #293582.)
> 
> Hi.  I realise a bug regarding error line numbers was already reported against kturtle (#96552), but that appeared to be an underflow/overflow issue; this seems to be something different.
> 
> I can confirm this; thought I get different numbers.  The debian user seems to find the line numbers are counted by non-comment lines, whereas in my tests the errors are all reported on line 3 (regardless of where they actually are).
> 
> Anyway: below is the debian user's original report.  If the issue has in fact been fixed in current CVS, is it easy to provide a backport to KDE_3_3_BRANCH?
> 
> Thanks - Ben.
> 
> KTurtle shows wrong line number when a Parse Error is found. Looks like it is always first non-empty non-comment line. For example:
> 
> Begin withoug matching end on line 3
> Details
>   Error code: 1050
>   Exact location: 3,29
> 
> I got the above messages from this program:
> 
> #Kukka 2
> 
> reset
> canvassize 170,170
> canvascolor 204,57,106
> go 50,130
> pencolor 150,50,200
> penwidth 3
> 
> repeat 8 [
>   repeat 4 [
>     forward 20
>     turnright 30
>     wait 0.2
>   ]
>   repeat 7 [
>     forward 7
>     turnright 15
>      wait 0.2
>   ]
>   repeat 9 [
>     forward 3
>     turnright 10
>     wait 0.2 [
> -------------^
> Actual error is here, on line 24
>   ]
> ]
> 
> go 150,150
>