Bug 98336 - when applying filters (CTRL-J), no clock-mouse cursor is displayed and UI is blocked
Summary: when applying filters (CTRL-J), no clock-mouse cursor is displayed and UI is ...
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.7.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-01 11:21 UTC by Pascal Niklaus
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal Niklaus 2005-02-01 11:21:55 UTC
Version:           1.7.2 (using KDE 3.3.2, compiled sources)
Compiler:          gcc version 3.3.3 (SuSE Linux)
OS:                Linux (i686) release 2.6.5-7.111.19-default

When applying filters to the mailbox, the application is completely locked, no busy-mousecursor is displayed (clock), and no cancel option is provided.

This would be important since filter operations can take a very long time (just ran a filter over a mailbox with several thousand messages). For such operations, either a cancel option/progress dialog should be provided, and/or they should run in the background. At least, the mouse cursor should indicate that the application is busy.
Comment 1 Andreas Gungl 2005-02-05 21:34:08 UTC
You missed one of the highest rated KDE bug reports when looking for existing duplicates. Consider voting for http://bugs.kde.org/show_bug.cgi?id=41514

*** This bug has been marked as a duplicate of 41514 ***