Bug 97677 - it's not possible to disable kgpg's tray icon
Summary: it's not possible to disable kgpg's tray icon
Status: RESOLVED FIXED
Alias: None
Product: kgpg
Classification: Applications
Component: general (show other bugs)
Version: 1.2
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Jimmy Gilles
URL:
Keywords:
: 146475 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-22 22:35 UTC by Vaclav Slavik
Modified: 2007-09-25 08:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vaclav Slavik 2005-01-22 22:35:48 UTC
Version:           1.2 (using KDE KDE 3.3.2)
Installed from:    Gentoo Packages
Compiler:          gcc 3.4.3 g++ (GCC) 3.4.3  (Gentoo Linux 3.4.3, ssp-3.4.3-0, pie-8.7.6.6)
OS:                Linux

When I run kgpg from Konqueror's right-click menu in order to sign or encrypt a file, kgpg won't exit after it's done with encrypting/signing. Instead, it will dock itself in system tray. Unlike with majority of X11 programs, there's no way to disable this behaviour. I understand that some people find it useful to have kgpg sitting in the dock all the time, but I'm not one of them and it's extremely annoying. I use kgpg only rarely and I *always* use it from Konqueror and never by dragging a file to tray icon or using tray icon's popup menu. For my way of using Kgpg, it's insistence on occupying valuable place in the tray is usability bug for my use case. Could this behaviour please be made optional?
Comment 1 Jimmy Gilles 2007-09-02 20:52:56 UTC
*** Bug 146475 has been marked as a duplicate of this bug. ***
Comment 2 Rolf Eike Beer 2007-09-25 08:07:25 UTC
SVN commit 716723 by dakon:

Make systray icon optional

BUG:97677


 M  +14 -0     conf_misc.ui  
 M  +9 -1      kgpg.cpp  
 M  +4 -0      kgpg.kcfg  
 M  +12 -0     kgpgoptions.cpp  
 M  +1 -0      kgpgoptions.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=716723