Bug 97616 - Maximize button not shown when window maximum size becomes larger than work area
Summary: Maximize button not shown when window maximum size becomes larger than work area
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: RedHat RPMs Linux
: NOR normal with 3 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-21 19:09 UTC by Simon Perreault
Modified: 2011-12-10 12:27 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Perreault 2005-01-21 19:09:16 UTC
Version:            (using KDE KDE 3.3.1)
Installed from:    RedHat RPMs

When a window has a maximum size smaller than the work area, no maximize button is shown, which is good. However, if that window's maximum size changes during execution and becomes bigger than the work area, there is still no maximize button shown, when there should be one.
Comment 1 Martin Flöser 2011-12-10 10:15:40 UTC
sorry that nobody replied for such a long time. As I am not sure whether this issue still persists in KDE 4 I set to unmaintained. If the issue is still present in a recent release please open a new report.
Comment 2 Thomas Lübking 2011-12-10 12:27:03 UTC
client.cpp:2245
I knew I fixed it, but don't ask me when ;-)