Bug 97243 - send message filters apply after sending, not before
Summary: send message filters apply after sending, not before
Status: RESOLVED DUPLICATE of bug 48938
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Slackware Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-17 15:31 UTC by Andrew Kohlsmith
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Kohlsmith 2005-01-17 15:31:09 UTC
Version:            (using KDE KDE 3.3.91)
Installed from:    Slackware Packages

In 3.4beta1 you have filters which seem to be meant to apply to messages BEFORE they are sent (request delivery, rewrite header, etc.) but the rewrite header applies post-send, not pre-send.

If I set up a filter to change the From: address (From is not in the pulldown, but I wrote "From" in and it took) and send a message to my test account, the message the test account receives is *not* altered, while my sent-mail is.

Please don't continue to tease me like this.  :-)  This is very similar to bug 48938 but it is marked as wishlist while this now appears to be a bug since these actions only have meaning if they are applied before sending.

You have added "Set Identity to" and "Set Fake MDN" and "Rewrite Header".  The first just plain doesn't work (both received message and sent mail do not show it coming from the selected identity), the second doesn't appear to do anything (I noticed no changes in the headers on the received message nor the message in the sent mail), and the third... well this is what the bug is on.

These actions only make sense if they are applied pre-send.  I am keen on using the "Rewrite Header" feature for the 13 or so mailing lists I'm on.  Please don't make me click an "apply filter" button or hotkey -- that's no better than what I have now (manually clicking on the To: and altering the From: name) -- the filters are a powerful, powerful feature for automating this kind of work.
Comment 1 Andreas Gungl 2005-01-18 20:31:48 UTC
Hi Andrew, reports usually don't get lost. There is no need to report issues twice or more. The only thing what might help to accelerate is to sponsor more time to develop on KMail or sending a patch. Regards,
Andreas

*** This bug has been marked as a duplicate of 48938 ***
Comment 2 Andrew Kohlsmith 2005-01-18 20:57:19 UTC
Wasn't intending on it being a duplicate -- I understand they don't get lost but the other's classified as wishlist and the features are certainly in there now, but not working, which to me is a bug now and not a wishlist item.

I thought I'd dug around in the source ages ago to try and do this but came up short.