Bug 97189 - cpp code generator options without effect
Summary: cpp code generator options without effect
Status: RESOLVED DUPLICATE of bug 84739
Alias: None
Product: umbrello
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Umbrello Development Group
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-16 22:26 UTC by Henrik Steffien
Modified: 2005-01-16 23:04 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Henrik Steffien 2005-01-16 22:26:46 UTC
Version:           1.4.0-beta1 (using KDE KDE 3.3.1)
Compiler:          g++ (GCC) 3.3.5 (Debian 1:3.3.5-5) 
OS:                Linux

Hello,

i'm testing the version 1.4.0-beta1 compiled from source tarball (date: 2005-01-15 05:07).
I created a class diagram with one package and two classes and tried some cpp code generation options.
The option for generating accessor methods seems to have no effect. The generator always creates accessor methods. And the option, where the package name is used as cpp namespace, also has no effect. I can't find any namespace definition in the header oder cpp file. The files are placed in a directory named to the package.
Comment 1 Henrik Steffien 2005-01-16 22:45:29 UTC
I have to correct my bug report. The generation of the namespace is working correct. During my tests I compared the 1.4.0 against the 1.3.2. The version 1.3.2 has a lot of problems in the cpp generator. The package and namespace thing isn't working at all.
In version 1.4.0 the namespaces are correctly generated.
Comment 2 Oliver Kellogg 2005-01-16 23:04:25 UTC

*** This bug has been marked as a duplicate of 84739 ***