Bug 97066 - a different mail subject on bug reports
Summary: a different mail subject on bug reports
Status: RESOLVED FIXED
Alias: None
Product: bugs.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Matt Rogers
URL:
Keywords:
: 169482 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-01-15 13:19 UTC by Angelo Naselli
Modified: 2013-01-05 21:25 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Angelo Naselli 2005-01-15 13:19:28 UTC
Version:            (using KDE KDE 3.3.2)
Installed from:    Unspecified Linux

At this moment we receive mails with a subject lik this
[Bug XXXXXX] BUG title
What about receiving also the application in which the bud has been subscribed?
I mean something like this 
[Bug XXXXXX] [kprinter] BUG title
or for those application that haven't the "k" prefix:
[Bug XXXXXX] [KDE gwenview] BUG title

I think in this way it's easier to make a filter....
Comment 1 Angelo Naselli 2005-01-15 13:20:24 UTC
... mail filter of course :-)
Comment 2 Stephan Binner 2005-01-18 20:06:33 UTC
Why can't you filter on "Product: kprinter" content?
Comment 3 Angelo Naselli 2005-01-18 20:58:19 UTC
Well I can't say it's so for every kde appl, but
for gwenview, kipi and this bug this is my webmail view:

Subject: [Bug 97066] a different mail subject on bug reports

------- You are receiving this mail because: -------
You reported the bug, or are watching the reporter.
         
http://bugs.kde.org/show_bug.cgi?id=97066         




------- Additional Comments From binner kde org  2005-01-18 20:06 -------
Why can't you filter on "Product: kprinter" content?



		
__________________________________ 
Do you Yahoo!? 
Read only the mail you want - Yahoo! Mail SpamGuard. 
http://promotions.yahoo.com/new_mail 

Comment 4 Stephan Binner 2005-01-18 21:02:15 UTC
Ah, you're talking about the comments format. :-)
Comment 5 Angelo Naselli 2005-01-18 21:02:43 UTC
Oops i misunderstand yuor last, it's not a problem on bugzilla site
it's on mails sent. The subject shows only the bug number and the title
so if you're watching more than one application you need to read all
the mail before knowing what application is related to.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

Comment 6 Stephan Kulow 2005-01-20 13:12:30 UTC
I'm thinking about adding a X-Bugzilla-Product header as the old bug tracking system had. 
Comment 7 Angelo Naselli 2005-01-20 14:14:56 UTC
good, i'm ready to test it... :-)

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

Comment 8 Angelo Naselli 2005-04-30 10:49:47 UTC
No news from this problem?
Comment 9 Thiago Macieira 2005-04-30 21:27:52 UTC
No
Comment 10 Thomas McGuire 2007-03-21 19:54:48 UTC
I also would like a X-Bugzilla-Product header very much.
Comment 11 Thomas McGuire 2008-09-12 20:25:29 UTC
*** Bug 169482 has been marked as a duplicate of this bug. ***
Comment 12 Richard Hartmann 2008-09-12 20:46:11 UTC
X-Bugzilla-Product is nice, but it does not help the average user. Why not simply change the Subject format?
Comment 13 Matt Rogers 2008-09-13 06:44:07 UTC
X-Bugzilla-Product already exists now. Why should the subject of the email be different? Why not just write a mail rule to rewrite the subject to contain whatever is in X-Bugzilla-Product. I don't see why the product should be in the subject. Can you please provide a use case of some sort?
Comment 14 Richard Hartmann 2008-09-13 11:14:53 UTC
Well, there are three points, imo.

1) I do not like to rewrite mail. Filtering & moving into subfolders/redirecting is OK, but other than that, no changes should be made. I am aware that spam filters, mailing lists etc rewrite mail, but once it arrives, it should be atomic.

2) KDE is moving more and more towards casual users. Rewriting the Subject lines of their mail is something I can't see those people doing even if they report bugs. This is especially true for KDE 4 with lots of new bugs & issues and a handy 'report bug' button in all help menues.

3) An email should provide all relevant information by itself without any need to tinker with it.


As for use case, it would be "see what component this is about at a glance without any extra work". It can be a pain to see that quickly, especially when you received 20 tracker mails over night. Back in the KDE 2 times, I learned not to include the component name in the short description of issues as that duplicates information (and even if I and the others here started doing it, it would not help much).


Two suggestions:

1) It does not _need_ to be in the Subject line. Why not put it in the body? As it is, there are 5 newlines below the link which serve no purpose.

2) Make this an option.


I am not saying this should be done _now_ or that _you_ have to do it. I am completely happy if this went upstream (I can report it there if we reach consensus here).


Last but not least, what would be the reason _not_ to change it? Just because something has been done in a certain way does not mean it needs to be so forever.


Richard

PS: Thanks for the new BTS, I love it{s speed}. :)
Comment 15 Angelo Naselli 2008-09-13 22:58:58 UTC
To Comment #13  Matt, have a look at mandriva bugzilla and the related mailing list for instance. Without product on subject you can see a list of bugs in your mailbox and you *must*read one by one to see if you're interested in.
Why?
a) because you can't ask for a good subject to any reporters
b) even if it was, how can you understand which product is if a subject could
   be applied to more than a product ("crash invoking print menu" for instance)
IMO the subject is the right place, because it can be seen by a quick look, and
help either users to get in touch in bugs they are interested, or developers to follow bugs when they are involved in more than a product.

Angelo
P.S. please restore the reply to bug option, via mail i mean, that one helps a lot again
Comment 16 Richard Hartmann 2008-09-23 11:09:09 UTC
Another point about putting the component name in the subject: What if it is re-assigned to another component?

Also, as a use case example, consider this email & tell me what it is about without looking into BTS, mail headers or svn:



Subject: [Bug 152761] No session management in KDE 4 - Sessions / directory / tabs not restored on login

http://bugs.kde.org/show_bug.cgi?id=152761


Stefan Becker changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
  Attachment #27386 [details]|0                           |1
        is obsolete|                            |




--- Comment #43 from Stefan Becker <censored cause i am paranoid :)>  2008-09-22 20:01:49 ---
Created an attachment (id=27517)
 --> (http://bugs.kde.org/attachment.cgi?id=27517)
Proposed patch for upstream merge

* Rebased to KDE SVN commit 863413 (after whitespace cleanup)
* Reworked after review comments


-- 
Configure bugmail: http://bugs.kde.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Comment 17 Angelo Naselli 2008-09-24 15:24:47 UTC
Richard, I'm quite sure in mandriva bugzilla that works well. If you change a
component the mail sender script will read the new component and add it to the 
subject (so no conflicts with the old one). 
If you've subscribed that bug you should see a changed subject, but you should 
receive that bug report anyway. If you haven't you could find new report subject
interesting and follow it up instead.