Bug 96164 - Usability: Collection management and playlist handling suggestions
Summary: Usability: Collection management and playlist handling suggestions
Status: RESOLVED FIXED
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 1.2-CVS
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-02 15:54 UTC by Marcus Thiesen
Modified: 2006-06-11 12:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch for requirement 1 (682 bytes, patch)
2005-03-02 20:21 UTC, Alisson Sellaro
Details
Menu order changed in every occurence of "Append to Playlist" and "Queue After Current Track" (2.72 KB, patch)
2005-03-03 13:51 UTC, Alisson Sellaro
Details
Patch correction (725 bytes, patch)
2005-03-03 16:07 UTC, Alisson Sellaro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Thiesen 2005-01-02 15:54:41 UTC
Version:           1.2-CVS (using KDE 3.3.2,  (3.1))
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-5)
OS:                Linux (i686) release 2.6.9-selinux1-mobilhal

Ok, after using amaroK for my new years eve party, I have some suggestions about usability:

1. Switch order of "make playlist" and "queue as next track", because the first one is playlist destrictive while the second one is not. Some people do a really bad job on my notebook's touchpad, therefore this would make it easier not to destroy the playlist.

2. I believe that the collection managers double click behaviour should be configureable, because I'd like it to be append to playlist without directly playing the song. 

3. This is not really related because it is more or less a real bug: the hack you use to open the menu from the menu button on the lower right side does not work when the toolbar wraps around, i.e. if the context browser half is big enough  to make the toolbar wrap, the menu option, which is only accesibble over the >> button, does not open up the menu.
Comment 1 Mark Kretschmann 2005-01-02 16:19:58 UTC
On Sunday 02 January 2005 15:54, Marcus Thiesen wrote:
> 3. This is not really related because it is more or less a real bug: the
> hack you use to open the menu from the menu button on the lower right side
> does not work when the toolbar wraps around, i.e. if the context browser
> half is big enough  to make the toolbar wrap, the menu option, which is
> only accesibble over the >> button, does not open up the menu.

Can't confirm this. Works here.

Comment 2 Max Howell 2005-01-05 19:57:15 UTC
Cool! Did it work well at the party? I must say I'd be nervous to use CVS at a party. It's stability isn't much fun for me.

1. Good suggestion.

2. I agree. Browser double-clicks should perhaps be wholly configurable some place. The same behavious for all browsers though.

Will try to implement these one day.
Comment 3 Marcus Thiesen 2005-01-06 13:58:58 UTC
I had one crash, but I'm not really sure what the people did to make it crash. Usually I like throwing new audio playback software at people to make some sort of usability test. 

BTW, I more or less ran only amaroK, without any window manager and anything else fancy. The only thing that makes this a not as good solution is that amaroK still allows to phyically delete files. (I know that I can make them read only, I even did that, but I still think that there might be a --kiosk or --party to make it "safer")
Comment 4 Max Howell 2005-01-06 16:05:14 UTC
Our attitude with regard to the delete menu is that amaroK should be run as a user without write permissions. Afterall it is trivial to delete stuff if the user has write permissions even if amaroK hasn't a delete menuitem.

I know it possible to accidently click the menuitem, but everything's a compromise - it was a well requested feature. Anyway you probably don't want the party-guests editing the tags or moving the files with the file-browser either so running KDE as a user with no write permissions to those dirs is your safest bet.

Still we could always add the option, but I haven't the time myself, maybe we'll get a patch.
Comment 5 Alisson Sellaro 2005-03-02 20:21:28 UTC
Created attachment 9933 [details]
Patch for requirement 1

Implements sequence changing on menus, as required in item 1.
Comment 6 Alisson Sellaro 2005-03-03 13:51:57 UTC
Created attachment 9948 [details]
Menu order changed in every occurence of "Append to Playlist" and "Queue After Current Track"
Comment 7 Alisson Sellaro 2005-03-03 16:07:20 UTC
Created attachment 9951 [details]
Patch correction

Correcting generated patch for application
Comment 8 Alisson Sellaro 2005-03-08 15:44:59 UTC
CVS commit by sellaro: 

CCMAIL:amarok-devel@lists.sourceforge.net
CCBUGS:96164
Added ChageLog note for resolution of bug 96164, part 1


  M +2 -0      ChangeLog   1.547


--- kdeextragear-1/amarok/ChangeLog  #1.546:1.547
@@ -23,4 +23,6 @@
     * GStreamer-engine now uses the "decodebin" autoplugger, which fixes
       the lag issues that some users had during crossfading. (BR 99570)
+    * Switched order of "Make playlist" and "Queue after current track" menus
+      to avoid playlist destruction. (BR 96164 part 1)
 
 


Comment 9 Alexandre Oliveira 2005-04-23 08:33:23 UTC
Part number 2 is a dup of Bug #89727, and it seems nobody could reproduce number 3. Please, avoid reporting many problem in the same bug report, it gets a hell to mantain. :-)