Bug 95441 - Folder tree contextual menú does not show shortcuts assigned to the actions
Summary: Folder tree contextual menú does not show shortcuts assigned to the actions
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-12-19 09:31 UTC by Albert Astals Cid
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch that fixes the problem (4.87 KB, patch)
2004-12-21 22:23 UTC, Albert Astals Cid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Astals Cid 2004-12-19 09:31:54 UTC
Version:            (using KDE Devel)
Installed from:    Compiled sources

The actions that appear when clicking right menu button over a item on the folder tree do not show the shortcuts assigned by the user on Configure shortcut dialog.

How to reproduce:
 - Go to the configure shortcuts and assign a shortcut to Mark All Messages as Read
 - Click on folder menu, see the shortcut
 - Right click on a folder in the folder tree, see the shortcut is not there

I think that is because on kmfoldertree.cpp, you do things like
folderMenu->insertItem( SmallIconSet("goto"), i18n("Mark All Messages as &Read"), mMainWidget, SLOT( slotMarkAllAsRead() ) );
instead of pluging mMarkAllAsReadAction action created on 
kmmainwidget.cpp
Comment 1 Albert Astals Cid 2004-12-21 22:23:19 UTC
Created attachment 8760 [details]
Patch that fixes the problem

I sent a patch to kde-pim mailing list but nobody answered, i'm attaching it
here to see if i have more luck.
Comment 2 Till Adam 2004-12-21 22:54:05 UTC
Looks good in principle, I suppose you've checked that the action disabling/enabling still works, for folder_reload and such? If so, feel free to commit.
Comment 3 Albert Astals Cid 2004-12-21 23:50:17 UTC
CVS commit by aacid: 

Use the main window actions in the folder contextual menu
Approved by Till Adam
BUG: 95441
CCMAIL: benjami@gmail.com


  M +14 -45    kmfoldertree.cpp   1.339