Bug 95433 - up button should have on more step if on subdomain.host to ascend to host
Summary: up button should have on more step if on subdomain.host to ascend to host
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 96572 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-12-19 07:02 UTC by Marcel Partap
Modified: 2009-10-03 14:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Adds KUrl::hasSubDomain() (test included) and gives upUrl ability to ascend from subdomains (2.99 KB, patch)
2008-02-09 15:05 UTC, Marcel Partap
Details
implement the new ability of upUrl to ascend from subdomains in Konqueror up button (818 bytes, patch)
2008-02-09 15:07 UTC, Marcel Partap
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel Partap 2004-12-19 07:02:40 UTC
Version:           3.3.90 (using KDE 3.3.90 (alpha1, CVS >= 20041206), Gentoo)
Compiler:          gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)
OS:                Linux (i686) release 2.6.9-gentoo

it is debatable, but the google toolbar does it and I miss it. I.e. when on forums.gentoo.org, I have to manually delete 'forums' from location bar to go to the main site. If 'Up' had one more level...
Comment 1 Stephan Kulow 2004-12-22 21:42:13 UTC
Hmm, it does that before after it removed all path components? Are you sure this is not about document relations?
Comment 2 Maksim Orlovich 2005-01-08 18:00:09 UTC
*** Bug 96572 has been marked as a duplicate of this bug. ***
Comment 3 Marcel Partap 2005-01-08 18:19:41 UTC
ooops. lol. sorry.
Comment 4 Marcel Partap 2005-11-21 01:38:00 UTC
It is still not there in KDE 3.5RC1. omfg I wished I could code QT yet.
Comment 5 Marcel Partap 2005-12-05 02:45:12 UTC
...and not in final 3.5 aswell. from dot.kde.org to kde.org I still cannot go without using a link on the site or removing the dot. manually. Disgusting. ;O
Comment 6 Marcel Partap 2006-10-13 18:58:56 UTC
This thing still has not been fixed. One of the most trivial wishes ever, lost in time and space. D'oh.
Comment 7 Marcel Partap 2008-02-09 15:05:19 UTC
Created attachment 23498 [details]
Adds KUrl::hasSubDomain() (test included) and gives upUrl ability to ascend from subdomains
Comment 8 Marcel Partap 2008-02-09 15:07:45 UTC
Created attachment 23499 [details]
implement the new ability  of upUrl to ascend from subdomains in Konqueror up button
Comment 9 FiNeX 2009-10-03 14:38:48 UTC
It is working for me on KDE 4.