Bug 94814 - several Document Relations Toolbar appear when open link in new tab, no way to remove Document Relations forever :(
Summary: several Document Relations Toolbar appear when open link in new tab, no way t...
Status: RESOLVED DUPLICATE of bug 86113
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 3.3.2
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: Konqueror Developers
Depends on:
Reported: 2004-12-10 14:55 UTC by Zhitomirsky Sergey
Modified: 2005-02-21 02:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Zhitomirsky Sergey 2004-12-10 14:55:51 UTC
Version:           3.3.2 (using KDE 3.3.2 Level "a" , unofficial build of SUSE )
Compiler:          gcc version 3.3.1 (SuSE Linux)
OS:                Linux (i686) release 2.4.21-215-default

I have never seen "Document Relations" toolbar, up to and including KDE 3.3.0.
After installation of KDE 3.3.2 for Suse-9.0
after open link in new tab in conqueror several "Document Relations" appear. I deselect them all manually, but after next "open in new tab" even more Document Relations toolbar appear. Konqueror became unusable web browser due to this wonderful super-buggy feature.
I found no way to turn off them permanently in Configure konqueror , or Configure Toolbar.
Comment 1 Maksim Orlovich 2004-12-10 16:34:23 UTC
rm is your friend. 

*** This bug has been marked as a duplicate of 86113 ***
Comment 2 Zhitomirsky Sergey 2004-12-10 16:51:12 UTC
What did you mean by "rm is your friend" ? 
Comment 3 Stephan Binner 2004-12-10 16:56:27 UTC
rm $KDEDIR/lib/kde3/librellinksplugin.*
Comment 4 Maksim Orlovich 2004-12-10 16:59:21 UTC
rm /opt/kde3/share/apps/khtml/kpartplugins/plugin_rellinks.rc

Anyway, this ... thing is disabled for 3.4, and will probably be for a hypothetical 3.3.3 shortly, since the author doesn't seem to be doign anything to fix it :-(
Comment 5 oliver_stieber 2004-12-13 16:41:48 UTC
I was using document relations in 3.3 (and found it a lot more useful than the back button!), it's a shame that no-one from the kde team is prepaired to have a look and see what's broken this plugin, I thought one of the befits of OSS was that you could fix something that was broken even if the author was no longer around, especially when it's been picked up and put into KDE core.

I still can't see how this one got through QA.
Comment 6 Kanwar Plaha 2004-12-14 00:26:37 UTC
I am seeing this bug in 3.4 alpha1 as well ...
Comment 7 francesco biscani 2004-12-23 15:01:48 UTC
To fix this you can also edit file ~/.kde3.3/share/config/rellinksrc like this:

Comment 8 Robert Cabane 2005-01-03 21:53:44 UTC
Document relations come from Netscape/Mozilla, where they're called 'Navigation toolbar'. They're quite handy with certain documentary websites, allowing you to quickly find the index, table of contents, author, copyright, first & last page, and so on. I can't find them in FireFox, a pity.
Comment 9 Rees Machtemes 2005-01-11 06:55:45 UTC
For some reason, editing config files really didn't help me. And I don't like the idea of deleting files or libraries without being sure I'll never need them again. My solution is probably the least problematic and works great for me on KDE 3.3.2 (current stable build). This is what I did:

chmod 600 $KDEDIR/lib/kde3/librellinksplugin.*

This removes the libs from ever being loaded or excuted, at least as a non-root user. Hopefully this will be usefull to some until the new build comes out that removes these files. While this feature may be useful R. Cabane, it really ticks me off that it keeps loading them instead of one toolbar per konqueror session. Hopefully this can be fixed instead. Anybody else have problems with modifing the rc files?
Comment 10 Al Marczak 2005-01-12 22:34:39 UTC
I'm running SUSE 9.1 PRO. After updating to KDE 3.3 I encountered the same problem with the document relations tool bar. I used the YAST "Install/Remove"  "update" function to update kdeaddons3-konqueror 3.3 back to kdeaddons3-konqueror 3.2.1-44. YAST showed no dependancy problems and the system linked OK. Of course I lost the "document relations" functionality (the bug) and the Google tollbar, but everything else seems to work properly.
Comment 11 Richard Fujimoto 2005-01-23 18:51:47 UTC
This problem persists in the 3.4 beta1.

I have tried doing the config file change, but it didn't affect anything.  I have unchecked the toolbar (Settings->Toolbars->Doc...) then resaved my webbrowsing profile.  This works for the first two tabs, but after opening the third tab the document relations toolbar is back.

Can this bug be re-opened since it's not really a duplicate of #86113 since that bug describes multiplying Document relations toolbar while this one is about our inability to remove the toolbar permanently.
Comment 12 Andrew Kar 2005-02-04 07:21:45 UTC
Am I missing something? When you go to Document Relations in the Tools menu of Konq doesn't it give you the options to a)show b)never show and c) show when appropriate? And this was in KDE 3.3 so I dont know about later..

Comment 13 lezardbreton 2005-02-11 18:35:40 UTC
You have the options, but they don't work. I confirm the bug is still in Slackware 10.1/KDE-3.3.2
Comment 14 CTWaley 2005-02-21 02:26:32 UTC
I added the [Position] lines to the user config file as suggested by Francesco (comment #7), which worked...........Then I modified his suggestion by omitting the "Hidden=true" line, and it still seems to work okay...

When clicking on a link in a new tab or window, there will be a brief instance of the Document Relations toolbar appearing below the address bar, then disappears after the page finishes loading. I also have the option set to "When Necessary" (the appropriate line at the top of the rellinksrc config file will read "mode=when necessary")....

However, there will still be a growing number of "Document Relations (Konqueror)" lines appearing in the "Settings -> Toolbar" menu, which can be clicked on (selected) and having a rellinks toolbar appearing at the side....

Hopefully, this will provide a more suitable workaround for those who find the rellinks toolbar handy to have around and still stop the unnecessary, and maddening, appearance of those toolbars from interefering with normal browsing....