Bug 94062 - kmail: very limited filter capabilities, for example can not remove second filter rule
Summary: kmail: very limited filter capabilities, for example can not remove second fi...
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: filtering (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist with 60 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: junior-jobs
: 56875 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-11-28 11:46 UTC by esigra
Modified: 2011-10-10 07:42 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8


Attachments
Tree representation of filter rules as Kmail should do it (1.76 KB, image/png)
2004-11-28 11:47 UTC, esigra
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esigra 2004-11-28 11:46:02 UTC
Version:           1.7.1 (using KDE KDE 3.3.1)
Installed from:    Gentoo Packages
OS:                Linux

The current filter capabilities in Kmail are very limited in the following ways:
1. There must be at least 2 filter rules.
2. There can be at most 8 filter rules.
3. The ways to connect the rules with the logical operators (and, or) are very limited. It is either a conjunction or a disjunction of all rules.

This is both a bug and a wish. First the bug:
Please allow removing the second filter rule. Is there a reason to require at least 2 filter rules? And it does not seem to be possible to set the second rule to be empty, like a newly created rule.

The wish:
Allow any number of rules connected in any way. This should be displayed in a tree. See attached picture. The data structure could be stored in XML.
Comment 1 esigra 2004-11-28 11:47:47 UTC
Created attachment 8466 [details]
Tree representation of filter rules as Kmail should do it
Comment 2 Andreas Gungl 2004-11-28 14:26:42 UTC
You can clean the second filter rule. Simply delete the values in the combox box and in the edit field. That's why I change the servirity to "wishlist".

There are some ideas to extend the capabilities of KMail regarding filtering. There is the Sieve standard which could be a good orientation for improvements in KMail. It's just that the development capacity is limited and the main focus is on the groupware features at the moment.
Comment 3 Jonny Collins 2007-08-10 14:06:17 UTC
I agree with the point about logical operators. At the moment, there is only the option to match any of the rules, or all of the rules.
Perhaps a suitable solution might be to add a combo box to the beginning of each rule, so we can apply and/or to each rule individually?
Comment 4 Maciej Pilichowski 2007-10-02 13:23:38 UTC
Andreas, about erasing, true, but there should be small "erase" buttons (wish of course).
Comment 5 Björn Ruberg 2009-12-20 13:39:43 UTC
I see two wishes in this: Add a small delete button for every filter rule or filter action - and increase the limit of rules and actions. Good for a junior
Comment 6 Björn Ruberg 2009-12-20 13:42:50 UTC
*** Bug 56875 has been marked as a duplicate of this bug. ***
Comment 7 François Rey 2010-04-08 11:17:42 UTC
Deleting a filter by emptying each of its field is a really convoluted way of doing things. And if one hopes to remove a filter by clicking on it and pressing "-Fewer", you end up with the last filter being deleted and not the one you were on. The whole process for deleting is so convoluted that it really deserve the status of a bug. Calling it a wish is just an insult to users who have to deal with the bad design of this screen.

This entry should be split in to entries:
1: BUG: implement filter deletion properly in current screen.
   I'd create this entry if I were sure it wouldn't end up being
   tagged as duplicate wish
2: WISH: remove limits, and/or, etc.
   What this entry is already

I don't think groupware features should not take precedence over BUG #1 which is a real issue for managing a large flow of mail items (mailing lists, ads, spam, etc.).
Moreover groupware only means an increase flow of items, so wouldn't you need better filtering for groupware so that one can easily sort mail/tasks/calendar/contacts between groups/projects/whatever?

So please don't neglect filtering. At least make it easier to remove/move items in present screen while you sort out a larger redesign plan that may take years before it gets released.

Thanks!
Comment 8 Laurent Montel 2011-10-07 16:02:45 UTC
I agree with this wish will look at it.
Comment 9 Christophe Giboudeaux 2011-10-07 16:17:24 UTC
let's reassign then
Comment 10 Laurent Montel 2011-10-10 07:42:03 UTC
Git commit a93c696691fa955530770a3defc3e5bb795cead2 by Montel Laurent.
Committed on 10/10/2011 at 09:41.
Pushed by mlaurent into branch 'master'.

Fix Bug 94062 - kmail: very limited filter capabilities, for example can not remove second filter rule

FIXED-IN: 4.8
BUG: 94062

M  +73   -21   libkdepim/kwidgetlister.cpp
M  +9    -0    libkdepim/kwidgetlister.h
M  +107  -18   mailcommon/filteractionwidget.cpp
M  +13   -2    mailcommon/filteractionwidget.h

http://commits.kde.org/kdepim/a93c696691fa955530770a3defc3e5bb795cead2
Comment 11 Laurent Montel 2011-10-10 07:42:43 UTC
I improve delete/add rules in kmfilterdialog in 4.8