Bug 93517 - kghostview is killed by kernel because out of memory condition
Summary: kghostview is killed by kernel because out of memory condition
Status: RESOLVED WORKSFORME
Alias: None
Product: kghostview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Luís Pedro Coelho
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-18 18:19 UTC by Peter Volkov
Modified: 2004-11-22 19:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Volkov 2004-11-18 18:19:59 UTC
Version:           0.3.1 (using KDE 3.3.1, Gentoo)
Compiler:          gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)
OS:                Linux (i686) release 2.4.26-gentoo-r9

Hello. I have a problem.

Try to open this document to reproduce:
http://www.netup.ru/download/Russian_1_9.pdf

Sorry. I'm not a developer, so I have no debugger information.

BTW, xpdf opens this document without problems.
Comment 1 Albert Astals Cid 2004-11-20 21:37:33 UTC
Strange, it works here. Are you building kpdf with agressive compiling optimizations?
Comment 2 Peter Volkov 2004-11-21 07:42:47 UTC
Oh. Sorry. :(

The problem is with embeded in konqueror pdf viewer.

I thought kpdf and embeded viewer are the same (uses the same libraries to render picture). But now I see it's not. Sorry again. I have to double check in future...

Should I repost bug concerning konqueror pdf viewer plugin? Where?
Comment 3 jos poortvliet 2004-11-21 10:16:34 UTC
can't reproduce this problem. debian/unstable, kde 3.3.1. works fine.
Comment 4 Albert Astals Cid 2004-11-21 14:52:49 UTC
Both kpdf and kghostview can be embedded into konqueror to see a pdf, to see which one are you using open the document embedded in konqueror, if the thumbnails have a checkbox under them it is KGhostview, if they do not have a checkbox it is kpdf.
Comment 5 Peter Volkov 2004-11-22 12:29:49 UTC
Thank you, for your attention.

Now I know. It is kghostview's emebeded viewer. So I think the problem is with ghostscript-afpl-8.14-r1 I have installed now. The problem is with option -dMaxBitmap=1000000. Seem it is too big. But I think I should report about it somewhere else.
Comment 6 Albert Astals Cid 2004-11-22 12:40:30 UTC
Reassigning to kghostview (the user made an error when selecting the pdf viewer he was using)
Comment 7 Albert Astals Cid 2004-11-22 12:41:04 UTC
Summary is wrong now ;D
Comment 8 Peter Volkov 2004-11-22 19:42:47 UTC
I think kde developers are not responsible for afpl's ghostscript bugs. So it's time to close.:)

Thank everyone very much for attention.