Bug 93387 - knotify do not work without arts, or lets me avoid arts daemon.
Summary: knotify do not work without arts, or lets me avoid arts daemon.
Status: RESOLVED DUPLICATE of bug 99246
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: knotify (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Carsten Pfeiffer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-16 19:37 UTC by Peter Volkov
Modified: 2007-08-03 00:33 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Volkov 2004-11-16 19:37:38 UTC
Version:           ��� (using KDE 3.3.1, Gentoo)
Compiler:          gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)
OS:                Linux (i686) release 2.4.26-gentoo-r9

Hello.

There is a possibility to compile kde without arts. I would like to have possibility to play kde system sounds through alsa (with alsa plugin kmix) by specifying external player facility.

External player can be simple bash script like this:

#!/bin/bash 
 if [ "${1: -4}" = ".mp3" ] 
 then 
    mpg321 $1    
 elif [ "${1: -4}" = ".wav" ]    
 then 
    aplay $1 
 elif [ "${1: -4}" = ".ogg" ] 
 then 
     ogg123 $1 
 fi

Summarizing. I want to avoid arts on my system.

P.S. Now there is a problem, I've told about in this thread:
http://forums.gentoo.org/viewtopic.php?p=1770293

Thank you very much,
____________
Peter.
Comment 1 C. Dominik Bódi 2005-02-25 23:49:58 UTC
An external player can be used for knotify. The appropriate option can be set in the knotify control center module. This works for me with artds not running.
I use alsaplayer as external player, with default user interface set to "text" in ~/.alsaplayer/config (if you haven't got that file, just run alsaplayer once manually, it will be created).

I don't know what will happen if you compile kde without arts, but if arts is compiled in you can use that option and artsd will not be running.

The only problem I have is that playing sounds in quick succession does not really work. It seems knotify won't spawn more than one instance of alsaplayer. If you use dmix that would be no problem at all. Therefore if sounds get played in quick succession, sounds after the first one won't get played. Using a script to detach the external player using the "&" symbol could probably work around that.

Comment 2 Peter Volkov 2005-02-26 09:31:31 UTC
Yes. The problem with plaing sounds in a quick succession exists. But I think this is the second step to avoid arts.

First step, that exhibits the second and other problems, is to remove arts completely from kde, and mix all using with alsa's kmix plugin. The problem is that when I do not compile arts and so kdelibs and others with arts, then sound system do not work at all. I can hear no sound even with external player specified!

I don't think the external player is a good idea, because it introduce some delays in plaing of all sounds. Of course direct usage of alsa's API is better solution. But I think this is(?) a future. In this with report I just wanted to attract developers attention to the problem: compilaion of the whole sytem without arts make kde completely silent...

May be it was better to mark this problem as a bug. I don't know.
Comment 3 Mario Tanev 2005-08-25 22:44:17 UTC
This bug is a duplicate of:

http://bugs.kde.org/show_bug.cgi?id=99246

Please vote there.
Comment 4 Pino Toscano 2007-08-03 00:33:00 UTC

*** This bug has been marked as a duplicate of 99246 ***