Bug 93379 - Suppressions directory
Summary: Suppressions directory
Status: RESOLVED DUPLICATE of bug 93376
Alias: None
Product: valgrind
Classification: Unclassified
Component: general (show other bugs)
Version: 2.3 CVS
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Julian Seward
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-16 18:28 UTC by Andrés Roldán
Modified: 2004-11-16 19:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrés Roldán 2004-11-16 18:28:27 UTC
It would be great if valgrind provided a directory (say /usr/lib/valgrind/supp.
d/) where specific programs could put arbitrarily suppressions files for their 
execution and valgrind could interpret and concatenate the files stored there. A 
good example is Python2.{3,4} which provides a valgrind suppression file and it 
needs to be added by the user or the OS packager in a distribution-independent 
suppression file.

It's just a thought and therefore marked as "wishlist".

Thanks.
Comment 1 Tom Hughes 2004-11-16 19:40:50 UTC

*** This bug has been marked as a duplicate of 93376 ***