Bug 93277 - kcontrol: WARNING: No K menu group with X-KDE-BaseGroup=settings found ! Defaulting to Settings/
Summary: kcontrol: WARNING: No K menu group with X-KDE-BaseGroup=settings found ! Defa...
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: ksycoca (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-14 20:56 UTC by Fabio Erculiani
Modified: 2012-02-05 21:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Erculiani 2004-11-14 20:56:29 UTC
Version:           3.3.x (using KDE KDE 3.3.0)
Installed from:    Gentoo Packages
Compiler:          gcc-3.3.4 CFLAGS="-march=i386 -Os"
OS:                Linux

I was including KDE 3.3.1 (and 3.3.0 before 3.3.1 shows up) in my LiveCD (Gentoo RR4 LiveCD 2.0). Everything emerged fine, no problems at all. So i started to make the ISO image, after this easy step, now I had to test KDE on my CD. X started and kde 3.3 too. I didn't know why kicker and K menu were so ugly until I've started kcontrol. No items at all. After some investigation, I've discovered that the problem was in kbuildsycoca, that  if running from a CD, cretes some problems.

Kcontrol reported this if started from a shell:
 * kcontrol: WARNING: No K menu group with X-KDE-BaseGroup=settings found ! Defaulting to Settings/

If I copy ksycoca and ksycocastamp from my HD to the LiveCD directory (/var/tmp/kdecache-user/ that is rw), kcontrol works great.

KDE 3.2.3 doesn't have this bug.
KDE 3.3.0 and 3.3.1 are affected.

Anyone can help me?
Comment 1 Waldo Bastian 2005-01-06 16:15:32 UTC
I think this got fixed with the following patch to kdelibs/kdecore/kconfigbackend.cpp:

--- kconfigbackend.cpp  27 Sep 2004 22:11:36 -0000      1.99
+++ kconfigbackend.cpp  27 Dec 2004 10:27:30 -0000      1.100
@@ -448,7 +448,7 @@ void KConfigINIBackEnd::parseSingleConfi
    map = ( const char* ) mmap(0, rFile.size(), PROT_READ, MAP_PRIVATE,
                                           rFile.handle(), 0);

-   if (map)
+   if ( map != MAP_FAILED )
    {
       s = (const char*) map;
       eof = s + rFile.size();

Please reopen this bugreport if the problem persists after applying this patch.
Comment 2 Matěj Laitl 2012-02-05 21:18:17 UTC
*** Bug 232976 has been marked as a duplicate of this bug. ***