Bug 92878 - Slowdown and crash after attempting to send message with large attachments
Summary: Slowdown and crash after attempting to send message with large attachments
Status: RESOLVED DUPLICATE of bug 59069
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-07 22:25 UTC by Tristan Miller
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tristan Miller 2004-11-07 22:25:22 UTC
Version:            (using KDE KDE 3.3.1)
Installed from:    SuSE RPMs

I'm using KMail with a local SMTP server (postfix 2.2_20040616).

I created a new e-mail message and attached two mp3 files of about 5 MB in size, resulting in a message whose encoded size was about 14 MB.  KMail began slowing down significantly as I was selecting the files, and by the time I clicked on the send button, performance was very poor.  The message window did not disappear until about a minute after I had hit the send button.  Shortly thereafter, I received the following error dialog:

Sending failed:
Sendmail exited abnormally.
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:
Sendmail

Since KMail was significantly degrading system performance, I tried to close it, and KMail crashed with the following backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 2036)]
[KCrash handler]
#4  0x42463cc1 in kill () from /lib/libc.so.6
#5  0x42303011 in pthread_kill () from /lib/libpthread.so.0
#6  0x4230338b in raise () from /lib/libpthread.so.0
#7  0x42463a54 in raise () from /lib/libc.so.6
#8  0x42464fcc in abort () from /lib/libc.so.6
#9  0x423e8175 in __cxxabiv1::__terminate () from /usr/lib/libstdc++.so.5
#10 0x423e81b2 in std::terminate () from /usr/lib/libstdc++.so.5
#11 0x423e82f2 in __cxa_throw () from /usr/lib/libstdc++.so.5
#12 0x423e852f in operator new () from /usr/lib/libstdc++.so.5
#13 0x423e85fd in operator new[] () from /usr/lib/libstdc++.so.5
#14 0x402595e1 in QValueVectorPrivate<KMMessage*>::QValueVectorPrivate ()
   from /opt/kde3/lib/libkmailprivate.so.0
#15 0x40258f3d in QValueVector<KMMessage*>::detachInternal ()
   from /opt/kde3/lib/libkmailprivate.so.0
#16 0x40258668 in QValueVector<KMMessage*>::front ()
   from /opt/kde3/lib/libkmailprivate.so.0
#17 0x402575cd in QValueVector<KMMessage*>::first ()
   from /opt/kde3/lib/libkmailprivate.so.0
#18 0x4023e793 in KMComposeWin::deadLetter ()
   from /opt/kde3/lib/libkmailprivate.so.0
#19 0x4032423a in KMKernel::dumpDeadLetters ()
   from /opt/kde3/lib/libkmailprivate.so.0
#20 0x40326160 in KMKernel::qt_invoke ()
   from /opt/kde3/lib/libkmailprivate.so.0
#21 0x41c2bf1b in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x41c2bce4 in QObject::activate_signal ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#23 0x41f73189 in QTimer::timeout () from /usr/lib/qt3/lib/libqt-mt.so.3
#24 0x41c4e7b3 in QTimer::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#25 0x41bc9eb6 in QApplication::internalNotify ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#26 0x41bc91de in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#27 0x4174020e in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#28 0x41bb6543 in QEventLoop::activateTimers ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#29 0x41b6eb57 in QEventLoop::processEvents ()
   from /usr/lib/qt3/lib/libqt-mt.so.3
#30 0x41bdcbc0 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#31 0x41bdcab6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#32 0x41bca14f in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#33 0x0804a34f in main ()
Comment 1 Till Adam 2004-12-14 00:07:40 UTC

*** This bug has been marked as a duplicate of 59069 ***