Bug 92225 - rewrite filter on outgoing mail has no effect
Summary: rewrite filter on outgoing mail has no effect
Status: RESOLVED DUPLICATE of bug 48938
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-27 22:19 UTC by Melchior Franz
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Melchior Franz 2004-10-27 22:19:46 UTC
Version:           1.7.50  (CVS/HEAD as of today, 2004/10/27) (using KDE Devel)
Installed from:    Compiled sources
Compiler:          gcc (GCC) 3.3.1 (SuSE Linux) 
OS:                Linux

Rewrite rules on outgoing messages don't seem to do anything. As a
test case, I defined a simple rule. And sent a message like this:

Subject: XYZ A
Date: Wed, 27 Oct 2004 22:10:38 +0200
From: m@server.lan
To: m@server.lan


 
This appeared in the filter log, which looks quite promising:

------------------------------
[22:17:11] Evaluating filter rules: (match all of the following)
	"Subject" <contains> "XYZ"
[22:17:11] 1 = "Subject" <contains> "XYZ" (XYZ A)
[22:17:11] Filter rules have matched.
[22:17:11] Applying filter action: Rewrite Header "Subject	A	B"
------------------------------


But the message came back as sent. The subject was still "XYZ A".
Other actions (play sound) did work. None of the rewrite actions
in this and other tests did work.
Comment 1 Andreas Gungl 2004-10-27 22:33:54 UTC
On Mittwoch 27 Oktober 2004 22:19, Melchior Franz wrote:
> But the message came back as sent. The subject was still "XYZ A".
> Other actions (play sound) did work. None of the rewrite actions
> in this and other tests did work.

KMail works as intended. The outgoing messages are filtered _after_ having 
been sent, so it's no surprise what you've found.

However I'm not sure, how to handle this report. Should we convert it to an 
appropriate wish? Should we close (and how)?

Any comments from the core developers on that special issue?

Comment 2 Melchior Franz 2004-10-27 22:53:32 UTC
> KMail works as intended. The outgoing messages are filtered _after_ having
> been sent, so it's no surprise what you've found. 
 
Oh. This is a (bad) surprise.

Some messages sent to me have tags added to the subject, for example "[SPEWS]" (denotes messages from spews listed sources; http://www.spews.org/).
I *do* want the tags there, so incoming filters aren't of any help. But, of course, when I'm replying to such a message, I want the "[SPEWS]" removed.

So, yes, I'd like this report converted to a wishlist item. (The current filter on sent mail is of no use for me.)
Comment 3 Ingo Klöcker 2004-11-08 22:07:50 UTC

*** This bug has been marked as a duplicate of 48938 ***