Bug 92105 - programs maximize under child panel when it is located over xinerama dead space
Summary: programs maximize under child panel when it is located over xinerama dead space
Status: RESOLVED DUPLICATE of bug 79842
Alias: None
Product: kicker
Classification: Plasma
Component: multiscreen (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Aaron J. Seigo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-26 00:25 UTC by Ian Monroe
Modified: 2005-05-27 20:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
shows the kicker overlapping a maximized application (38.02 KB, image/jpeg)
2004-10-26 00:29 UTC, Ian Monroe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ian Monroe 2004-10-26 00:25:38 UTC
Version:            (using KDE KDE 3.3.1)
Installed from:    Gentoo Packages
OS:                Linux

I have two monitors, the left monitor at 1280x1024 and the right monitor at 1024x768. I like having all the various kicker bars in the smaller right monitor. However, the kicker at the bottom, the one above the 'dead space' while still remaining above the applications is not counted when apps are maximized, so the bottom of the app is covered by the kicker bar.

I'll post a screen shot that shows this clearly.
Comment 1 Ian Monroe 2004-10-26 00:29:38 UTC
Created attachment 8036 [details]
shows the kicker overlapping a maximized application

I cropped out most of the left monitor and reduced resolution of the screen
shot. Saturn denotes the beginning of the left monitor. 

The yellow arrow points to where you can see the maximized konsole's buttom
toolbar is being covered by the kicker. You can also see the dead space below
the 'problem' panel. Note it works fine with the other panels.
Comment 2 Aaron J. Seigo 2004-11-03 19:43:19 UTC
this is a dupe of a bug in the kwin multihead component, so i'm marking it as such.

Lubos: is this a kwin issue or a kicker issue? if it is a kicker issue, could you reassing this bug back to kicker? thanks.

*** This bug has been marked as a duplicate of 79842 ***
Comment 3 Luke 2005-05-27 02:49:56 UTC
This problem is not fixed in KDE 3.3.2 or KDE 3.4, so perhaps it is not really a duplicate of bug 79842 which is apparently fixed?

See bug 94470 for a later report of this same problem.
Comment 4 Aaron J. Seigo 2005-05-27 04:04:53 UTC
@Luke: this was certainly fixed for xinerama in 3.4. i could duplicate it before quite easily, and fixed it in 3.4.

perhaps your bug is something different than this one?
Comment 5 Ian Monroe 2005-05-27 08:16:28 UTC
Bug is still there for me. 

I've worked around it by rearranging my panels, I actual prefer the current "functionality" now. :)
Comment 6 Ian Monroe 2005-05-27 08:17:55 UTC
I should mention that I use NVidia Twinview, that might be relevant. I'm on KDE SVN from Wednesday.
Comment 7 Aaron J. Seigo 2005-05-27 20:07:57 UTC
i just took a look at the screenshot again.. this isn't the bug i was was thinking of... if you are still seeing this issue, it would be a kwin problem in any case