Bug 92006 - messages becoming 'unknown' when clicking
Summary: messages becoming 'unknown' when clicking
Status: RESOLVED DUPLICATE of bug 121272
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.7.50
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-24 15:45 UTC by Edwin Schepers
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edwin Schepers 2004-10-24 15:45:42 UTC
Version:           1.7.50 (using KDE 3.3.89 (CVS >= 20040820), compiled sources)
Compiler:          gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1)
OS:                Linux (i686) release 2.4.22-1.2115.nptl

Hi,
When I click on a message with date >2-jan-204 and <7-march-2004, the message is mangled (like :
<source>
atigheid.</font></td>
                          </tr>
                          <tr valign="top"> 
                            <td width="87" style="padding-top: 10px;"><font face="Arial, Helvetica, sans-serif" size="2"><b>UITSPRAAK:</b></font></td>
                            <td style="padding-top: 10px; padding-right: 5px;"><font face="Arial, Helvetica, sans-serif" size="2">[a-no-ma-LIE]<P><I>Ingezonden door Willy van de
Riet.</I></font></td>
                          </tr>
                          
                          <tr valign="top"> 
                            <td width="87" style="padding-top: 10px;"><font face="Arial, Helvetica, sans-serif" size="2"><b>WOORDFEIT:</b></font></td>
                            <td style="padding-top: 10px; padding-right: 5px;"><font face="Arial, Helvetica, sans-serif" size="2">Het Nederlands heeft <i>anomalie</i> in de
negentiende eeuw aan het Frans ontleend. Het gaat terug op het Griekse
<i>anomalia</i> 'ongelijkheid, onregelmatigheid'. Het bijbehorende bijvoeglijk
naamwoord <i>anomalos</i> bestaat uit de ontkenning <i>a(n)-</i> en <i>homalos</i>
'gelij
.....
<source>
And subject is "no subject" and date/sender is unknown.
I guess I'll have to delete the .index, but maybe someone is interested in how it happens. I can at least reproduce.

This is printed when I click on a message :
[edwin@CC90001-A distributies]$ kmail: (138006498, last 138005642)  , readyToShow true
kmail: parseMsg(KMMessage* aMsg == aMsg )
kmail: + Text/Plain
kmail:       Inserting one item into MimePartTree
kmail:                 Content-Type: Text/Plain
kmail: partNode::findType() is looking at Text/Plain
kmail: final presence: ''
kmail: ObjectTreeParser::parseObjectTree( node OK, showOnlyOneMimePart: FALSE )
kmail: Unknown codec "7bit" requested!
kmail: Unknown codec "7bit" requested!
kmail: KMReaderWin  -  finished parsing and displaying of message.
Comment 1 Thomas McGuire 2007-05-07 17:18:22 UTC

*** This bug has been marked as a duplicate of 121272 ***