Bug 91929 - kdevelop crash on startup after embedded vim editor selected
Summary: kdevelop crash on startup after embedded vim editor selected
Alias: None
Product: kdevelop
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash
Target Milestone: ---
Assignee: kdevelop-bugs-null
: 98962 (view as bug list)
Depends on:
Reported: 2004-10-22 23:36 UTC by Michael Wynne
Modified: 2005-02-09 20:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Michael Wynne 2004-10-22 23:36:28 UTC
Version:           3.3.1 (using KDE KDE 3.3.0)
Installed from:    Debian testing/unstable Packages
Compiler:          gcc version 3.3.5 (Debian 1:3.3.5-1) 
OS:                Linux

Consistantly crashes on startup after embedded vim component is selected in Kdevelop settings. Also affects Kdevelop 3.1.0. Tried different versions of vim; gvim-gtk 6.3.025, kvim 6.3.025, 6.3.013, etc. Also tried compiling and installing most recent version of vimpart. This problem renders Kdevelop unusable as the user cannot get back in to change the editor component. 

Results in the following backtrace:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 5969)]
[New Thread 32769 (LWP 5970)]
[New Thread 16386 (LWP 5971)]
[KCrash handler]
#6  0x42819a6d in Vim::Document::activeWidget ()
   from /usr/lib/kde3/libvimpart.so.0
#7  0x40692ea2 in KParts::ReadOnlyPart::openURL ()
   from /usr/lib/libkparts.so.2
#8  0x08075f56 in PartController::editDocumentInternal ()
#9  0x08093e4c in ProjectSession::loadDocument ()
#10 0x08091b68 in ProjectSession::qt_invoke ()
#11 0x4124952c in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#12 0x4158708a in QSignal::signal () from /usr/lib/libqt-mt.so.3
#13 0x412636ed in QSignal::activate () from /usr/lib/libqt-mt.so.3
#14 0x4126aed3 in QSingleShotTimer::event () from /usr/lib/libqt-mt.so.3
#15 0x411ecbcf in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#16 0x411ec1ce in QApplication::notify () from /usr/lib/libqt-mt.so.3
#17 0x40d6f1a3 in KApplication::notify () from /usr/lib/libkdecore.so.4
#18 0x411dc405 in QEventLoop::activateTimers () from /usr/lib/libqt-mt.so.3
#19 0x41195c4b in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#20 0x411fef28 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#21 0x411fedd8 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#22 0x411ece21 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#23 0x080a24aa in main ()
Comment 1 Michael Wynne 2004-10-22 23:56:50 UTC
Kdevelop version is actually 3.1.1 compiled on Debian GNU/Linux 3.1 kernel version 2.4.27-1-k7. Same crash occurs with the the "unstable" Debian Kdevelop 3.1.0 package.  
Comment 2 Michael Wynne 2004-10-23 01:40:08 UTC
Deleting the kdevses file allows me to open Kdevelop and change editors. Though trying to open a file while the vim editor is still selected causes a crash. This appears very similar to bug 80427, only more severe.  
Comment 3 Jens Dagerbo 2004-10-23 19:49:58 UTC
The answer to bug 80427 applies here as well. We don't maintain vim-part, and neither do the authors of it. It's dead, give up on it. (I hear yzis is quite good though.)

Comment 4 Alexander Dymo 2004-10-24 00:04:12 UTC
Yzis: www.yzis.org - a better choice.
Comment 5 Jens Dagerbo 2005-02-09 20:10:10 UTC
*** Bug 98962 has been marked as a duplicate of this bug. ***