Bug 91881 - Take multiple screenshots at certain intervals
Summary: Take multiple screenshots at certain intervals
Status: RESOLVED UNMAINTAINED
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist with 31 votes (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
: 271129 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-10-22 09:48 UTC by Peter Reinhart
Modified: 2018-09-04 04:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Reinhart 2004-10-22 09:48:40 UTC
Version:            (using KDE KDE 3.3.0)
Installed from:    SuSE RPMs

I recently needed to take a number of screenshots of a jump&run game called "SuperTux". It was a time-consuming process as I started ksnapshot and then knew that I had a number of seconds to actually get something interesting for the picture. Then, I paused the game, had a quick look at the screenshot, noticed that it was not so good, launched another screenshot-taking process... after all, I repeated this for some 30 times.

During the process, I greatly missed a feature that I would like to propose: To take a number screenshots in fixed intervals, such as one screenshot in 10 seconds. I would just have played the game for, let's say, half an hour and kuickshot would have taken some 100+ screenshots of it. Enough of a choice to find a good one.

If this feature is introduced, I suggest to have various variables for the filename format, e.g. a number n that counts up or the current time.
Comment 1 Brad Hards 2005-01-30 01:31:13 UTC
Would it be enough to have a DCOP interface that could say snapShot(filename), so you can write a simple script that can provide whatever name you like.
Comment 2 Peter Reinhart 2005-01-30 09:55:38 UTC
Well, that would at least be a start. As a non-programmer however, I wouldn't be able to write such a script. ;-)
Comment 3 Philippe Rigault 2005-03-05 20:30:03 UTC
Things could get a little complicated in the case of 'window under cursor', once the window performs some action:
- resize/move are simple, it should be easy to track it and still snapshot the correct thing.
- iconify or move-to-desktop are problematic, there is nothing to snapshot any more.

> Would it be enough to have a DCOP interface that could say snapShot(filename)

One could also do snapShotnext(filename) using Ksnapshot::autoincFilename()function --broken right now, see http://bugs.kde.org/show_bug.cgi?id=94726 -- to perform a series of saves in different filenames.
Comment 4 Christoph Feck 2011-04-23 18:42:48 UTC
*** Bug 271129 has been marked as a duplicate of this bug. ***
Comment 5 smihael 2017-01-08 19:37:11 UTC
Can we reopen that for Spectacle? It would be a nice feature (even though it is done easily with some bash scripting)
Comment 6 Christoph Feck 2017-01-10 00:01:46 UTC
See bug 366598. I am sure a screen cast recorder would allow you to specify the capture speed (FPS).
Comment 7 Andrew Crouthamel 2018-09-04 04:21:25 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years and I will be closing this bug. Spectacle is the replacement for ksnapshot now. Please test again and file a new bug for Spectacle if you still have issues. Thank you!