Bug 90043 - GUI should be responsive when running filters
Summary: GUI should be responsive when running filters
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: 1.7
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-22 19:45 UTC by Tom
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom 2004-09-22 19:45:55 UTC
Version:           1.7 (using KDE 3.3.0, Gentoo)
Compiler:          gcc version 3.4.1 20040803 (Gentoo Linux 3.4.1-r2, ssp-3.4-2, pie-8.7.6.5)
OS:                Linux (x86_64) release 2.6.8.1-ck5-kraxel

When applying filters to a large number of messages, the GUI isn't redrawn.  This, in combination with http://bugs.kde.org/show_bug.cgi?id=90042 and slow spam filters, means that the GUI can become unresponsive for minutes at a time.  These things ought to be done in a seperate thread, or else the GUI should still be periodicly updated.  Ideally there would be a dialog with a progress bar and a cancel button during large or slow runs of apply filters.
Comment 1 Stephan Binner 2004-09-25 00:52:23 UTC

*** This bug has been marked as a duplicate of 41514 ***