Bug 89885 - does not support sending a complete e-mail from a file via shell
Summary: does not support sending a complete e-mail from a file via shell
Status: RESOLVED DUPLICATE of bug 89882
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-20 17:09 UTC by Martin Steigerwald
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Steigerwald 2004-09-20 17:09:29 UTC
Version:            (using KDE KDE 3.3.0)
Installed from:    Debian testing/unstable Packages
OS:                Linux

Hello,

today I wanted to use the Debian reportbug program for the first time. Since I use KMail as my regular mailer I wanted it to use KMail instead of its own mailer or mutt for sending the bug report.

This cannot work. reportbug generates a mail file including headers and body of the email that can be send via "mutt -H" for example. mutt takes headers and body of the e-mail directly from the mail file.

From "kmail --help" I thought I could use "kmail --msg" for that purpose, but this doesn't work as KMail then puts the whole mail file including the header in the body of the new mail to be send. This is as it is documented when I try "man kmail". 

There does not seem to be an option to send a mail from a file and have KMail takes the headers and the body of the email out of the file. This essentially renders KMail unusable from applications that generate a complete e-mail in a file and want to send it via an external mail user agent.

Thus I would like an option to have KMail send a mail from a file which contains headers and body of the mail. A KMail compose window with all the headers and the body, well even attachments if any, should pop up and let me edit the e-mail before I sent it out. 

Regards,
Martin
Comment 1 Tom Albers 2004-09-20 17:14:52 UTC

*** This bug has been marked as a duplicate of 89882 ***