Bug 89166 - kmail hangs when filtering many messages
Summary: kmail hangs when filtering many messages
Status: RESOLVED DUPLICATE of bug 41514
Alias: None
Product: kmail
Classification: Unclassified
Component: filtering (show other bugs)
Version: 1.7
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-09 14:50 UTC by Kevin Goeser
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Goeser 2004-09-09 14:50:32 UTC
Version:           1.7 (using KDE 3.3.0, Gentoo)
Compiler:          gcc version 3.3.3 20040412 (Gentoo Linux 3.3.3-r6, ssp-3.3.2-2, pie-8.7.6)
OS:                Linux (i686) release 2.6.8-gentoo-r3

I filtered something about 150 mails at once, having clamav-, bogofilter and a filter moving mailinglist-mails to a different folder.

KMail was hanging during the filter process, what is quite bad, but there are some wishes about that. For me, KMail was completely hanging. So no cpu usage, and still not reacting for ages. I finally killed it and found it had totally messed up my mails :( The mail overview looked just like normal. Opening any email, it just showed up being empty and the subject was renamed to 'no subject'.

I'm using it inside of kontact.
Comment 1 Kevin Goeser 2004-09-09 15:03:28 UTC
kmail just crashed again and did the same mess. I removed now all filters :(
Comment 2 Kevin Goeser 2004-09-09 15:42:09 UTC
I just tried it with the same filters (and the same mails), except using spamassassin instead of bogofilter. KMail hangs during the filter process, but works again as soon the filter process is finished.

# bogofilter --version
bogofilter version 0.92.0
    Database: BerkeleyDB (4.1.25)
Comment 3 Till Adam 2004-10-03 23:21:47 UTC

*** This bug has been marked as a duplicate of 41514 ***