Bug 88484 - New messages aren't displayed in the folder list
Summary: New messages aren't displayed in the folder list
Status: RESOLVED WORKSFORME
Alias: None
Product: kmail
Classification: Applications
Component: general (show other bugs)
Version: 1.7
Platform: unspecified Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-31 00:45 UTC by ieure
Modified: 2007-09-14 12:17 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of the issue (245.01 KB, image/jpeg)
2004-08-31 21:23 UTC, ieure
Details
My IMAP folder structure. (43.34 KB, image/png)
2004-09-01 14:13 UTC, Jeroen Wijnhout
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ieure 2004-08-31 00:45:41 UTC
Version:           1.7 (using KDE 3.3.0,  (3.1))
Compiler:          gcc version 3.3.4 (Debian 1:3.3.4-9)
OS:                Linux (i686) release 2.6.7-1-686

After checking mail in an IMAP account, the new/unread message count in the tray icon appears to be correct, but the folders do not have the new/unread message count next to them in the folder list.

The only way to determine which folders contain the new mail is by right-clicking the systray icon and using the 'New Messages In' sub-menu. Which, as I reported in #88483, is buggy as well.
Comment 1 Andreas Gungl 2004-08-31 08:40:39 UTC
Am Dienstag, 31. August 2004 00:45 schrieb ieure@debian.org:
> After checking mail in an IMAP account, the new/unread message count in
> the tray icon appears to be correct, but the folders do not have the
> new/unread message count next to them in the folder list.

Works fine here. Can you let us kno wsome more details? Which columns are 
visible / enabled in the folder view? Are the folders containing new 
messages in bold font? What happens if you enter a folder containing more 
than one new message?

Comment 2 Carsten Burghardt 2004-08-31 10:32:45 UTC
Perhaps you enabled the unread column but the size of the column is too
small so that you don't see it? Right click on the header (or use the View
menu) to check if the column is active.

Comment 3 ieure 2004-08-31 21:20:14 UTC
Nope. I only have the folder name displayed in the folder list. Nothing is cut off or obscured in any way.

Behavior isn't consistent. After checking mail, some folders display the correct status, and others don't.

Folders which have new/unread mail in them /should be/ displayed in bold, with a new message count in parentheses. Some do display like this, but others (which do have unread mail in them) do not; they display like a folder with no new messages. Not bold, with no message count.

Opening one of these folders shows the new messages in the message list, and it's status in the folder list is updated, e.g. it appears correctly. There's just no way to know if the folder has new messages without opening every one, or checking with the tray icon.
Comment 4 ieure 2004-08-31 21:23:51 UTC
Created attachment 7374 [details]
Screenshot of the issue

Note that the Debian -> KDE folder does not appear to have any new messages in
it in the folder list, but you can see that one new message is shown in that
folder in the systray.
Comment 5 ieure 2004-08-31 21:30:16 UTC
Ok, more data.

It only happens to sub-folders whose parents are collapsed at the time the mail check takes place.

So if I fold up the Debian tree and check mail, the status of the sub-folders (the Debian folder itself gets no mail, only it's subfolders) doesn't get updated. If I expand it and check mail again, the folders get their status updated correctly.
Comment 6 Christian Schuerer 2004-09-01 00:13:41 UTC
I've got the same problem (using Debian unstable). Even enabling the unread-column doesn't show proper count. For me it seems that this problem only occurs on folders containing messages which got moved by a filter action - but all my folders for mailing lists are sub-folders, so it could also be related as written in comment #5.
Comment 7 ieure 2004-09-01 00:26:17 UTC
I have no KMail filters set up at all, so that doesn't seem to be an issue.

I'm running Debian sarge, but KDE is installed from sid. This doesn't seem like a packaging issue, but I suppose it's possible.
Comment 8 ieure 2004-09-01 09:02:04 UTC
After some more experimenting, this seems to be a general issue with unexpanded folder trees not getting updated. It has nothing to do with IMAP, and can be reproduced locally.

1. Create two nested folders, if you don't already have some. E.g. 'Parent Folder' and 'Child Folder'.
2. Collapse that folder.
3. Select a message in a different folder.
4. Right-click the message in the message list, Mark Message -> Mark Message As New
5. Right-click the message in the message list, Move To -> Local Folders -> Parent Folder -> Child Folder

Observe that Parent Folder does not appear to contain new messages. Expand it to show Child Folder, and observe that it doesn't, either. Right-click the tray icon and observe that Child Folder is listed as having a new message.
Comment 9 Jeroen Wijnhout 2004-09-01 14:12:01 UTC
I have exactly the same problem (KDE_3_3_BRANCH from 31-8-2004). It only happens with collapsed folders. For me KDE 3.3.0 was ok, the problems started after I updated the branch on 31-8-2004.

I will attach a screeny with my folder structure. (I think this bug should be marked as confirmed, since three people report the same issue.)

best,
Jeroen
Comment 10 Jeroen Wijnhout 2004-09-01 14:13:41 UTC
Created attachment 7381 [details]
My IMAP folder structure.
Comment 11 Mathias Homann 2004-09-01 21:53:00 UTC
maybe related:

imap accounts with unread mail in subfolders used to show up in bold text in the folder list back in kmail 1.6, but not anymore in 1.7...
Comment 12 Till Adam 2004-09-05 12:45:30 UTC
Can you check if my commit of today resolves this issue, please?
Comment 13 Jeroen Wijnhout 2004-09-06 11:02:53 UTC
I tried, but (aside from KNotes compiler errors) I get:

gmake[3]: Entering directory `/scratch/forge/src/kde/kmail_temp/kdepim/l
ibkdepim'
source='kdepimwidgets.cpp' object='kdepimwidgets_la-kdepimwidgets.lo' li
btool=yes \
depfile='.deps/kdepimwidgets_la-kdepimwidgets.Plo' tmpdepfile='.deps/kde
pimwidgets_la-kdepimwidgets.TPlo' \
depmode=gcc3 /bin/bash ../admin/depcomp \
#>-     /bin/bash ../libtool --silent --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/scratch/opt/kde_3_3/include -I/scratch/lib/qt-3.3/include -I/usr/X11R6/include   -DQT_THREAD_SUPPORT  -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DQT_PLUGIN -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -c -o kdepimwidgets_la-kdepimwidgets.lo `test -f 'kdepimwidgets.cpp' || echo './'`kdepimwidgets.cpp
../admin/depcomp: line 60: -MT: command not found

I've seen this before, but I can not remember what the solution was. Line 60 in depcomp is
"$@" -MT "$object" -MD -MP -MF "$tmpdepfile"
So apparently "$@" is evaluated to "".

best,
Jeroen
Comment 14 Marcus Thiesen 2004-09-07 03:43:32 UTC
Same for me, but the problem only occurred after KMail crashed (some IMAP thing I couldn't reproduce). Since then, no folder shows the number of unread messages if it is not selected. If I select a folder, it will display the number of unread messages correctly. Going through the unread messages with "+" works, though.
Couldn't test the new version.
Comment 15 Jeroen Wijnhout 2004-09-07 11:18:06 UTC
I can confirm that the latest changes that made it into HEAD fix the problem (at least for me).

best,
Jeroen
Comment 16 Jeroen Wijnhout 2004-09-07 16:35:07 UTC
One small thing. When I get mail in the root folder (the "inbox") folder, it is marked in the folder list (you see "inbox(1)"). However the systray icon does not reflect this.

best,
Jeroen
Comment 17 Rich Birch 2005-03-24 00:26:12 UTC
Doesn't seem to be a issue for me.

Looks resolvable. Can someone else confirm?
Comment 18 Christian Schuerer 2005-03-24 11:54:53 UTC
This bug seems to be solved in KMail 1.8
Comment 19 ieure 2005-03-24 19:33:09 UTC
Same here, I haven't seen it since upgrading to KDE 3.4.0.