Bug 88390 - Drag and drop from konqueror to mozilla provides incorrect URL
Summary: Drag and drop from konqueror to mozilla provides incorrect URL
Status: RESOLVED FIXED
Alias: None
Product: kde
Classification: I don't know
Component: general (show other bugs)
Version: unspecified
Platform: RedHat Enterprise Linux Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-08-29 17:57 UTC by Wendell Nichols
Modified: 2005-02-25 15:21 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wendell Nichols 2004-08-29 17:57:49 UTC
Version:           3.2.2-4 (using KDE KDE 3.2.2)
Installed from:    RedHat RPMs
OS:                Linux

If I display a directory of images (jpegs) in konqueror and then drag one to an outgoing mozilla email, the url looks like:
file:/ostar/archive/wcn00/pipin/data/wcn00/Pictures/2004_07_27/110_1100_2.JPG

When I send this email mozilla complains that there was a problem with the attachment and fails to include it.  If I do this operation on windows it works (from explorer) and the url used is:
file://E:/ostar/archive/wcn00/pipin/data/wcn00/Pictures/2004_07_27/110_1100_2.JPG

It would appear that the problem is that it is not using a correct URL, ie file:/... is not right it should be file:///...

If you would preferr me to fix this and send in the source, drop me a note, but I'm pretty busy just now.
wcn

p.s.  I have not tested this with kde 3.3 because it's too risky to upgrade, and downgrading is a nightmare.  If it is fixed there please tell me and I may chance it.
Comment 1 Wilco Greven 2004-10-14 19:56:56 UTC
A solution could be to always use the 'correct' file:///... URL internally, and for URL's which the user sees, use the short file:/... form. This can be done by letting KURL::url always return the longer form, and KURL::prettyURL the shorter form.
Comment 2 Matt Rogers 2004-12-17 07:38:54 UTC
KDE 3.4 alpha 1 and later uses "file:///" everywhere now for local file: URLs
Please reopen if this is still a problem with KDE 3.4 alpha 1 or later
Comment 3 Adeodato Simó 2005-02-25 15:16:03 UTC
I suspect the answer will be 'no', but anyway I have to try: from what you recall from the fix, is it backportable? Not that I ask that it gets commited to KDE_3_3_BRANCH, but if I received some indications, I'd like to recollect myself the patches to include them in Debian's 3.3.2 packges.

Thanks.